Upstream information

CVE-2016-4622 at MITRE

Description

WebKit in Apple iOS before 9.3.3, Safari before 9.1.2, and tvOS before 9.2.2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-4589, CVE-2016-4623, and CVE-2016-4624.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.82
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • libwebkit2gtk3-lang >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Software Development Kit 12 SP2
  • webkit2gtk3-devel >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA webkit2gtk3-devel
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libwebkit2gtk3-lang >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libwebkit2gtk3-lang
openSUSE Leap 42.2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.6
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.6
  • libwebkit2gtk3-lang >= 2.12.5-1.6
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.6
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.6
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.6
Patchnames:
openSUSE Leap 42.2 GA libjavascriptcoregtk-4_0-18
openSUSE Tumbleweed
  • libjavascriptcoregtk-4_0-18 >= 2.14.2-2.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.14.2-2.1
  • libwebkit2gtk-4_0-37 >= 2.14.2-2.1
  • libwebkit2gtk-4_0-37-32bit >= 2.14.2-2.1
  • libwebkit2gtk3-lang >= 2.14.2-2.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.14.2-2.1
  • typelib-1_0-WebKit2-4_0 >= 2.14.2-2.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.14.2-2.1
  • webkit-jsc-4 >= 2.14.2-2.1
  • webkit2gtk-4_0-injected-bundles >= 2.14.2-2.1
  • webkit2gtk3-devel >= 2.14.2-2.1
  • webkit2gtk3-plugin-process-gtk2 >= 2.14.2-2.1
Patchnames:
openSUSE Tumbleweed GA libjavascriptcoregtk-4_0-18