Upstream information

CVE-2016-4477 at MITRE

Description

wpa_supplicant 0.4.0 through 2.5 does not reject \n and \r characters in passphrase parameters, which allows local users to trigger arbitrary library loading and consequently gain privileges, or cause a denial of service (daemon outage), via a crafted (1) SET, (2) SET_CRED, or (3) SET_NETWORK command.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.4 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 978175 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • wpa_supplicant >= 2.6-2.50
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA wpa_supplicant
openSUSE Leap 15.0
  • wpa_supplicant >= 2.6-lp150.2.13
Patchnames:
openSUSE Leap 15.0 GA wpa_supplicant
openSUSE Tumbleweed
  • wpa_supplicant >= 2.6-1.1
  • wpa_supplicant-gui >= 2.6-1.1
Patchnames:
openSUSE Tumbleweed GA wpa_supplicant


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Desktop 12 GA wpa_supplicant Affected
SUSE Linux Enterprise Desktop 12 SP1 wpa_supplicant Unsupported
SUSE Linux Enterprise Server 10 SP4 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP2 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP3 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Server 12 GA wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP1 wpa_supplicant Unsupported