Upstream information

CVE-2016-4439 at MITRE

Description

The esp_reg_write function in hw/scsi/esp.c in the 53C9X Fast SCSI Controller (FSC) support in QEMU does not properly check command buffer length, which allows local guest OS administrators to cause a denial of service (out-of-bounds write and QEMU process crash) or potentially execute arbitrary code on the QEMU host via unspecified vectors.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.64 3.51
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:H/Au:S/C:P/I:P/A:P
Access Vector Local Local
Access Complexity Low High
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.2
Vector AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required High
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 980711 [RESOLVED / FIXED], 980716 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • qemu >= 2.0.2-48.19.1
  • qemu-block-curl >= 2.0.2-48.19.1
  • qemu-ipxe >= 1.0.0-48.19.1
  • qemu-kvm >= 2.0.2-48.19.1
  • qemu-seabios >= 1.7.4-48.19.1
  • qemu-sgabios >= 8-48.19.1
  • qemu-tools >= 2.0.2-48.19.1
  • qemu-vgabios >= 1.7.4-48.19.1
  • qemu-x86 >= 2.0.2-48.19.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-924
SUSE Linux Enterprise Desktop 12 SP1
  • qemu >= 2.3.1-14.1
  • qemu-block-curl >= 2.3.1-14.1
  • qemu-ipxe >= 1.0.0-14.1
  • qemu-kvm >= 2.3.1-14.1
  • qemu-seabios >= 1.8.1-14.1
  • qemu-sgabios >= 8-14.1
  • qemu-tools >= 2.3.1-14.1
  • qemu-vgabios >= 1.8.1-14.1
  • qemu-x86 >= 2.3.1-14.1
  • xen >= 4.5.3_08-17.1
  • xen-kmp-default >= 4.5.3_08_k3.12.59_60.45-17.1
  • xen-libs >= 4.5.3_08-17.1
  • xen-libs-32bit >= 4.5.3_08-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1007
SUSE-SLE-DESKTOP-12-SP1-2016-1238
SUSE Linux Enterprise Desktop 12 SP2
  • qemu >= 2.6.1-27.15
  • qemu-block-curl >= 2.6.1-27.15
  • qemu-ipxe >= 1.0.0-27.15
  • qemu-kvm >= 2.6.1-27.15
  • qemu-seabios >= 1.9.1-27.15
  • qemu-sgabios >= 8-27.15
  • qemu-tools >= 2.6.1-27.15
  • qemu-vgabios >= 1.9.1-27.15
  • qemu-x86 >= 2.6.1-27.15
  • xen >= 4.7.0_12-23.4
  • xen-libs >= 4.7.0_12-23.4
  • xen-libs-32bit >= 4.7.0_12-23.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA qemu
SUSE Linux Enterprise Desktop 12 SP2 GA xen
SUSE Linux Enterprise Point of Sale 11 SP3
  • xen >= 4.2.5_21-27.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-libs >= 4.2.5_21-27.1
  • xen-tools-domU >= 4.2.5_21-27.1
Patchnames:
sleposp3-xen-12836
SUSE Linux Enterprise Server 11 SP2-LTSS
  • xen >= 4.1.6_08-29.1
  • xen-devel >= 4.1.6_08-29.1
  • xen-doc-html >= 4.1.6_08-29.1
  • xen-doc-pdf >= 4.1.6_08-29.1
  • xen-kmp-default >= 4.1.6_08_3.0.101_0.7.40-29.1
  • xen-kmp-pae >= 4.1.6_08_3.0.101_0.7.40-29.1
  • xen-kmp-trace >= 4.1.6_08_3.0.101_0.7.40-29.1
  • xen-libs >= 4.1.6_08-29.1
  • xen-libs-32bit >= 4.1.6_08-29.1
  • xen-tools >= 4.1.6_08-29.1
  • xen-tools-domU >= 4.1.6_08-29.1
Patchnames:
slessp2-xen-12786
SUSE Linux Enterprise Server 11 SP3-LTSS
  • kvm >= 1.4.2-46.1
  • xen >= 4.2.5_21-27.1
  • xen-doc-html >= 4.2.5_21-27.1
  • xen-doc-pdf >= 4.2.5_21-27.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-libs >= 4.2.5_21-27.1
  • xen-libs-32bit >= 4.2.5_21-27.1
  • xen-tools >= 4.2.5_21-27.1
  • xen-tools-domU >= 4.2.5_21-27.1
Patchnames:
slessp3-kvm-12634
slessp3-xen-12836
SUSE Linux Enterprise Server 11 SP4
  • kvm >= 1.4.2-44.1
  • xen >= 4.4.4_07-37.1
  • xen-doc-html >= 4.4.4_07-37.1
  • xen-kmp-default >= 4.4.4_07_3.0.101_77-37.1
  • xen-kmp-pae >= 4.4.4_07_3.0.101_77-37.1
  • xen-libs >= 4.4.4_07-37.1
  • xen-libs-32bit >= 4.4.4_07-37.1
  • xen-tools >= 4.4.4_07-37.1
  • xen-tools-domU >= 4.4.4_07-37.1
Patchnames:
slessp4-kvm-12645
slessp4-xen-12702
SUSE Linux Enterprise Server 12
  • qemu >= 2.0.2-48.19.1
  • qemu-block-curl >= 2.0.2-48.19.1
  • qemu-block-rbd >= 2.0.2-48.19.1
  • qemu-guest-agent >= 2.0.2-48.19.1
  • qemu-ipxe >= 1.0.0-48.19.1
  • qemu-kvm >= 2.0.2-48.19.1
  • qemu-lang >= 2.0.2-48.19.1
  • qemu-ppc >= 2.0.2-48.19.1
  • qemu-s390 >= 2.0.2-48.19.1
  • qemu-seabios >= 1.7.4-48.19.1
  • qemu-sgabios >= 8-48.19.1
  • qemu-tools >= 2.0.2-48.19.1
  • qemu-vgabios >= 1.7.4-48.19.1
  • qemu-x86 >= 2.0.2-48.19.1
Patchnames:
SUSE-SLE-SERVER-12-2016-924
SUSE Linux Enterprise Server 12 SP1
  • qemu >= 2.3.1-14.1
  • qemu-block-curl >= 2.3.1-14.1
  • qemu-block-rbd >= 2.3.1-14.1
  • qemu-guest-agent >= 2.3.1-14.1
  • qemu-ipxe >= 1.0.0-14.1
  • qemu-kvm >= 2.3.1-14.1
  • qemu-lang >= 2.3.1-14.1
  • qemu-ppc >= 2.3.1-14.1
  • qemu-s390 >= 2.3.1-14.1
  • qemu-seabios >= 1.8.1-14.1
  • qemu-sgabios >= 8-14.1
  • qemu-tools >= 2.3.1-14.1
  • qemu-vgabios >= 1.8.1-14.1
  • qemu-x86 >= 2.3.1-14.1
  • xen >= 4.5.3_08-17.1
  • xen-doc-html >= 4.5.3_08-17.1
  • xen-kmp-default >= 4.5.3_08_k3.12.59_60.45-17.1
  • xen-libs >= 4.5.3_08-17.1
  • xen-libs-32bit >= 4.5.3_08-17.1
  • xen-tools >= 4.5.3_08-17.1
  • xen-tools-domU >= 4.5.3_08-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1007
SUSE-SLE-SERVER-12-SP1-2016-1238
SUSE Linux Enterprise Server 12 SP2
  • qemu >= 2.6.1-27.15
  • qemu-arm >= 2.6.1-27.15
  • qemu-block-curl >= 2.6.1-27.15
  • qemu-block-rbd >= 2.6.1-27.15
  • qemu-block-ssh >= 2.6.1-27.15
  • qemu-guest-agent >= 2.6.1-27.15
  • qemu-ipxe >= 1.0.0-27.15
  • qemu-kvm >= 2.6.1-27.15
  • qemu-lang >= 2.6.1-27.15
  • qemu-ppc >= 2.6.1-27.15
  • qemu-s390 >= 2.6.1-27.15
  • qemu-seabios >= 1.9.1-27.15
  • qemu-sgabios >= 8-27.15
  • qemu-tools >= 2.6.1-27.15
  • qemu-vgabios >= 1.9.1-27.15
  • qemu-x86 >= 2.6.1-27.15
  • xen >= 4.7.0_12-23.4
  • xen-doc-html >= 4.7.0_12-23.4
  • xen-libs >= 4.7.0_12-23.4
  • xen-libs-32bit >= 4.7.0_12-23.4
  • xen-tools >= 4.7.0_12-23.4
  • xen-tools-domU >= 4.7.0_12-23.4
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA qemu
SUSE Linux Enterprise Server 12 SP2 GA xen
SUSE Linux Enterprise Server 12-LTSS
  • xen >= 4.4.4_04-22.22.2
  • xen-doc-html >= 4.4.4_04-22.22.2
  • xen-kmp-default >= 4.4.4_04_k3.12.60_52.54-22.22.2
  • xen-libs >= 4.4.4_04-22.22.2
  • xen-libs-32bit >= 4.4.4_04-22.22.2
  • xen-tools >= 4.4.4_04-22.22.2
  • xen-tools-domU >= 4.4.4_04-22.22.2
Patchnames:
SUSE-SLE-SERVER-12-2016-1476
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • qemu >= 2.6.1-27.15
  • qemu-arm >= 2.6.1-27.15
  • qemu-block-curl >= 2.6.1-27.15
  • qemu-block-rbd >= 2.6.1-27.15
  • qemu-block-ssh >= 2.6.1-27.15
  • qemu-guest-agent >= 2.6.1-27.15
  • qemu-ipxe >= 1.0.0-27.15
  • qemu-lang >= 2.6.1-27.15
  • qemu-tools >= 2.6.1-27.15
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA qemu
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xen >= 4.4.4_07-37.1
  • xen-devel >= 4.4.4_07-37.1
Patchnames:
sdksp4-xen-12702
SUSE Linux Enterprise Software Development Kit 12 SP1
  • xen >= 4.5.3_08-17.1
  • xen-devel >= 4.5.3_08-17.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1238
SUSE Linux Enterprise Software Development Kit 12 SP2
  • xen-devel >= 4.7.0_12-23.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA xen-devel
SUSE Linux Enterprise for SAP 12
  • xen >= 4.4.4_04-22.22.2
  • xen-doc-html >= 4.4.4_04-22.22.2
  • xen-kmp-default >= 4.4.4_04_k3.12.60_52.54-22.22.2
  • xen-libs >= 4.4.4_04-22.22.2
  • xen-libs-32bit >= 4.4.4_04-22.22.2
  • xen-tools >= 4.4.4_04-22.22.2
  • xen-tools-domU >= 4.4.4_04-22.22.2
Patchnames:
SUSE-SLE-SAP-12-2016-1476
SUSE Manager 2.1
  • xen >= 4.2.5_21-27.1
  • xen-doc-html >= 4.2.5_21-27.1
  • xen-doc-pdf >= 4.2.5_21-27.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-libs >= 4.2.5_21-27.1
  • xen-libs-32bit >= 4.2.5_21-27.1
  • xen-tools >= 4.2.5_21-27.1
  • xen-tools-domU >= 4.2.5_21-27.1
Patchnames:
sleman21-xen-12836
SUSE Manager Proxy 2.1
  • xen >= 4.2.5_21-27.1
  • xen-doc-html >= 4.2.5_21-27.1
  • xen-doc-pdf >= 4.2.5_21-27.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-libs >= 4.2.5_21-27.1
  • xen-libs-32bit >= 4.2.5_21-27.1
  • xen-tools >= 4.2.5_21-27.1
  • xen-tools-domU >= 4.2.5_21-27.1
Patchnames:
slemap21-xen-12836
SUSE OpenStack Cloud 5
  • xen >= 4.2.5_21-27.1
  • xen-doc-html >= 4.2.5_21-27.1
  • xen-doc-pdf >= 4.2.5_21-27.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.86-27.1
  • xen-libs >= 4.2.5_21-27.1
  • xen-libs-32bit >= 4.2.5_21-27.1
  • xen-tools >= 4.2.5_21-27.1
  • xen-tools-domU >= 4.2.5_21-27.1
Patchnames:
sleclo50sp3-xen-12836
openSUSE 13.2
  • xen >= 4.4.4_05-49.1
  • xen-debugsource >= 4.4.4_05-49.1
  • xen-devel >= 4.4.4_05-49.1
  • xen-doc-html >= 4.4.4_05-49.1
  • xen-kmp-default >= 4.4.4_05_k3.16.7_42-49.1
  • xen-kmp-default-debuginfo >= 4.4.4_05_k3.16.7_42-49.1
  • xen-kmp-desktop >= 4.4.4_05_k3.16.7_42-49.1
  • xen-kmp-desktop-debuginfo >= 4.4.4_05_k3.16.7_42-49.1
  • xen-libs >= 4.4.4_05-49.1
  • xen-libs-32bit >= 4.4.4_05-49.1
  • xen-libs-debuginfo >= 4.4.4_05-49.1
  • xen-libs-debuginfo-32bit >= 4.4.4_05-49.1
  • xen-tools >= 4.4.4_05-49.1
  • xen-tools-debuginfo >= 4.4.4_05-49.1
  • xen-tools-domU >= 4.4.4_05-49.1
  • xen-tools-domU-debuginfo >= 4.4.4_05-49.1
Patchnames:
openSUSE-2016-1169
openSUSE Leap 42.1
  • qemu >= 2.3.1-15.1
  • qemu-arm >= 2.3.1-15.1
  • qemu-arm-debuginfo >= 2.3.1-15.1
  • qemu-block-curl >= 2.3.1-15.1
  • qemu-block-curl-debuginfo >= 2.3.1-15.1
  • qemu-block-rbd >= 2.3.1-15.1
  • qemu-block-rbd-debuginfo >= 2.3.1-15.1
  • qemu-debugsource >= 2.3.1-15.1
  • qemu-extra >= 2.3.1-15.1
  • qemu-extra-debuginfo >= 2.3.1-15.1
  • qemu-guest-agent >= 2.3.1-15.1
  • qemu-guest-agent-debuginfo >= 2.3.1-15.1
  • qemu-ipxe >= 1.0.0-15.1
  • qemu-kvm >= 2.3.1-15.1
  • qemu-lang >= 2.3.1-15.1
  • qemu-linux-user >= 2.3.1-15.1
  • qemu-linux-user-debuginfo >= 2.3.1-15.1
  • qemu-linux-user-debugsource >= 2.3.1-15.1
  • qemu-ppc >= 2.3.1-15.1
  • qemu-ppc-debuginfo >= 2.3.1-15.1
  • qemu-s390 >= 2.3.1-15.1
  • qemu-s390-debuginfo >= 2.3.1-15.1
  • qemu-seabios >= 1.8.1-15.1
  • qemu-sgabios >= 8-15.1
  • qemu-testsuite >= 2.3.1-15.2
  • qemu-tools >= 2.3.1-15.1
  • qemu-tools-debuginfo >= 2.3.1-15.1
  • qemu-vgabios >= 1.8.1-15.1
  • qemu-x86 >= 2.3.1-15.1
  • qemu-x86-debuginfo >= 2.3.1-15.1
  • xen >= 4.5.3_10-15.2
  • xen-debugsource >= 4.5.3_10-15.2
  • xen-devel >= 4.5.3_10-15.2
  • xen-doc-html >= 4.5.3_10-15.2
  • xen-kmp-default >= 4.5.3_10_k4.1.31_30-15.2
  • xen-kmp-default-debuginfo >= 4.5.3_10_k4.1.31_30-15.2
  • xen-libs >= 4.5.3_10-15.2
  • xen-libs-32bit >= 4.5.3_10-15.2
  • xen-libs-debuginfo >= 4.5.3_10-15.2
  • xen-libs-debuginfo-32bit >= 4.5.3_10-15.2
  • xen-tools >= 4.5.3_10-15.2
  • xen-tools-debuginfo >= 4.5.3_10-15.2
  • xen-tools-domU >= 4.5.3_10-15.2
  • xen-tools-domU-debuginfo >= 4.5.3_10-15.2
Patchnames:
openSUSE-2016-1170
openSUSE-2016-839
openSUSE Leap 42.2
  • qemu >= 2.6.1-21.1
  • qemu-arm >= 2.6.1-21.1
  • qemu-block-curl >= 2.6.1-21.1
  • qemu-block-dmg >= 2.6.1-21.1
  • qemu-block-iscsi >= 2.6.1-21.1
  • qemu-block-rbd >= 2.6.1-21.1
  • qemu-block-ssh >= 2.6.1-21.1
  • qemu-extra >= 2.6.1-21.1
  • qemu-ipxe >= 1.0.0-21.1
  • qemu-kvm >= 2.6.1-21.1
  • qemu-lang >= 2.6.1-21.1
  • qemu-linux-user >= 2.6.1-21.1
  • qemu-ppc >= 2.6.1-21.1
  • qemu-s390 >= 2.6.1-21.1
  • qemu-seabios >= 1.9.1-21.1
  • qemu-sgabios >= 8-21.1
  • qemu-tools >= 2.6.1-21.1
  • qemu-vgabios >= 1.9.1-21.1
  • qemu-x86 >= 2.6.1-21.1
  • xen >= 4.7.0_12-1.6
  • xen-doc-html >= 4.7.0_12-1.6
  • xen-libs >= 4.7.0_12-1.6
  • xen-tools >= 4.7.0_12-1.6
  • xen-tools-domU >= 4.7.0_12-1.6
Patchnames:
openSUSE Leap 42.2 GA qemu
openSUSE Leap 42.2 GA qemu-linux-user
openSUSE Leap 42.2 GA xen
openSUSE Tumbleweed
  • qemu >= 2.6.1-1.5
  • qemu-arm >= 2.6.1-1.5
  • qemu-block-curl >= 2.6.1-1.5
  • qemu-block-dmg >= 2.6.1-1.5
  • qemu-block-gluster >= 2.6.1-1.5
  • qemu-block-iscsi >= 2.6.1-1.5
  • qemu-block-ssh >= 2.6.1-1.5
  • qemu-extra >= 2.6.1-1.5
  • qemu-guest-agent >= 2.6.1-1.5
  • qemu-ipxe >= 1.0.0-1.5
  • qemu-ksm >= 2.6.1-1.5
  • qemu-kvm >= 2.6.1-1.5
  • qemu-lang >= 2.6.1-1.5
  • qemu-linux-user >= 2.6.1-1.5
  • qemu-ppc >= 2.6.1-1.5
  • qemu-s390 >= 2.6.1-1.5
  • qemu-seabios >= 1.9.1-1.5
  • qemu-sgabios >= 8-1.5
  • qemu-testsuite >= 2.6.1-1.5
  • qemu-tools >= 2.6.1-1.5
  • qemu-vgabios >= 1.9.1-1.5
  • qemu-x86 >= 2.6.1-1.5
  • xen >= 4.7.0_12-1.3
  • xen-devel >= 4.7.0_12-1.3
  • xen-doc-html >= 4.7.0_12-1.3
  • xen-libs >= 4.7.0_12-1.3
  • xen-libs-32bit >= 4.7.0_12-1.3
  • xen-tools >= 4.7.0_12-1.3
  • xen-tools-domU >= 4.7.0_12-1.3
Patchnames:
openSUSE Tumbleweed GA qemu
openSUSE Tumbleweed GA qemu-linux-user
openSUSE Tumbleweed GA xen


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 10 SP4 LTSS
xen