Upstream information

CVE-2016-4302 at MITRE

Description

Heap-based buffer overflow in the parse_codes function in archive_read_support_format_rar.c in libarchive before 3.2.1 allows remote attackers to execute arbitrary code via a RAR file with a zero-sized dictionary.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.82 6.82
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 985835 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libarchive >= 3.1.2-22.1
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1123
SUSE Linux Enterprise Desktop 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libarchive13
SUSE Linux Enterprise Server 12 SP1
  • libarchive >= 3.1.2-22.1
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1123
SUSE Linux Enterprise Server 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libarchive13
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libarchive13
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libarchive >= 3.1.2-22.1
  • libarchive-devel >= 3.1.2-22.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1123
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libarchive-devel >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libarchive-devel
openSUSE Leap 42.1
  • bsdtar >= 3.1.2-13.2
  • bsdtar-debuginfo >= 3.1.2-13.2
  • libarchive >= 3.1.2-13.2
  • libarchive-debugsource >= 3.1.2-13.2
  • libarchive-devel >= 3.1.2-13.2
  • libarchive13 >= 3.1.2-13.2
  • libarchive13-32bit >= 3.1.2-13.2
  • libarchive13-debuginfo >= 3.1.2-13.2
  • libarchive13-debuginfo-32bit >= 3.1.2-13.2
Patchnames:
openSUSE-2016-969
openSUSE Leap 42.2
  • bsdtar >= 3.1.2-14.1
  • libarchive-devel >= 3.1.2-14.1
  • libarchive13 >= 3.1.2-14.1
Patchnames:
openSUSE Leap 42.2 GA bsdtar