Upstream information

CVE-2016-4225 at MITRE

Description

Adobe Flash Player before 18.0.0.366 and 19.x through 22.x before 22.0.0.209 on Windows and OS X and before 11.2.202.632 on Linux allows attackers to execute arbitrary code by leveraging an unspecified "type confusion," a different vulnerability than CVE-2016-4223 and CVE-2016-4224.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.82 6.82
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 988579 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 11.2.202.632-137.1
  • flash-player-gnome >= 11.2.202.632-137.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1073
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 11.2.202.632-137.1
  • flash-player-gnome >= 11.2.202.632-137.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1073
openSUSE 13.2 NonFree
  • flash-player >= 11.2.202.632-2.103.1
  • flash-player-gnome >= 11.2.202.632-2.103.1
  • flash-player-kde4 >= 11.2.202.632-2.103.1
Patchnames:
openSUSE-2016-866