Upstream information

CVE-2016-4049 at MITRE

Description

The bgp_dump_routes_func function in bgpd/bgp_dump.c in Quagga does not perform size checks when dumping data, which might allow remote attackers to cause a denial of service (assertion failure and daemon crash) via a large BGP packet.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.96
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 977012 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
  • quagga >= 0.99.15-0.24.2
Patchnames:
slessp4-quagga-12596
SUSE Linux Enterprise Server 12
  • quagga >= 0.99.22.1-12.1
Patchnames:
SUSE-SLE-SERVER-12-2016-882
SUSE Linux Enterprise Server 12 SP1
  • quagga >= 0.99.22.1-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-882
SUSE Linux Enterprise Server 12 SP2
  • quagga >= 0.99.22.1-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA quagga
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • quagga >= 0.99.22.1-12.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA quagga
SUSE Linux Enterprise Software Development Kit 11 SP4
  • quagga >= 0.99.15-0.24.2
  • quagga-devel >= 0.99.15-0.24.2
Patchnames:
sdksp4-quagga-12596
SUSE Linux Enterprise Software Development Kit 12
  • quagga >= 0.99.22.1-12.1
  • quagga-devel >= 0.99.22.1-12.1
Patchnames:
SUSE-SLE-SDK-12-2016-882
SUSE Linux Enterprise Software Development Kit 12 SP1
  • quagga >= 0.99.22.1-12.1
  • quagga-devel >= 0.99.22.1-12.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-882
SUSE Linux Enterprise Software Development Kit 12 SP2
  • quagga-devel >= 0.99.22.1-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA quagga-devel
openSUSE 13.2
  • quagga >= 0.99.23-2.9.1
  • quagga-debuginfo >= 0.99.23-2.9.1
  • quagga-debugsource >= 0.99.23-2.9.1
  • quagga-devel >= 0.99.23-2.9.1
Patchnames:
openSUSE-2016-591
openSUSE Leap 42.1
  • quagga >= 0.99.24.1-11.1
  • quagga-debuginfo >= 0.99.24.1-11.1
  • quagga-debugsource >= 0.99.24.1-11.1
  • quagga-devel >= 0.99.24.1-11.1
Patchnames:
openSUSE-2016-591
openSUSE Leap 42.2
  • quagga >= 0.99.24.1-15.1
Patchnames:
openSUSE Leap 42.2 GA quagga
openSUSE Tumbleweed
  • libospf0 >= 1.0.20160315-5.1
  • libospfapiclient0 >= 1.0.20160315-5.1
  • libzebra0 >= 1.0.20160315-5.1
  • quagga >= 1.0.20160315-5.1
  • quagga-devel >= 1.0.20160315-5.1
Patchnames:
openSUSE Tumbleweed GA libospf0