Upstream information

CVE-2016-3977 at MITRE

Description

Heap-based buffer overflow in util/gif2rgb.c in gif2rgb in giflib 5.1.2 allows remote attackers to cause a denial of service (application crash) via the background color index in a GIF file.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.30 4.96
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 974847 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • giflib >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-667
SUSE Linux Enterprise Desktop 12 SP1
  • giflib >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-667
SUSE Linux Enterprise Desktop 12 SP2
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libgif6-32bit
SUSE Linux Enterprise Server 11 SP4
  • giflib >= 4.1.6-21.1
  • giflib-32bit >= 4.1.6-21.1
  • giflib-progs >= 4.1.6-21.1
  • giflib-x86 >= 4.1.6-21.1
Patchnames:
slessp4-giflib-12526
SUSE Linux Enterprise Server 12
  • giflib >= 5.0.5-12.1
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE-SLE-SERVER-12-2016-667
SUSE Linux Enterprise Server 12 SP1
  • giflib >= 5.0.5-12.1
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-667
SUSE Linux Enterprise Server 12 SP2
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA giflib-progs
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA giflib-progs
SUSE Linux Enterprise Software Development Kit 11 SP4
  • giflib >= 4.1.6-21.1
  • giflib-devel >= 4.1.6-21.1
  • giflib-devel-32bit >= 4.1.6-21.1
Patchnames:
sdksp4-giflib-12526
SUSE Linux Enterprise Software Development Kit 12
  • giflib >= 5.0.5-12.1
  • giflib-devel >= 5.0.5-12.1
Patchnames:
SUSE-SLE-SDK-12-2016-667
SUSE Linux Enterprise Software Development Kit 12 SP1
  • giflib >= 5.0.5-12.1
  • giflib-devel >= 5.0.5-12.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-667
SUSE Linux Enterprise Software Development Kit 12 SP2
  • giflib-devel >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA giflib-devel
openSUSE 13.1
  • giflib >= 5.0.5-2.9.1
  • giflib-debugsource >= 5.0.5-2.9.1
  • giflib-devel >= 5.0.5-2.9.1
  • giflib-devel-32bit >= 5.0.5-2.9.1
  • giflib-progs >= 5.0.5-2.9.1
  • giflib-progs-debuginfo >= 5.0.5-2.9.1
  • libgif6 >= 5.0.5-2.9.1
  • libgif6-32bit >= 5.0.5-2.9.1
  • libgif6-debuginfo >= 5.0.5-2.9.1
  • libgif6-debuginfo-32bit >= 5.0.5-2.9.1
Patchnames:
2016-497
openSUSE 13.2
  • giflib >= 5.0.5-4.6.1
  • giflib-debugsource >= 5.0.5-4.6.1
  • giflib-devel >= 5.0.5-4.6.1
  • giflib-devel-32bit >= 5.0.5-4.6.1
  • giflib-progs >= 5.0.5-4.6.1
  • giflib-progs-debuginfo >= 5.0.5-4.6.1
  • libgif6 >= 5.0.5-4.6.1
  • libgif6-32bit >= 5.0.5-4.6.1
  • libgif6-debuginfo >= 5.0.5-4.6.1
  • libgif6-debuginfo-32bit >= 5.0.5-4.6.1
Patchnames:
openSUSE-2016-492
openSUSE Leap 42.1
  • giflib >= 5.0.5-10.1
  • giflib-debugsource >= 5.0.5-10.1
  • giflib-devel >= 5.0.5-10.1
  • giflib-devel-32bit >= 5.0.5-10.1
  • giflib-progs >= 5.0.5-10.1
  • giflib-progs-debuginfo >= 5.0.5-10.1
  • libgif6 >= 5.0.5-10.1
  • libgif6-32bit >= 5.0.5-10.1
  • libgif6-debuginfo >= 5.0.5-10.1
  • libgif6-debuginfo-32bit >= 5.0.5-10.1
Patchnames:
openSUSE-2016-556
openSUSE Leap 42.2
  • giflib-devel >= 5.0.5-11.1
  • libgif6 >= 5.0.5-11.1
Patchnames:
openSUSE Leap 42.2 GA giflib-devel
openSUSE Tumbleweed
  • giflib-devel >= 5.1.4-1.12
  • giflib-devel-32bit >= 5.1.4-1.12
  • giflib-progs >= 5.1.4-1.12
  • libgif7 >= 5.1.4-1.12
  • libgif7-32bit >= 5.1.4-1.12
Patchnames:
openSUSE Tumbleweed GA giflib-devel-32bit