Upstream information

CVE-2016-3959 at MITRE

Description

The Verify function in crypto/dsa/dsa.go in Go before 1.5.4 and 1.6.x before 1.6.1 does not properly check parameters passed to the big integer library, which might allow remote attackers to cause a denial of service (infinite loop) via a crafted public key to a program that uses HTTPS client certificates or SSH server libraries.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 974232 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12
  • go >= 1.6.1-23.1
  • go-doc >= 1.6.1-23.1
Patchnames:
SUSE-SLE-BSK-12-2016-670
SUSE-SLE-BSK-12-2016-714
openSUSE Leap 42.1
  • go >= 1.6.1-14.1
  • go-debuginfo >= 1.6.1-14.1
  • go-debugsource >= 1.6.1-14.1
  • go-doc >= 1.6.1-14.1
Patchnames:
openSUSE-2016-606
openSUSE Tumbleweed
  • go >= 1.7.0-2.1
  • go-doc >= 1.7.0-2.1
Patchnames:
openSUSE Tumbleweed GA go


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 GA go Affected