Upstream information

CVE-2016-3191 at MITRE

Description

The compile_branch function in pcre_compile.c in PCRE 8.x before 8.39 and pcre2_compile.c in PCRE2 before 10.22 mishandles patterns containing an (*ACCEPT) substring in conjunction with nested parentheses, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, aka ZDI-CAN-3542.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having important severity.

SUSE Bugzilla entry: 971741 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1744
SUSE-SLE-DESKTOP-12-SP1-2016-1827
SUSE Linux Enterprise Desktop 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1744
SUSE-SLE-DESKTOP-12-SP2-2016-1827
SUSE Linux Enterprise High Availability 12 SP1
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-HA-12-SP1-2016-1744
SUSE-SLE-HA-12-SP1-2016-1827
SUSE Linux Enterprise High Availability 12 SP2
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-HA-12-SP2-2016-1744
SUSE-SLE-HA-12-SP2-2016-1827
SUSE Linux Enterprise Server 12 SP1
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1744
SUSE-SLE-SERVER-12-SP1-2016-1827
SUSE Linux Enterprise Server 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1744
SUSE-SLE-SERVER-12-SP2-2016-1827
SUSE Linux Enterprise Server 12-LTSS
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-2016-1827
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1744
SUSE-SLE-RPI-12-SP2-2016-1827
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpcrecpp0 >= 8.39-7.1
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
  • pcre-devel >= 8.39-7.1
  • pcre-devel-static >= 8.39-7.1
  • pcre-tools >= 8.39-7.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1744
SUSE-SLE-SDK-12-SP1-2016-1827
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpcrecpp0 >= 8.39-7.1
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
  • pcre-devel >= 8.39-7.1
  • pcre-devel-static >= 8.39-7.1
  • pcre-tools >= 8.39-7.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1744
SUSE-SLE-SDK-12-SP2-2016-1827
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1744
SUSE-SLE-WE-12-SP1-2016-1827
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-WE-12-SP2-2016-1744
SUSE-SLE-WE-12-SP2-2016-1827
SUSE Linux Enterprise for SAP 12
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SAP-12-2016-1827
openSUSE 13.2
  • libpcre1 >= 8.39-3.8.1
  • libpcre1-32bit >= 8.39-3.8.1
  • libpcre1-debuginfo >= 8.39-3.8.1
  • libpcre1-debuginfo-32bit >= 8.39-3.8.1
  • libpcre16-0 >= 8.39-3.8.1
  • libpcre16-0-32bit >= 8.39-3.8.1
  • libpcre16-0-debuginfo >= 8.39-3.8.1
  • libpcre16-0-debuginfo-32bit >= 8.39-3.8.1
  • libpcrecpp0 >= 8.39-3.8.1
  • libpcrecpp0-32bit >= 8.39-3.8.1
  • libpcrecpp0-debuginfo >= 8.39-3.8.1
  • libpcrecpp0-debuginfo-32bit >= 8.39-3.8.1
  • libpcreposix0 >= 8.39-3.8.1
  • libpcreposix0-32bit >= 8.39-3.8.1
  • libpcreposix0-debuginfo >= 8.39-3.8.1
  • libpcreposix0-debuginfo-32bit >= 8.39-3.8.1
  • pcre >= 8.39-3.8.1
  • pcre-debugsource >= 8.39-3.8.1
  • pcre-devel >= 8.39-3.8.1
  • pcre-devel-static >= 8.39-3.8.1
  • pcre-doc >= 8.39-3.8.1
  • pcre-tools >= 8.39-3.8.1
  • pcre-tools-debuginfo >= 8.39-3.8.1
Patchnames:
openSUSE-2016-1303
openSUSE Leap 42.1
  • libpcre1 >= 8.39-5.1
  • libpcre1-32bit >= 8.39-5.1
  • libpcre1-debuginfo >= 8.39-5.1
  • libpcre1-debuginfo-32bit >= 8.39-5.1
  • libpcre16-0 >= 8.39-5.1
  • libpcre16-0-32bit >= 8.39-5.1
  • libpcre16-0-debuginfo >= 8.39-5.1
  • libpcre16-0-debuginfo-32bit >= 8.39-5.1
  • libpcre2-16-0 >= 10.22-7.1
  • libpcre2-16-0-32bit >= 10.22-7.1
  • libpcre2-16-0-debuginfo >= 10.22-7.1
  • libpcre2-16-0-debuginfo-32bit >= 10.22-7.1
  • libpcre2-32-0 >= 10.22-7.1
  • libpcre2-32-0-32bit >= 10.22-7.1
  • libpcre2-32-0-debuginfo >= 10.22-7.1
  • libpcre2-32-0-debuginfo-32bit >= 10.22-7.1
  • libpcre2-8-0 >= 10.22-7.1
  • libpcre2-8-0-32bit >= 10.22-7.1
  • libpcre2-8-0-debuginfo >= 10.22-7.1
  • libpcre2-8-0-debuginfo-32bit >= 10.22-7.1
  • libpcre2-posix1 >= 10.22-7.1
  • libpcre2-posix1-32bit >= 10.22-7.1
  • libpcre2-posix1-debuginfo >= 10.22-7.1
  • libpcre2-posix1-debuginfo-32bit >= 10.22-7.1
  • libpcrecpp0 >= 8.39-5.1
  • libpcrecpp0-32bit >= 8.39-5.1
  • libpcrecpp0-debuginfo >= 8.39-5.1
  • libpcrecpp0-debuginfo-32bit >= 8.39-5.1
  • libpcreposix0 >= 8.39-5.1
  • libpcreposix0-32bit >= 8.39-5.1
  • libpcreposix0-debuginfo >= 8.39-5.1
  • libpcreposix0-debuginfo-32bit >= 8.39-5.1
  • pcre >= 8.39-5.1
  • pcre-debugsource >= 8.39-5.1
  • pcre-devel >= 8.39-5.1
  • pcre-devel-static >= 8.39-5.1
  • pcre-doc >= 8.39-5.1
  • pcre-tools >= 8.39-5.1
  • pcre-tools-debuginfo >= 8.39-5.1
  • pcre2 >= 10.22-7.1
  • pcre2-debugsource >= 10.22-7.1
  • pcre2-devel >= 10.22-7.1
  • pcre2-devel-static >= 10.22-7.1
  • pcre2-doc >= 10.22-7.1
  • pcre2-tools >= 10.22-7.1
  • pcre2-tools-debuginfo >= 10.22-7.1
Patchnames:
openSUSE-2016-1448
openSUSE-2016-966
openSUSE Leap 42.2
  • libpcre1 >= 8.39-6.1
  • libpcre1-32bit >= 8.39-6.1
  • libpcre1-debuginfo >= 8.39-6.1
  • libpcre1-debuginfo-32bit >= 8.39-6.1
  • libpcre16-0 >= 8.39-6.1
  • libpcre16-0-32bit >= 8.39-6.1
  • libpcre16-0-debuginfo >= 8.39-6.1
  • libpcre16-0-debuginfo-32bit >= 8.39-6.1
  • libpcrecpp0 >= 8.39-6.1
  • libpcrecpp0-32bit >= 8.39-6.1
  • libpcrecpp0-debuginfo >= 8.39-6.1
  • libpcrecpp0-debuginfo-32bit >= 8.39-6.1
  • libpcreposix0 >= 8.39-6.1
  • libpcreposix0-32bit >= 8.39-6.1
  • libpcreposix0-debuginfo >= 8.39-6.1
  • libpcreposix0-debuginfo-32bit >= 8.39-6.1
  • pcre >= 8.39-6.1
  • pcre-debugsource >= 8.39-6.1
  • pcre-devel >= 8.39-6.1
  • pcre-devel-static >= 8.39-6.1
  • pcre-doc >= 8.39-6.1
  • pcre-tools >= 8.39-6.1
  • pcre-tools-debuginfo >= 8.39-6.1
Patchnames:
openSUSE-2016-1448
openSUSE Tumbleweed
  • libpcre1 >= 8.39-2.5
  • libpcre1-32bit >= 8.39-2.5
  • libpcre16-0 >= 8.39-2.5
  • libpcre16-0-32bit >= 8.39-2.5
  • libpcre2-16-0 >= 10.22-1.3
  • libpcre2-16-0-32bit >= 10.22-1.3
  • libpcre2-32-0 >= 10.22-1.3
  • libpcre2-32-0-32bit >= 10.22-1.3
  • libpcre2-8-0 >= 10.22-1.3
  • libpcre2-8-0-32bit >= 10.22-1.3
  • libpcre2-posix1 >= 10.22-1.3
  • libpcre2-posix1-32bit >= 10.22-1.3
  • libpcrecpp0 >= 8.39-2.5
  • libpcrecpp0-32bit >= 8.39-2.5
  • libpcreposix0 >= 8.39-2.5
  • libpcreposix0-32bit >= 8.39-2.5
  • pcre-devel >= 8.39-2.5
  • pcre-devel-static >= 8.39-2.5
  • pcre-doc >= 8.39-2.5
  • pcre-tools >= 8.39-2.5
  • pcre2-devel >= 10.22-1.3
  • pcre2-devel-static >= 10.22-1.3
  • pcre2-doc >= 10.22-1.3
  • pcre2-tools >= 10.22-1.3
Patchnames:
openSUSE Tumbleweed GA libpcre1-32bit
openSUSE Tumbleweed GA libpcre2-16-0


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Desktop 11 SP4
  • SUSE Linux Enterprise Desktop 12 GA
  • SUSE Linux Enterprise High Availability 12 GA
  • SUSE Linux Enterprise SDK 11 SP4
  • SUSE Linux Enterprise SDK 12 GA
  • SUSE Linux Enterprise Server 10 SP4 LTSS
  • SUSE Linux Enterprise Server 11 SP2 LTSS
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 11 SP4
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Workstation Extension 12 GA
pcre