Upstream information

CVE-2016-3190 at MITRE

Description

The fill_xrgb32_lerp_opaque_spans function in cairo-image-compositor.c in cairo before 1.14.2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a negative span length.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 971964 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • cairo >= 1.12.16-13.1
  • libcairo-gobject2 >= 1.12.16-13.1
  • libcairo-gobject2-32bit >= 1.12.16-13.1
  • libcairo2 >= 1.12.16-13.1
  • libcairo2-32bit >= 1.12.16-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-646
SUSE Linux Enterprise Desktop 12 SP1
  • cairo >= 1.12.16-13.1
  • libcairo-gobject2 >= 1.12.16-13.1
  • libcairo-gobject2-32bit >= 1.12.16-13.1
  • libcairo-script-interpreter2 >= 1.12.16-13.1
  • libcairo2 >= 1.12.16-13.1
  • libcairo2-32bit >= 1.12.16-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-646
SUSE Linux Enterprise Server 12
  • cairo >= 1.12.16-13.1
  • libcairo-gobject2 >= 1.12.16-13.1
  • libcairo-gobject2-32bit >= 1.12.16-13.1
  • libcairo2 >= 1.12.16-13.1
  • libcairo2-32bit >= 1.12.16-13.1
Patchnames:
SUSE-SLE-SERVER-12-2016-646
SUSE Linux Enterprise Server 12 SP1
  • cairo >= 1.12.16-13.1
  • libcairo-gobject2 >= 1.12.16-13.1
  • libcairo-gobject2-32bit >= 1.12.16-13.1
  • libcairo-script-interpreter2 >= 1.12.16-13.1
  • libcairo2 >= 1.12.16-13.1
  • libcairo2-32bit >= 1.12.16-13.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-646
SUSE Linux Enterprise Software Development Kit 12
  • cairo >= 1.12.16-13.1
  • cairo-devel >= 1.12.16-13.1
  • libcairo-script-interpreter2 >= 1.12.16-13.1
Patchnames:
SUSE-SLE-SDK-12-2016-646
SUSE Linux Enterprise Software Development Kit 12 SP1
  • cairo >= 1.12.16-13.1
  • cairo-devel >= 1.12.16-13.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-646


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 cairo Not affected
SUSE Linux Enterprise Desktop 12 GA cairo Released
SUSE Linux Enterprise Desktop 12 SP1 cairo Released
SUSE Linux Enterprise SDK 11 SP4 cairo Not affected
SUSE Linux Enterprise SDK 12 GA cairo Released
SUSE Linux Enterprise SDK 12 SP1 cairo Released
SUSE Linux Enterprise Server 10 SP4 LTSS cairo Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS cairo Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS cairo Not affected
SUSE Linux Enterprise Server 11 SP4 cairo Not affected
SUSE Linux Enterprise Server 12 GA cairo Released
SUSE Linux Enterprise Server 12 SP1 cairo Released