Upstream information

CVE-2016-3065 at MITRE

Description

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 8.5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 978456 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.3-2.1
  • libpq5 >= 9.6.3-2.1
  • libpq5-32bit >= 9.6.3-2.1
  • postgresql96 >= 9.6.3-2.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libecpg6
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 9.6.3-2.1
  • libpq5 >= 9.6.3-2.1
  • libpq5-32bit >= 9.6.3-2.1
  • postgresql96 >= 9.6.3-2.4
  • postgresql96-contrib >= 9.6.3-2.4
  • postgresql96-docs >= 9.6.3-2.4
  • postgresql96-server >= 9.6.3-2.4
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libecpg6
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.3-2.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA postgresql96-devel
openSUSE Leap 42.3
  • libecpg6 >= 9.6.3-3.1
  • libpq5 >= 9.6.3-3.1
  • postgresql95-docs >= 9.5.7-1.8
  • postgresql96 >= 9.6.3-3.1
  • postgresql96-contrib >= 9.6.3-3.1
  • postgresql96-devel >= 9.6.3-3.1
  • postgresql96-docs >= 9.6.3-3.1
  • postgresql96-server >= 9.6.3-3.1
Patchnames:
openSUSE Leap 42.3 GA libecpg6
openSUSE Leap 42.3 GA postgresql95-docs
openSUSE Tumbleweed
  • libecpg6 >= 9.5.4-1.2
  • libecpg6-32bit >= 9.5.4-1.2
  • libpq5 >= 9.5.4-1.2
  • libpq5-32bit >= 9.5.4-1.2
  • postgresql95 >= 9.5.4-1.2
  • postgresql95-contrib >= 9.5.4-1.2
  • postgresql95-devel >= 9.5.4-1.2
  • postgresql95-docs >= 9.5.4-1.2
  • postgresql95-plperl >= 9.5.4-1.2
  • postgresql95-plpython >= 9.5.4-1.2
  • postgresql95-pltcl >= 9.5.4-1.2
  • postgresql95-server >= 9.5.4-1.2
  • postgresql95-test >= 9.5.4-1.2
Patchnames:
openSUSE Tumbleweed GA libecpg6-32bit