Upstream information

CVE-2016-2851 at MITRE

Description

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 6.82
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 969785 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
  • libotr >= 3.2.0-10.5.1
  • libotr2 >= 3.2.0-10.5.1
Patchnames:
sledsp4-libotr-12442
SUSE Linux Enterprise Desktop 12
  • libotr >= 4.0.0-9.1
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-404
SUSE Linux Enterprise Desktop 12 SP1
  • libotr >= 4.0.0-9.1
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-404
SUSE Linux Enterprise Desktop 12 SP2
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libotr5
SUSE Linux Enterprise Server 11 SP4
  • libotr >= 3.2.0-10.5.1
  • libotr2 >= 3.2.0-10.5.1
Patchnames:
slessp4-libotr-12442
SUSE Linux Enterprise Server 12
  • libotr >= 4.0.0-9.1
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE-SLE-SERVER-12-2016-404
SUSE Linux Enterprise Server 12 SP1
  • libotr >= 4.0.0-9.1
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-404
SUSE Linux Enterprise Server 12 SP2
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libotr5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libotr5 >= 4.0.0-9.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libotr5
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libotr >= 3.2.0-10.5.1
  • libotr-devel >= 3.2.0-10.5.1
Patchnames:
sdksp4-libotr-12442
SUSE Linux Enterprise Software Development Kit 12
  • libotr >= 4.0.0-9.1
  • libotr-devel >= 4.0.0-9.1
Patchnames:
SUSE-SLE-SDK-12-2016-404
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libotr >= 4.0.0-9.1
  • libotr-devel >= 4.0.0-9.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-404
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libotr-devel >= 4.0.0-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libotr-devel
openSUSE 13.1
  • libotr >= 4.0.0-5.7.1
  • libotr-debugsource >= 4.0.0-5.7.1
  • libotr-devel >= 4.0.0-5.7.1
  • libotr-tools >= 4.0.0-5.7.1
  • libotr-tools-debuginfo >= 4.0.0-5.7.1
  • libotr2 >= 3.2.1-5.3.1
  • libotr2-debuginfo >= 3.2.1-5.3.1
  • libotr2-debugsource >= 3.2.1-5.3.1
  • libotr2-devel >= 3.2.1-5.3.1
  • libotr2-tools >= 3.2.1-5.3.1
  • libotr2-tools-debuginfo >= 3.2.1-5.3.1
  • libotr5 >= 4.0.0-5.7.1
  • libotr5-debuginfo >= 4.0.0-5.7.1
Patchnames:
2016-333
openSUSE 13.2
  • libotr >= 4.0.0-8.3.1
  • libotr-debugsource >= 4.0.0-8.3.1
  • libotr-devel >= 4.0.0-8.3.1
  • libotr-tools >= 4.0.0-8.3.1
  • libotr-tools-debuginfo >= 4.0.0-8.3.1
  • libotr2 >= 3.2.1-7.3.1
  • libotr2-debuginfo >= 3.2.1-7.3.1
  • libotr2-debugsource >= 3.2.1-7.3.1
  • libotr2-devel >= 3.2.1-7.3.1
  • libotr2-tools >= 3.2.1-7.3.1
  • libotr2-tools-debuginfo >= 3.2.1-7.3.1
  • libotr5 >= 4.0.0-8.3.1
  • libotr5-debuginfo >= 4.0.0-8.3.1
Patchnames:
openSUSE-2016-322
openSUSE Leap 42.1
  • libotr >= 4.1.1-4.1
  • libotr-debugsource >= 4.1.1-4.1
  • libotr-devel >= 4.1.1-4.1
  • libotr-tools >= 4.1.1-4.1
  • libotr-tools-debuginfo >= 4.1.1-4.1
  • libotr2 >= 3.2.1-13.1
  • libotr2-debuginfo >= 3.2.1-13.1
  • libotr2-debugsource >= 3.2.1-13.1
  • libotr2-devel >= 3.2.1-13.1
  • libotr2-tools >= 3.2.1-13.1
  • libotr2-tools-debuginfo >= 3.2.1-13.1
  • libotr5 >= 4.1.1-4.1
  • libotr5-debuginfo >= 4.1.1-4.1
Patchnames:
openSUSE-2016-322
openSUSE Leap 42.2
  • libotr-devel >= 4.1.1-5.1
  • libotr5 >= 4.1.1-5.1
Patchnames:
openSUSE Leap 42.2 GA libotr-devel
openSUSE Tumbleweed
  • libotr-devel >= 4.1.1-1.6
  • libotr-tools >= 4.1.1-1.6
  • libotr5 >= 4.1.1-1.6
Patchnames:
openSUSE Tumbleweed GA libotr-devel