Upstream information

CVE-2016-2779 at MITRE

Description

runuser in util-linux allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1000998 [RESOLVED / FIXED], 1018892 [RESOLVED], 946429 [IN_PROGRESS], 968375 [NEW], 968674 [IN_PROGRESS], 968675 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libblkid-devel >= 2.31.1-7.1
  • libblkid-devel-static >= 2.31.1-7.1
  • libblkid1 >= 2.31.1-7.1
  • libblkid1-32bit >= 2.31.1-7.1
  • libfdisk-devel >= 2.31.1-7.1
  • libfdisk1 >= 2.31.1-7.1
  • libmount-devel >= 2.31.1-7.1
  • libmount1 >= 2.31.1-7.1
  • libmount1-32bit >= 2.31.1-7.1
  • libsmartcols-devel >= 2.31.1-7.1
  • libsmartcols1 >= 2.31.1-7.1
  • libuuid-devel >= 2.31.1-7.1
  • libuuid-devel-static >= 2.31.1-7.1
  • libuuid1 >= 2.31.1-7.1
  • libuuid1-32bit >= 2.31.1-7.1
  • util-linux >= 2.31.1-7.1
  • util-linux-lang >= 2.31.1-7.1
  • util-linux-systemd >= 2.31.1-7.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libblkid-devel
SUSE Linux Enterprise Module for Server Applications 15
  • uuidd >= 2.31.1-7.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA uuidd
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libuuid-devel >= 2.29.2-2.3
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libuuid-devel
openSUSE Leap 15.0
  • libblkid1 >= 2.31.1-lp150.6.1
  • libblkid1-32bit >= 2.31.1-lp150.6.1
  • libfdisk1 >= 2.31.1-lp150.6.1
  • libmount1 >= 2.31.1-lp150.6.1
  • libsmartcols1 >= 2.31.1-lp150.6.1
  • libuuid1 >= 2.31.1-lp150.6.1
  • libuuid1-32bit >= 2.31.1-lp150.6.1
  • util-linux >= 2.31.1-lp150.6.1
  • util-linux-lang >= 2.31.1-lp150.6.1
  • util-linux-systemd >= 2.31.1-lp150.6.1
Patchnames:
openSUSE Leap 15.0 GA libblkid1
openSUSE Leap 42.2
  • libblkid-devel >= 2.28-5.10
  • libblkid1 >= 2.28-5.10
  • libblkid1-32bit >= 2.28-5.10
  • libfdisk1 >= 2.28-5.10
  • libmount1 >= 2.28-5.10
  • libmount1-32bit >= 2.28-5.10
  • libsmartcols1 >= 2.28-5.10
  • libuuid-devel >= 2.28-5.10
  • libuuid1 >= 2.28-5.10
  • libuuid1-32bit >= 2.28-5.10
  • util-linux >= 2.28-5.10
  • util-linux-lang >= 2.28-5.10
  • util-linux-systemd >= 2.28-5.2
Patchnames:
openSUSE Leap 42.2 GA libblkid-devel
openSUSE Tumbleweed
  • libblkid-devel >= 2.28.2-2.1
  • libblkid-devel-32bit >= 2.28.2-2.1
  • libblkid-devel-static >= 2.28.2-2.1
  • libblkid1 >= 2.28.2-2.1
  • libblkid1-32bit >= 2.28.2-2.1
  • libfdisk-devel >= 2.28.2-2.1
  • libfdisk-devel-static >= 2.28.2-2.1
  • libfdisk1 >= 2.28.2-2.1
  • libmount-devel >= 2.28.2-2.1
  • libmount-devel-32bit >= 2.28.2-2.1
  • libmount-devel-static >= 2.28.2-2.1
  • libmount1 >= 2.28.2-2.1
  • libmount1-32bit >= 2.28.2-2.1
  • libsmartcols-devel >= 2.28.2-2.1
  • libsmartcols-devel-static >= 2.28.2-2.1
  • libsmartcols1 >= 2.28.2-2.1
  • libuuid-devel >= 2.28.2-2.1
  • libuuid-devel-32bit >= 2.28.2-2.1
  • libuuid-devel-static >= 2.28.2-2.1
  • libuuid1 >= 2.28.2-2.1
  • libuuid1-32bit >= 2.28.2-2.1
  • python-libmount >= 2.28.2-2.1
  • util-linux >= 2.28.2-2.1
  • util-linux-lang >= 2.28.2-2.1
  • util-linux-systemd >= 2.28.2-2.1
  • uuidd >= 2.28.2-2.1
Patchnames:
openSUSE Tumbleweed GA libblkid-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 util-linux Affected
SUSE Linux Enterprise Desktop 12 GA util-linux Affected
SUSE Linux Enterprise Desktop 12 SP1 util-linux Affected
SUSE Linux Enterprise SDK 11 SP4 util-linux Affected
SUSE Linux Enterprise SDK 12 GA util-linux Affected
SUSE Linux Enterprise SDK 12 SP1 util-linux Affected
SUSE Linux Enterprise Server 11 SP3 util-linux Affected
SUSE Linux Enterprise Server 11 SP4 util-linux Affected
SUSE Linux Enterprise Server 12 GA util-linux Affected
SUSE Linux Enterprise Server 12 SP1 util-linux Affected
SUSE Linux Enterprise Workstation Extension 12 GA util-linux Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 util-linux Affected
SUSE Studio Onsite 1.3 util-linux Affected