Upstream information

CVE-2016-2776 at MITRE

Description

buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x before 9.11.0rc3 does not properly construct responses, which allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted query.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.79 7.79
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

Note from the SUSE Security Team

This issue affects all maintained versions of the BIND nameserver in SUSE Linux Enterprise Server and openSUSE.

SUSE Bugzilla entries: 1000362 [RESOLVED / FIXED], 1001595 [RESOLVED / DUPLICATE], 1001597 [RESOLVED / FIXED], 1007829 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • bind >= 9.9.9P1-46.1
  • bind-libs >= 9.9.9P1-46.1
  • bind-libs-32bit >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1399
SUSE Linux Enterprise Desktop 12 SP2
  • bind-libs >= 9.9.9P1-46.1
  • bind-libs-32bit >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA bind-libs-32bit
SUSE Linux Enterprise Point of Sale 11 SP3
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
sleposp3-bind-12763
SUSE Linux Enterprise Server 11 SP2-LTSS
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-devel >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-libs-32bit >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
slessp2-bind-12763
SUSE Linux Enterprise Server 11 SP3-LTSS
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-libs-32bit >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
slessp3-bind-12763
SUSE Linux Enterprise Server 11 SP4
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-libs-32bit >= 9.9.6P1-0.30.1
  • bind-libs-x86 >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
slessp4-bind-12763
SUSE Linux Enterprise Server 12 SP1
  • bind >= 9.9.9P1-46.1
  • bind-chrootenv >= 9.9.9P1-46.1
  • bind-doc >= 9.9.9P1-46.1
  • bind-libs >= 9.9.9P1-46.1
  • bind-libs-32bit >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1399
SUSE Linux Enterprise Server 12 SP2
  • bind >= 9.9.9P1-46.1
  • bind-chrootenv >= 9.9.9P1-46.1
  • bind-doc >= 9.9.9P1-46.1
  • bind-libs >= 9.9.9P1-46.1
  • bind-libs-32bit >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA bind
SUSE Linux Enterprise Server 12-LTSS
  • bind >= 9.9.9P1-28.20.1
  • bind-chrootenv >= 9.9.9P1-28.20.1
  • bind-doc >= 9.9.9P1-28.20.1
  • bind-libs >= 9.9.9P1-28.20.1
  • bind-libs-32bit >= 9.9.9P1-28.20.1
  • bind-utils >= 9.9.9P1-28.20.1
Patchnames:
SUSE-SLE-SERVER-12-2016-1400
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • bind >= 9.9.9P1-46.1
  • bind-chrootenv >= 9.9.9P1-46.1
  • bind-doc >= 9.9.9P1-46.1
  • bind-libs >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA bind
SUSE Linux Enterprise Software Development Kit 11 SP4
  • bind >= 9.9.6P1-0.30.1
  • bind-devel >= 9.9.6P1-0.30.1
  • bind-devel-32bit >= 9.9.6P1-0.30.1
Patchnames:
sdksp4-bind-12763
SUSE Linux Enterprise Software Development Kit 12 SP1
  • bind >= 9.9.9P1-46.1
  • bind-devel >= 9.9.9P1-46.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1399
SUSE Linux Enterprise Software Development Kit 12 SP2
  • bind-devel >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA bind-devel
SUSE Linux Enterprise for SAP 12
  • bind >= 9.9.9P1-28.20.1
  • bind-chrootenv >= 9.9.9P1-28.20.1
  • bind-doc >= 9.9.9P1-28.20.1
  • bind-libs >= 9.9.9P1-28.20.1
  • bind-libs-32bit >= 9.9.9P1-28.20.1
  • bind-utils >= 9.9.9P1-28.20.1
Patchnames:
SUSE-SLE-SAP-12-2016-1400
SUSE Manager 2.1
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-libs-32bit >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
sleman21-bind-12763
SUSE Manager Proxy 2.1
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-libs-32bit >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
slemap21-bind-12763
SUSE OpenStack Cloud 5
  • bind >= 9.9.6P1-0.30.1
  • bind-chrootenv >= 9.9.6P1-0.30.1
  • bind-doc >= 9.9.6P1-0.30.1
  • bind-libs >= 9.9.6P1-0.30.1
  • bind-libs-32bit >= 9.9.6P1-0.30.1
  • bind-utils >= 9.9.6P1-0.30.1
Patchnames:
sleclo50sp3-bind-12763
openSUSE 13.2
  • bind >= 9.9.6P1-2.22.1
  • bind-chrootenv >= 9.9.6P1-2.22.1
  • bind-debuginfo >= 9.9.6P1-2.22.1
  • bind-debugsource >= 9.9.6P1-2.22.1
  • bind-devel >= 9.9.6P1-2.22.1
  • bind-doc >= 9.9.6P1-2.22.1
  • bind-libs >= 9.9.6P1-2.22.1
  • bind-libs-32bit >= 9.9.6P1-2.22.1
  • bind-libs-debuginfo >= 9.9.6P1-2.22.1
  • bind-libs-debuginfo-32bit >= 9.9.6P1-2.22.1
  • bind-lwresd >= 9.9.6P1-2.22.1
  • bind-lwresd-debuginfo >= 9.9.6P1-2.22.1
  • bind-utils >= 9.9.6P1-2.22.1
  • bind-utils-debuginfo >= 9.9.6P1-2.22.1
Patchnames:
openSUSE-2016-1133
openSUSE Leap 42.1
  • bind >= 9.9.9P1-39.1
  • bind-chrootenv >= 9.9.9P1-39.1
  • bind-debuginfo >= 9.9.9P1-39.1
  • bind-debugsource >= 9.9.9P1-39.1
  • bind-devel >= 9.9.9P1-39.1
  • bind-doc >= 9.9.9P1-39.1
  • bind-libs >= 9.9.9P1-39.1
  • bind-libs-32bit >= 9.9.9P1-39.1
  • bind-libs-debuginfo >= 9.9.9P1-39.1
  • bind-libs-debuginfo-32bit >= 9.9.9P1-39.1
  • bind-lwresd >= 9.9.9P1-39.1
  • bind-lwresd-debuginfo >= 9.9.9P1-39.1
  • bind-utils >= 9.9.9P1-39.1
  • bind-utils-debuginfo >= 9.9.9P1-39.1
Patchnames:
openSUSE-2016-1133
openSUSE Leap 42.2
  • bind >= 9.9.9P1-41.1
  • bind-chrootenv >= 9.9.9P1-41.1
  • bind-doc >= 9.9.9P1-41.1
  • bind-libs >= 9.9.9P1-41.1
  • bind-utils >= 9.9.9P1-41.1
Patchnames:
openSUSE Leap 42.2 GA bind
openSUSE Tumbleweed
  • bind >= 9.10.3P4-21.1
  • bind-chrootenv >= 9.10.3P4-21.1
  • bind-devel >= 9.10.3P4-21.1
  • bind-devel-32bit >= 9.10.3P4-21.1
  • bind-doc >= 9.10.3P4-21.1
  • bind-lwresd >= 9.10.3P4-21.1
  • bind-utils >= 9.10.3P4-21.1
  • idnkit >= 1.0-21.1
  • idnkit-devel >= 1.0-21.1
  • idnkit-devel-32bit >= 1.0-21.1
  • libbind9-140 >= 9.10.3P4-21.1
  • libbind9-140-32bit >= 9.10.3P4-21.1
  • libdns162 >= 9.10.3P4-21.1
  • libdns162-32bit >= 9.10.3P4-21.1
  • libidnkit1 >= 1.0-21.1
  • libidnkit1-32bit >= 1.0-21.1
  • libidnkitlite1 >= 1.0-21.1
  • libidnkitlite1-32bit >= 1.0-21.1
  • libidnkitres1 >= 1.0-21.1
  • libidnkitres1-32bit >= 1.0-21.1
  • libirs-devel >= 9.10.3P4-21.1
  • libirs141 >= 9.10.3P4-21.1
  • libirs141-32bit >= 9.10.3P4-21.1
  • libisc160 >= 9.10.3P4-21.1
  • libisc160-32bit >= 9.10.3P4-21.1
  • libisccc140 >= 9.10.3P4-21.1
  • libisccc140-32bit >= 9.10.3P4-21.1
  • libisccfg140 >= 9.10.3P4-21.1
  • libisccfg140-32bit >= 9.10.3P4-21.1
  • liblwres141 >= 9.10.3P4-21.1
  • liblwres141-32bit >= 9.10.3P4-21.1
Patchnames:
openSUSE Tumbleweed GA bind


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 10 SP4 LTSS
bind