Upstream information

CVE-2016-2563 at MITRE

Description

Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 6.82
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 981407 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.2
  • putty >= 0.67-4.10.1
  • putty-debuginfo >= 0.67-4.10.1
  • putty-debugsource >= 0.67-4.10.1
Patchnames:
openSUSE-2016-667
openSUSE Leap 42.1
  • putty >= 0.67-9.1
  • putty-debuginfo >= 0.67-9.1
  • putty-debugsource >= 0.67-9.1
Patchnames:
openSUSE-2016-667