Upstream information

CVE-2016-2532 at MITRE

Description

The dissect_llrp_parameters function in epan/dissectors/packet-llrp.c in the LLRP dissector in Wireshark 1.12.x before 1.12.10 and 2.0.x before 2.0.2 does not limit the recursion depth, which allows remote attackers to cause a denial of service (memory consumption or application crash) via a crafted packet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 968565 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • wireshark >= 1.12.11-25.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-788
SUSE Linux Enterprise Desktop 12 SP1
  • wireshark >= 1.12.11-25.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-788
SUSE Linux Enterprise Desktop 12 SP2
  • wireshark >= 1.12.13-31.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA wireshark
SUSE Linux Enterprise Desktop 12 SP3
  • libwireshark8 >= 2.2.7-47.1
  • libwiretap6 >= 2.2.7-47.1
  • libwscodecs1 >= 2.2.7-47.1
  • libwsutil7 >= 2.2.7-47.1
  • wireshark >= 2.2.7-47.1
  • wireshark-gtk >= 2.2.7-47.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libwireshark8
SUSE Linux Enterprise Server 11 SP4
  • wireshark >= 1.12.11-0.18.1
Patchnames:
slessp4-wireshark-12565
SUSE Linux Enterprise Server 12
  • wireshark >= 1.12.11-25.1
Patchnames:
SUSE-SLE-SERVER-12-2016-788
SUSE Linux Enterprise Server 12 SP1
  • wireshark >= 1.12.11-25.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-788
SUSE Linux Enterprise Server 12 SP2
  • wireshark >= 1.12.13-31.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA wireshark
SUSE Linux Enterprise Server 12 SP3
  • libwireshark8 >= 2.2.7-47.1
  • libwiretap6 >= 2.2.7-47.1
  • libwscodecs1 >= 2.2.7-47.1
  • libwsutil7 >= 2.2.7-47.1
  • wireshark >= 2.2.7-47.1
  • wireshark-gtk >= 2.2.7-47.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libwireshark8
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • wireshark >= 1.12.13-31.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA wireshark
SUSE Linux Enterprise Software Development Kit 11 SP4
  • wireshark >= 1.12.11-0.18.1
  • wireshark-devel >= 1.12.11-0.18.1
Patchnames:
sdksp4-wireshark-12565
SUSE Linux Enterprise Software Development Kit 12
  • wireshark >= 1.12.11-25.1
  • wireshark-devel >= 1.12.11-25.1
Patchnames:
SUSE-SLE-SDK-12-2016-788
SUSE Linux Enterprise Software Development Kit 12 SP1
  • wireshark >= 1.12.11-25.1
  • wireshark-devel >= 1.12.11-25.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-788
SUSE Linux Enterprise Software Development Kit 12 SP2
  • wireshark-devel >= 1.12.13-31.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA wireshark-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • wireshark-devel >= 2.2.7-47.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA wireshark-devel
openSUSE 13.1
  • wireshark >= 1.12.10-50.1
  • wireshark-debuginfo >= 1.12.10-50.1
  • wireshark-debugsource >= 1.12.10-50.1
  • wireshark-devel >= 1.12.10-50.1
  • wireshark-ui-gtk >= 1.12.10-50.1
  • wireshark-ui-gtk-debuginfo >= 1.12.10-50.1
  • wireshark-ui-qt >= 1.12.10-50.1
  • wireshark-ui-qt-debuginfo >= 1.12.10-50.1
Patchnames:
2016-302
openSUSE Leap 42.1
  • wireshark >= 1.12.10-17.1
  • wireshark-debuginfo >= 1.12.10-17.1
  • wireshark-debugsource >= 1.12.10-17.1
  • wireshark-devel >= 1.12.10-17.1
  • wireshark-ui-gtk >= 1.12.10-17.1
  • wireshark-ui-gtk-debuginfo >= 1.12.10-17.1
  • wireshark-ui-qt >= 1.12.10-17.1
  • wireshark-ui-qt-debuginfo >= 1.12.10-17.1
Patchnames:
openSUSE-2016-301
openSUSE Leap 42.2
  • wireshark >= 2.2.1-1.1
  • wireshark-ui-gtk >= 2.2.1-1.1
Patchnames:
openSUSE Leap 42.2 GA wireshark
openSUSE Leap 42.3
  • wireshark >= 2.2.7-15.1
  • wireshark-ui-gtk >= 2.2.7-15.1
Patchnames:
openSUSE Leap 42.3 GA wireshark
openSUSE Tumbleweed
  • wireshark >= 2.2.2-1.1
  • wireshark-devel >= 2.2.2-1.1
  • wireshark-ui-gtk >= 2.2.2-1.1
  • wireshark-ui-qt >= 2.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA wireshark


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 wireshark Released
SUSE Linux Enterprise Desktop 11 SP3 wireshark Released
SUSE Linux Enterprise Desktop 11 SP4 wireshark In progress
SUSE Linux Enterprise Desktop 12 GA wireshark Released
SUSE Linux Enterprise Desktop 12 SP1 wireshark Released
SUSE Linux Enterprise SDK 11 SP2 wireshark Released
SUSE Linux Enterprise SDK 11 SP3 wireshark Released
SUSE Linux Enterprise SDK 11 SP4 wireshark In progress
SUSE Linux Enterprise SDK 12 GA wireshark Released
SUSE Linux Enterprise SDK 12 SP1 wireshark Released
SUSE Linux Enterprise Server 11 SP1 LTSS wireshark Released
SUSE Linux Enterprise Server 11 SP2 wireshark Released
SUSE Linux Enterprise Server 11 SP2 LTSS wireshark Released
SUSE Linux Enterprise Server 11 SP3 wireshark In progress
SUSE Linux Enterprise Server 11 SP3 LTSS wireshark Released
SUSE Linux Enterprise Server 11 SP4 wireshark In progress
SUSE Linux Enterprise Server 12 GA wireshark Released
SUSE Linux Enterprise Server 12 SP1 wireshark Released
SUSE Linux Enterprise Server for SAP 11 SP2 wireshark Released