Upstream information

CVE-2016-2510 at MITRE

Description

BeanShell (bsh) before 2.0b6, when included on the classpath by an application that uses Java serialization or XStream, allows remote attackers to execute arbitrary code via crafted serialized data, related to XThis.Handler.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 9.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 967593 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • bsh2 >= 2.0-318.1
  • bsh2-classgen >= 2.0-318.1
  • bsh2-javadoc >= 2.0-318.1
Patchnames:
sdksp4-bsh2-12441
SUSE Linux Enterprise Software Development Kit 12
  • bsh2 >= 2.0.0.b5-3.2
  • bsh2-classgen >= 2.0.0.b5-3.2
  • bsh2-javadoc >= 2.0.0.b5-3.2
Patchnames:
SUSE-SLE-SDK-12-2016-399
SUSE Linux Enterprise Software Development Kit 12 SP1
  • bsh2 >= 2.0.0.b5-3.2
  • bsh2-classgen >= 2.0.0.b5-3.2
  • bsh2-javadoc >= 2.0.0.b5-3.2
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-399
SUSE Linux Enterprise Software Development Kit 12 SP2
  • bsh2 >= 2.0.0.b5-3.2
  • bsh2-classgen >= 2.0.0.b5-3.2
  • bsh2-javadoc >= 2.0.0.b5-3.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA bsh2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • bsh2 >= 2.0.0.b5-3.2
  • bsh2-classgen >= 2.0.0.b5-3.2
  • bsh2-javadoc >= 2.0.0.b5-3.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA bsh2
openSUSE Leap 42.1
  • bsh2 >= 2.0.0.b5-30.1
  • bsh2-bsf >= 2.0.0.b5-30.1
  • bsh2-classgen >= 2.0.0.b5-30.1
  • bsh2-demo >= 2.0.0.b5-30.1
  • bsh2-javadoc >= 2.0.0.b5-30.1
  • bsh2-manual >= 2.0.0.b5-30.1
  • bsh2-src >= 2.0.0.b5-30.1
Patchnames:
openSUSE-2016-351
openSUSE Tumbleweed
  • bsh2 >= 2.0.0.b6-2.7
  • bsh2-bsf >= 2.0.0.b6-2.7
  • bsh2-classgen >= 2.0.0.b6-2.7
  • bsh2-demo >= 2.0.0.b6-2.7
  • bsh2-javadoc >= 2.0.0.b6-2.7
  • bsh2-manual >= 2.0.0.b6-2.7
Patchnames:
openSUSE Tumbleweed GA bsh2


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP2 bsh2 Released
SUSE Linux Enterprise SDK 11 SP3 bsh2 Released
SUSE Linux Enterprise SDK 11 SP4 bsh2 Released
SUSE Linux Enterprise SDK 12 GA bsh2 Released
SUSE Linux Enterprise SDK 12 SP1 bsh2 Released