Upstream information

CVE-2016-2464 at MITRE

Description

libvpx in libwebm in mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-06-01 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted mkv file, aka internal bug 23167726.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.3 6.8
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 984448 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libvpx-devel >= 1.6.0-2.1
  • libvpx4 >= 1.6.0-2.1
  • libvpx4-32bit >= 1.6.0-2.1
  • vpx-tools >= 1.6.0-2.1
Patchnames:
openSUSE Tumbleweed GA libvpx-devel


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA libvpx Not affected
SUSE Linux Enterprise Desktop 12 SP1 libvpx Unsupported
SUSE Linux Enterprise SDK 12 GA libvpx Not affected
SUSE Linux Enterprise SDK 12 SP1 libvpx Unsupported
SUSE Linux Enterprise Server 12 GA libvpx Not affected
SUSE Linux Enterprise Server 12 SP1 libvpx Unsupported
SUSE Linux Enterprise Workstation Extension 12 GA libvpx Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 libvpx Unsupported