Upstream information

CVE-2016-2324 at MITRE

Description

Integer overflow in Git before 2.7.4 allows remote attackers to execute arbitrary code via a (1) long filename or (2) many nested trees, which triggers a heap-based buffer overflow.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 10.00 6.82
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 971328 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12
  • git >= 1.8.5.6-18.1
  • git-core >= 1.8.5.6-18.1
Patchnames:
SUSE-SLE-SERVER-12-2016-467
SUSE Linux Enterprise Server 12 SP1
  • git >= 1.8.5.6-18.1
  • git-core >= 1.8.5.6-18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-467
SUSE Linux Enterprise Server 12 SP2
  • git-core >= 1.8.5.6-18.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA git-core
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • git-core >= 1.8.5.6-18.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA git-core
SUSE Linux Enterprise Software Development Kit 11 SP4
  • git >= 1.7.12.4-0.14.1
  • git-arch >= 1.7.12.4-0.14.1
  • git-core >= 1.7.12.4-0.14.1
  • git-cvs >= 1.7.12.4-0.14.1
  • git-daemon >= 1.7.12.4-0.14.1
  • git-email >= 1.7.12.4-0.14.1
  • git-gui >= 1.7.12.4-0.14.1
  • git-svn >= 1.7.12.4-0.14.1
  • git-web >= 1.7.12.4-0.14.1
  • gitk >= 1.7.12.4-0.14.1
Patchnames:
sdksp4-git-12460
SUSE Linux Enterprise Software Development Kit 12
  • git >= 1.8.5.6-18.1
  • git-arch >= 1.8.5.6-18.1
  • git-core >= 1.8.5.6-18.1
  • git-cvs >= 1.8.5.6-18.1
  • git-daemon >= 1.8.5.6-18.1
  • git-email >= 1.8.5.6-18.1
  • git-gui >= 1.8.5.6-18.1
  • git-svn >= 1.8.5.6-18.1
  • git-web >= 1.8.5.6-18.1
  • gitk >= 1.8.5.6-18.1
Patchnames:
SUSE-SLE-SDK-12-2016-467
SUSE Linux Enterprise Software Development Kit 12 SP1
  • git >= 1.8.5.6-18.1
  • git-arch >= 1.8.5.6-18.1
  • git-core >= 1.8.5.6-18.1
  • git-cvs >= 1.8.5.6-18.1
  • git-daemon >= 1.8.5.6-18.1
  • git-email >= 1.8.5.6-18.1
  • git-gui >= 1.8.5.6-18.1
  • git-svn >= 1.8.5.6-18.1
  • git-web >= 1.8.5.6-18.1
  • gitk >= 1.8.5.6-18.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-467
SUSE Linux Enterprise Software Development Kit 12 SP2
  • git >= 1.8.5.6-18.1
  • git-arch >= 1.8.5.6-18.1
  • git-core >= 1.8.5.6-18.1
  • git-cvs >= 1.8.5.6-18.1
  • git-daemon >= 1.8.5.6-18.1
  • git-email >= 1.8.5.6-18.1
  • git-gui >= 1.8.5.6-18.1
  • git-svn >= 1.8.5.6-18.1
  • git-web >= 1.8.5.6-18.1
  • gitk >= 1.8.5.6-18.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA git
SUSE OpenStack Cloud 5
  • git >= 1.7.12.4-0.14.1
  • git-core >= 1.7.12.4-0.14.1
Patchnames:
sleclo50sp3-git-12460
openSUSE 13.1
  • cgit >= 0.12-11.12.1
  • cgit-debuginfo >= 0.12-11.12.1
  • cgit-debugsource >= 0.12-11.12.1
  • git >= 1.8.4.5-3.14.1
  • git-arch >= 1.8.4.5-3.14.1
  • git-core >= 1.8.4.5-3.14.1
  • git-core-debuginfo >= 1.8.4.5-3.14.1
  • git-cvs >= 1.8.4.5-3.14.1
  • git-daemon >= 1.8.4.5-3.14.1
  • git-daemon-debuginfo >= 1.8.4.5-3.14.1
  • git-debugsource >= 1.8.4.5-3.14.1
  • git-email >= 1.8.4.5-3.14.1
  • git-gui >= 1.8.4.5-3.14.1
  • git-remote-helpers >= 1.8.4.5-3.14.1
  • git-svn >= 1.8.4.5-3.14.1
  • git-svn-debuginfo >= 1.8.4.5-3.14.1
  • git-web >= 1.8.4.5-3.14.1
  • gitk >= 1.8.4.5-3.14.1
Patchnames:
2016-366
2016-367
openSUSE 13.2
  • cgit >= 0.12-13.9.1
  • cgit-debuginfo >= 0.12-13.9.1
  • cgit-debugsource >= 0.12-13.9.1
  • git >= 2.1.4-19.1
  • git-arch >= 2.1.4-19.1
  • git-core >= 2.1.4-19.1
  • git-core-debuginfo >= 2.1.4-19.1
  • git-cvs >= 2.1.4-19.1
  • git-daemon >= 2.1.4-19.1
  • git-daemon-debuginfo >= 2.1.4-19.1
  • git-debugsource >= 2.1.4-19.1
  • git-doc >= 2.1.4-19.1
  • git-email >= 2.1.4-19.1
  • git-gui >= 2.1.4-19.1
  • git-svn >= 2.1.4-19.1
  • git-svn-debuginfo >= 2.1.4-19.1
  • git-web >= 2.1.4-19.1
  • gitk >= 2.1.4-19.1
Patchnames:
openSUSE-2016-355
openSUSE-2016-356
openSUSE Evergreen 11.4
  • cgit >= 0.8.3.3-5.11.1
  • cgit-debuginfo >= 0.8.3.3-5.11.1
  • cgit-debugsource >= 0.8.3.3-5.11.1
  • git >= 1.7.3.4-4.14.1
  • git-arch >= 1.7.3.4-4.14.1
  • git-core >= 1.7.3.4-4.14.1
  • git-core-debuginfo >= 1.7.3.4-4.14.1
  • git-cvs >= 1.7.3.4-4.14.1
  • git-daemon >= 1.7.3.4-4.14.1
  • git-daemon-debuginfo >= 1.7.3.4-4.14.1
  • git-debugsource >= 1.7.3.4-4.14.1
  • git-email >= 1.7.3.4-4.14.1
  • git-gui >= 1.7.3.4-4.14.1
  • git-remote-helpers >= 1.7.3.4-4.14.1
  • git-svn >= 1.7.3.4-4.14.1
  • git-svn-debuginfo >= 1.8.4.5-3.14.1
  • git-web >= 1.7.3.4-4.14.1
  • gitk >= 1.7.3.4-4.14.1
Patchnames:
2016-366
2016-367
openSUSE Leap 42.1
  • cgit >= 0.12-9.1
  • cgit-debuginfo >= 0.12-9.1
  • cgit-debugsource >= 0.12-9.1
  • git >= 2.6.6-7.1
  • git-arch >= 2.6.6-7.1
  • git-core >= 2.6.6-7.1
  • git-core-debuginfo >= 2.6.6-7.1
  • git-credential-gnome-keyring >= 2.6.6-7.1
  • git-credential-gnome-keyring-debuginfo >= 2.6.6-7.1
  • git-cvs >= 2.6.6-7.1
  • git-daemon >= 2.6.6-7.1
  • git-daemon-debuginfo >= 2.6.6-7.1
  • git-debugsource >= 2.6.6-7.1
  • git-doc >= 2.6.6-7.1
  • git-email >= 2.6.6-7.1
  • git-gui >= 2.6.6-7.1
  • git-svn >= 2.6.6-7.1
  • git-svn-debuginfo >= 2.6.6-7.1
  • git-web >= 2.6.6-7.1
  • gitk >= 2.6.6-7.1
Patchnames:
openSUSE-2016-355
openSUSE-2016-356
openSUSE-2016-428
openSUSE Leap 42.2
  • git >= 2.10.0-1.5
  • git-core >= 2.10.0-1.5
  • git-cvs >= 2.10.0-1.5
  • git-daemon >= 2.10.0-1.5
  • git-email >= 2.10.0-1.5
  • git-gui >= 2.10.0-1.5
  • git-svn >= 2.10.0-1.5
  • git-web >= 2.10.0-1.5
  • gitk >= 2.10.0-1.5
Patchnames:
openSUSE Leap 42.2 GA git
openSUSE Tumbleweed
  • cgit >= 1.0-1.3
  • git >= 2.11.0-1.1
  • git-arch >= 2.11.0-1.1
  • git-core >= 2.11.0-1.1
  • git-credential-gnome-keyring >= 2.11.0-1.1
  • git-cvs >= 2.11.0-1.1
  • git-daemon >= 2.11.0-1.1
  • git-doc >= 2.11.0-1.1
  • git-email >= 2.11.0-1.1
  • git-gui >= 2.11.0-1.1
  • git-svn >= 2.11.0-1.1
  • git-web >= 2.11.0-1.1
  • gitk >= 2.11.0-1.1
Patchnames:
openSUSE Tumbleweed GA cgit
openSUSE Tumbleweed GA git