Upstream information

CVE-2016-2193 at MITRE

Description

PostgreSQL before 9.5.x before 9.5.2 does not properly maintain row-security status in cached plans, which might allow attackers to bypass intended access restrictions by leveraging a session that performs queries as more than one role.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 3.56
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:N/AC:H/Au:S/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Low High
Authentication None Single
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
SUSE Bugzilla entry: 978456 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libecpg6 >= 9.5.4-1.2
  • libecpg6-32bit >= 9.5.4-1.2
  • libpq5 >= 9.5.4-1.2
  • libpq5-32bit >= 9.5.4-1.2
  • postgresql95 >= 9.5.4-1.2
  • postgresql95-contrib >= 9.5.4-1.2
  • postgresql95-devel >= 9.5.4-1.2
  • postgresql95-docs >= 9.5.4-1.2
  • postgresql95-plperl >= 9.5.4-1.2
  • postgresql95-plpython >= 9.5.4-1.2
  • postgresql95-pltcl >= 9.5.4-1.2
  • postgresql95-server >= 9.5.4-1.2
  • postgresql95-test >= 9.5.4-1.2
Patchnames:
openSUSE Tumbleweed GA libecpg6-32bit