Upstream information

CVE-2016-2168 at MITRE

Description

The req_check_access function in the mod_authz_svn module in the httpd server in Apache Subversion before 1.8.16 and 1.9.x before 1.9.4 allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) via a crafted header in a (1) MOVE or (2) COPY request, involving an authorization check.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.00
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 976850 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • subversion >= 1.6.17-1.35.1
  • subversion-devel >= 1.6.17-1.35.1
  • subversion-perl >= 1.6.17-1.35.1
  • subversion-python >= 1.6.17-1.35.1
  • subversion-server >= 1.6.17-1.35.1
  • subversion-tools >= 1.6.17-1.35.1
Patchnames:
sdksp4-subversion-12599
SUSE Linux Enterprise Software Development Kit 12
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-21.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-21.1
  • subversion >= 1.8.10-21.1
  • subversion-bash-completion >= 1.8.10-21.1
  • subversion-devel >= 1.8.10-21.1
  • subversion-perl >= 1.8.10-21.1
  • subversion-python >= 1.8.10-21.1
  • subversion-server >= 1.8.10-21.1
  • subversion-tools >= 1.8.10-21.1
Patchnames:
SUSE-SLE-SDK-12-2016-726
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-21.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-21.1
  • subversion >= 1.8.10-21.1
  • subversion-bash-completion >= 1.8.10-21.1
  • subversion-devel >= 1.8.10-21.1
  • subversion-perl >= 1.8.10-21.1
  • subversion-python >= 1.8.10-21.1
  • subversion-server >= 1.8.10-21.1
  • subversion-tools >= 1.8.10-21.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-726
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-24.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.10-24.1
  • subversion-bash-completion >= 1.8.10-24.1
  • subversion-devel >= 1.8.10-24.1
  • subversion-perl >= 1.8.10-24.1
  • subversion-python >= 1.8.10-24.1
  • subversion-server >= 1.8.10-24.1
  • subversion-tools >= 1.8.10-24.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libsvn_auth_gnome_keyring-1-0
SUSE Studio Onsite 1.3
  • subversion >= 1.6.17-1.35.1
Patchnames:
slestso13-subversion-12599
openSUSE 13.2
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.16-2.26.1
  • libsvn_auth_gnome_keyring-1-0-debuginfo >= 1.8.16-2.26.1
  • libsvn_auth_kwallet-1-0 >= 1.8.16-2.26.1
  • libsvn_auth_kwallet-1-0-debuginfo >= 1.8.16-2.26.1
  • subversion >= 1.8.16-2.26.1
  • subversion-bash-completion >= 1.8.16-2.26.1
  • subversion-debuginfo >= 1.8.16-2.26.1
  • subversion-debugsource >= 1.8.16-2.26.1
  • subversion-devel >= 1.8.16-2.26.1
  • subversion-perl >= 1.8.16-2.26.1
  • subversion-perl-debuginfo >= 1.8.16-2.26.1
  • subversion-python >= 1.8.16-2.26.1
  • subversion-python-ctypes >= 1.8.16-2.26.1
  • subversion-python-debuginfo >= 1.8.16-2.26.1
  • subversion-ruby >= 1.8.16-2.26.1
  • subversion-ruby-debuginfo >= 1.8.16-2.26.1
  • subversion-server >= 1.8.16-2.26.1
  • subversion-server-debuginfo >= 1.8.16-2.26.1
  • subversion-tools >= 1.8.16-2.26.1
  • subversion-tools-debuginfo >= 1.8.16-2.26.1
Patchnames:
openSUSE-2016-571
openSUSE Leap 42.1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-9.1
  • libsvn_auth_gnome_keyring-1-0-debuginfo >= 1.8.10-9.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-9.1
  • libsvn_auth_kwallet-1-0-debuginfo >= 1.8.10-9.1
  • subversion >= 1.8.10-9.1
  • subversion-bash-completion >= 1.8.10-9.1
  • subversion-debuginfo >= 1.8.10-9.1
  • subversion-debugsource >= 1.8.10-9.1
  • subversion-devel >= 1.8.10-9.1
  • subversion-perl >= 1.8.10-9.1
  • subversion-perl-debuginfo >= 1.8.10-9.1
  • subversion-python >= 1.8.10-9.1
  • subversion-python-debuginfo >= 1.8.10-9.1
  • subversion-ruby >= 1.8.10-9.1
  • subversion-ruby-debuginfo >= 1.8.10-9.1
  • subversion-server >= 1.8.10-9.1
  • subversion-server-debuginfo >= 1.8.10-9.1
  • subversion-tools >= 1.8.10-9.1
  • subversion-tools-debuginfo >= 1.8.10-9.1
Patchnames:
openSUSE-2016-570
openSUSE Leap 42.2
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.4-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.4-1.1
  • subversion >= 1.9.4-1.1
  • subversion-bash-completion >= 1.9.4-1.1
  • subversion-devel >= 1.9.4-1.1
  • subversion-perl >= 1.9.4-1.1
  • subversion-python >= 1.9.4-1.1
  • subversion-server >= 1.9.4-1.1
  • subversion-tools >= 1.9.4-1.1
Patchnames:
openSUSE Leap 42.2 GA libsvn_auth_gnome_keyring-1-0
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.5-1.1
  • subversion >= 1.9.5-1.1
  • subversion-bash-completion >= 1.9.5-1.1
  • subversion-devel >= 1.9.5-1.1
  • subversion-perl >= 1.9.5-1.1
  • subversion-python >= 1.9.5-1.1
  • subversion-python-ctypes >= 1.9.5-1.1
  • subversion-ruby >= 1.9.5-1.1
  • subversion-server >= 1.9.5-1.1
  • subversion-tools >= 1.9.5-1.1
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0