Upstream information

CVE-2016-2107 at MITRE

Description

The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session. NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-0169.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.6 7.1
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N AV:N/AC:M/Au:N/C:C/I:N/A:N
Access Vector Network Network
Access Complexity High Medium
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None

Note from the SUSE Security Team

This code is present only in AES-NI enhanced openssl code, which was not present in 0.9.8 and older. OpenSSL 0.9.8j and older are not affected.

SUSE Bugzilla entries: 976942 [RESOLVED / FIXED], 977584 [RESOLVED / FIXED], 977616 [RESOLVED / FIXED], 978492 [RESOLVED / FIXED], 990369 [RESOLVED / FIXED], 990370 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libopenssl1_0_0 >= 1.0.1i-27.16.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.16.1
  • openssl >= 1.0.1i-27.16.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-715
SUSE Linux Enterprise Desktop 12 SP1
  • libopenssl1_0_0 >= 1.0.1i-47.1
  • libopenssl1_0_0-32bit >= 1.0.1i-47.1
  • openssl >= 1.0.1i-47.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-717
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
  • libopenssl1_0_0 >= 1.0.2j-55.1
  • libopenssl1_0_0-32bit >= 1.0.2j-55.1
  • openssl >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Desktop 12 SP3
  • libopenssl-devel >= 1.0.2j-59.1
  • libopenssl1_0_0 >= 1.0.2j-59.1
  • libopenssl1_0_0-32bit >= 1.0.2j-59.1
  • openssl >= 1.0.2j-59.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libopenssl-devel
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE Linux Enterprise Server 11-SECURITY
  • libopenssl1-devel >= 1.0.1g-0.47.1
  • libopenssl1_0_0 >= 1.0.1g-0.47.1
  • libopenssl1_0_0-32bit >= 1.0.1g-0.47.1
  • libopenssl1_0_0-x86 >= 1.0.1g-0.47.1
  • openssl1 >= 1.0.1g-0.47.1
  • openssl1-doc >= 1.0.1g-0.47.1
Patchnames:
secsp3-openssl1-12539
SUSE Linux Enterprise Server 12
  • libopenssl1_0_0 >= 1.0.1i-27.16.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.16.1
  • libopenssl1_0_0-hmac >= 1.0.1i-27.16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-27.16.1
  • openssl >= 1.0.1i-27.16.1
  • openssl-doc >= 1.0.1i-27.16.1
Patchnames:
SUSE-SLE-SERVER-12-2016-715
SUSE Linux Enterprise Server 12 SP1
  • libopenssl1_0_0 >= 1.0.1i-47.1
  • libopenssl1_0_0-32bit >= 1.0.1i-47.1
  • libopenssl1_0_0-hmac >= 1.0.1i-47.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-47.1
  • openssl >= 1.0.1i-47.1
  • openssl-doc >= 1.0.1i-47.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-717
SUSE Linux Enterprise Server 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
  • libopenssl1_0_0 >= 1.0.2j-55.1
  • libopenssl1_0_0-32bit >= 1.0.2j-55.1
  • libopenssl1_0_0-hmac >= 1.0.2j-55.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-55.1
  • openssl >= 1.0.2j-55.1
  • openssl-doc >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Server 12 SP3
  • libopenssl-devel >= 1.0.2j-59.1
  • libopenssl1_0_0 >= 1.0.2j-59.1
  • libopenssl1_0_0-32bit >= 1.0.2j-59.1
  • libopenssl1_0_0-hmac >= 1.0.2j-59.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-59.1
  • openssl >= 1.0.2j-59.1
  • openssl-doc >= 1.0.2j-59.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libopenssl-devel
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
  • libopenssl1_0_0 >= 1.0.2j-55.1
  • libopenssl1_0_0-hmac >= 1.0.2j-55.1
  • openssl >= 1.0.2j-55.1
  • openssl-doc >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Software Development Kit 12
  • libopenssl-devel >= 1.0.1i-27.16.1
  • openssl >= 1.0.1i-27.16.1
Patchnames:
SUSE-SLE-SDK-12-2016-715
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libopenssl-devel >= 1.0.1i-47.1
  • openssl >= 1.0.1i-47.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-717
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libopenssl-devel >= 1.0.2j-59.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libopenssl-devel
openSUSE 13.1
  • libopenssl-devel >= 1.0.1k-11.87.1
  • libopenssl-devel-32bit >= 1.0.1k-11.87.1
  • libopenssl1_0_0 >= 1.0.1k-11.87.1
  • libopenssl1_0_0-32bit >= 1.0.1k-11.87.1
  • libopenssl1_0_0-debuginfo >= 1.0.1k-11.87.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1k-11.87.1
  • openssl >= 1.0.1k-11.87.1
  • openssl-debuginfo >= 1.0.1k-11.87.1
  • openssl-debugsource >= 1.0.1k-11.87.1
  • openssl-doc >= 1.0.1k-11.87.1
Patchnames:
2016-562
openSUSE Leap 42.1
  • libopenssl-devel >= 1.0.1i-15.1
  • libopenssl-devel-32bit >= 1.0.1i-15.1
  • libopenssl1_0_0 >= 1.0.1i-15.1
  • libopenssl1_0_0-32bit >= 1.0.1i-15.1
  • libopenssl1_0_0-debuginfo >= 1.0.1i-15.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1i-15.1
  • libopenssl1_0_0-hmac >= 1.0.1i-15.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-15.1
  • nodejs >= 4.4.5-27.1
  • nodejs-debuginfo >= 4.4.5-27.1
  • nodejs-debugsource >= 4.4.5-27.1
  • nodejs-devel >= 4.4.5-27.1
  • nodejs-docs >= 4.4.5-27.1
  • npm >= 4.4.5-27.1
  • openssl >= 1.0.1i-15.1
  • openssl-debuginfo >= 1.0.1i-15.1
  • openssl-debugsource >= 1.0.1i-15.1
  • openssl-doc >= 1.0.1i-15.1
Patchnames:
openSUSE-2016-564
openSUSE-2016-715
openSUSE Leap 42.2
  • libopenssl-devel >= 1.0.2j-2.2
  • libopenssl1_0_0 >= 1.0.2j-2.2
  • libopenssl1_0_0-32bit >= 1.0.2j-2.2
  • openssl >= 1.0.2j-2.2
Patchnames:
openSUSE Leap 42.2 GA libopenssl-devel
openSUSE Leap 42.3
  • libopenssl-devel >= 1.0.2j-7.3
  • libopenssl1_0_0 >= 1.0.2j-7.3
  • libopenssl1_0_0-32bit >= 1.0.2j-7.3
  • openssl >= 1.0.2j-7.3
Patchnames:
openSUSE Leap 42.3 GA libopenssl-devel
openSUSE Tumbleweed
  • libopenssl-devel >= 1.0.2j-2.2
  • libopenssl-devel-32bit >= 1.0.2j-2.2
  • libopenssl1_0_0 >= 1.0.2j-2.2
  • libopenssl1_0_0-32bit >= 1.0.2j-2.2
  • libopenssl1_0_0-hmac >= 1.0.2j-2.2
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-2.2
  • libopenssl1_0_0-steam >= 1.0.2h-4.1
  • libopenssl1_0_0-steam-32bit >= 1.0.2h-4.1
  • openssl >= 1.0.2j-2.2
  • openssl-doc >= 1.0.2j-2.2
Patchnames:
openSUSE Tumbleweed GA libopenssl-devel
openSUSE Tumbleweed GA libopenssl1_0_0-steam


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 compat-openssl097g Not affected
SUSE Linux Enterprise Desktop 11 SP4 openssl Not affected
SUSE Linux Enterprise Desktop 12 GA compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 GA openssl Released
SUSE Linux Enterprise Desktop 12 SP1 compat-openssl098 Unsupported
SUSE Linux Enterprise Desktop 12 SP1 openssl Released
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Not affected
SUSE Linux Enterprise SDK 11 SP4 openssl Not affected
SUSE Linux Enterprise SDK 12 GA openssl Released
SUSE Linux Enterprise SDK 12 SP1 openssl Released
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Released
SUSE Linux Enterprise Server 10 SP4 LTSS compat-openssl097g Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 GA openssl Released
SUSE Linux Enterprise Server 12 SP1 openssl Released
SUSE Linux Enterprise Server for SAP 11 SP4 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP 12 SP1 compat-openssl098 Not affected
SUSE Studio Onsite 1.3 openssl Not affected