Upstream information

CVE-2016-2105 at MITRE

Description

Integer overflow in the EVP_EncodeUpdate function in crypto/evp/encode.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to cause a denial of service (heap memory corruption) via a large amount of binary data.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 3.32
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having low severity.

SUSE Bugzilla entries: 1025347 [CONFIRMED], 977584 [RESOLVED / FIXED], 977614 [RESOLVED / FIXED], 978492 [RESOLVED / FIXED], 989902 [RESOLVED / INVALID], 990369 [RESOLVED / FIXED], 990370 [RESOLVED / FIXED], 991918 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • compat-openssl098 >= 0.9.8j-97.1
  • libopenssl0_9_8 >= 0.9.8j-97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-97.1
  • libopenssl1_0_0 >= 1.0.1i-27.16.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.16.1
  • openssl >= 1.0.1i-27.16.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-715
SUSE-SLE-DESKTOP-12-2016-735
SUSE Linux Enterprise Desktop 12 SP1
  • compat-openssl098 >= 0.9.8j-97.1
  • libopenssl0_9_8 >= 0.9.8j-97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-97.1
  • libopenssl1_0_0 >= 1.0.1i-47.1
  • libopenssl1_0_0-32bit >= 1.0.1i-47.1
  • openssl >= 1.0.1i-47.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-717
SUSE-SLE-DESKTOP-12-SP1-2016-735
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
  • libopenssl0_9_8 >= 0.9.8j-102.1
  • libopenssl0_9_8-32bit >= 0.9.8j-102.1
  • libopenssl1_0_0 >= 1.0.2j-55.1
  • libopenssl1_0_0-32bit >= 1.0.2j-55.1
  • openssl >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Desktop 12 SP2 GA libopenssl0_9_8
SUSE Linux Enterprise Module for Legacy Software 12
  • compat-openssl098 >= 0.9.8j-97.1
  • libopenssl0_9_8 >= 0.9.8j-97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-97.1
Patchnames:
SUSE-SLE-Module-Legacy-12-2016-735
SUSE Linux Enterprise Server 11 SP2-LTSS
  • libopenssl-devel >= 0.9.8j-0.97.1
  • libopenssl0_9_8 >= 0.9.8j-0.97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
  • openssl-doc >= 0.9.8j-0.97.1
Patchnames:
slessp2-openssl-12557
SUSE Linux Enterprise Server 11 SP3-LTSS
  • libopenssl-devel >= 0.9.8j-0.97.1
  • libopenssl0_9_8 >= 0.9.8j-0.97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
  • openssl-doc >= 0.9.8j-0.97.1
Patchnames:
slessp3-openssl-12557
SUSE Linux Enterprise Server 11 SP4
  • libopenssl0_9_8 >= 0.9.8j-0.97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
  • openssl-doc >= 0.9.8j-0.97.1
Patchnames:
slessp4-openssl-12557
SUSE Linux Enterprise Server 11-SECURITY
  • libopenssl1-devel >= 1.0.1g-0.47.1
  • libopenssl1_0_0 >= 1.0.1g-0.47.1
  • libopenssl1_0_0-32bit >= 1.0.1g-0.47.1
  • libopenssl1_0_0-x86 >= 1.0.1g-0.47.1
  • openssl1 >= 1.0.1g-0.47.1
  • openssl1-doc >= 1.0.1g-0.47.1
Patchnames:
secsp3-openssl1-12539
SUSE Linux Enterprise Server 12
  • libopenssl1_0_0 >= 1.0.1i-27.16.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.16.1
  • libopenssl1_0_0-hmac >= 1.0.1i-27.16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-27.16.1
  • openssl >= 1.0.1i-27.16.1
  • openssl-doc >= 1.0.1i-27.16.1
Patchnames:
SUSE-SLE-SERVER-12-2016-715
SUSE Linux Enterprise Server 12 SP1
  • libopenssl1_0_0 >= 1.0.1i-47.1
  • libopenssl1_0_0-32bit >= 1.0.1i-47.1
  • libopenssl1_0_0-hmac >= 1.0.1i-47.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-47.1
  • openssl >= 1.0.1i-47.1
  • openssl-doc >= 1.0.1i-47.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-717
SUSE Linux Enterprise Server 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
  • libopenssl1_0_0 >= 1.0.2j-55.1
  • libopenssl1_0_0-32bit >= 1.0.2j-55.1
  • libopenssl1_0_0-hmac >= 1.0.2j-55.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-55.1
  • openssl >= 1.0.2j-55.1
  • openssl-doc >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
  • libopenssl1_0_0 >= 1.0.2j-55.1
  • libopenssl1_0_0-hmac >= 1.0.2j-55.1
  • openssl >= 1.0.2j-55.1
  • openssl-doc >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libopenssl-devel >= 0.9.8j-0.97.1
  • libopenssl-devel-32bit >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
Patchnames:
sdksp4-openssl-12557
SUSE Linux Enterprise Software Development Kit 12
  • libopenssl-devel >= 1.0.1i-27.16.1
  • openssl >= 1.0.1i-27.16.1
Patchnames:
SUSE-SLE-SDK-12-2016-715
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libopenssl-devel >= 1.0.1i-47.1
  • openssl >= 1.0.1i-47.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-717
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libopenssl-devel >= 1.0.2j-55.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libopenssl-devel
SUSE Linux Enterprise for SAP 11 SP3
  • compat-openssl097g >= 0.9.7g-146.22.44.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.44.1
Patchnames:
slesappsp3-compat-openssl097g-12541
SUSE Linux Enterprise for SAP 11 SP4
  • compat-openssl097g >= 0.9.7g-146.22.44.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.44.1
Patchnames:
slesappsp4-compat-openssl097g-12541
SUSE Linux Enterprise for SAP 12 SP1
  • compat-openssl098 >= 0.9.8j-97.1
  • libopenssl0_9_8 >= 0.9.8j-97.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2016-735
SUSE Manager 2.1
  • libopenssl-devel >= 0.9.8j-0.97.1
  • libopenssl0_9_8 >= 0.9.8j-0.97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
  • openssl-doc >= 0.9.8j-0.97.1
Patchnames:
sleman21-openssl-12557
SUSE Manager Proxy 2.1
  • libopenssl-devel >= 0.9.8j-0.97.1
  • libopenssl0_9_8 >= 0.9.8j-0.97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
  • openssl-doc >= 0.9.8j-0.97.1
Patchnames:
slemap21-openssl-12557
SUSE OpenStack Cloud 5
  • libopenssl-devel >= 0.9.8j-0.97.1
  • libopenssl0_9_8 >= 0.9.8j-0.97.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.97.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
  • openssl-doc >= 0.9.8j-0.97.1
Patchnames:
sleclo50sp3-openssl-12557
SUSE Studio Onsite 1.3
  • libopenssl-devel >= 0.9.8j-0.97.1
  • openssl >= 0.9.8j-0.97.1
Patchnames:
slestso13-openssl-12557
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • openssl >= 0.9.8a-18.96.1
  • openssl-devel >= 0.9.8a-18.96.1
  • openssl-doc >= 0.9.8a-18.96.1
Builds
ZYPP Patch Nr: 9267
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.96.1
  • openssl-32bit >= 0.9.8a-18.96.1
  • openssl-devel >= 0.9.8a-18.96.1
  • openssl-devel-32bit >= 0.9.8a-18.96.1
  • openssl-doc >= 0.9.8a-18.96.1
Builds
ZYPP Patch Nr: 9267
openSUSE 13.1
  • libopenssl-devel >= 1.0.1k-11.87.1
  • libopenssl-devel-32bit >= 1.0.1k-11.87.1
  • libopenssl0_9_8 >= 0.9.8zh-5.3.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-5.3.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-5.3.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-5.3.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-5.3.1
  • libopenssl1_0_0 >= 1.0.1k-11.87.1
  • libopenssl1_0_0-32bit >= 1.0.1k-11.87.1
  • libopenssl1_0_0-debuginfo >= 1.0.1k-11.87.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1k-11.87.1
  • openssl >= 1.0.1k-11.87.1
  • openssl-debuginfo >= 1.0.1k-11.87.1
  • openssl-debugsource >= 1.0.1k-11.87.1
  • openssl-doc >= 1.0.1k-11.87.1
Patchnames:
2016-562
2016-563
openSUSE 13.2
  • libmysql56client18 >= 5.6.34-2.23.1
  • libmysql56client18-32bit >= 5.6.34-2.23.1
  • libmysql56client18-debuginfo >= 5.6.34-2.23.1
  • libmysql56client18-debuginfo-32bit >= 5.6.34-2.23.1
  • libmysql56client_r18 >= 5.6.34-2.23.1
  • libmysql56client_r18-32bit >= 5.6.34-2.23.1
  • libopenssl-devel >= 1.0.1k-2.36.1
  • libopenssl-devel-32bit >= 1.0.1k-2.36.1
  • libopenssl0_9_8 >= 0.9.8zh-9.6.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-9.6.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-9.6.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-9.6.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-9.6.1
  • libopenssl1_0_0 >= 1.0.1k-2.36.1
  • libopenssl1_0_0-32bit >= 1.0.1k-2.36.1
  • libopenssl1_0_0-debuginfo >= 1.0.1k-2.36.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1k-2.36.1
  • libopenssl1_0_0-hmac >= 1.0.1k-2.36.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1k-2.36.1
  • mysql-community-server >= 5.6.34-2.23.1
  • mysql-community-server-bench >= 5.6.34-2.23.1
  • mysql-community-server-bench-debuginfo >= 5.6.34-2.23.1
  • mysql-community-server-client >= 5.6.34-2.23.1
  • mysql-community-server-client-debuginfo >= 5.6.34-2.23.1
  • mysql-community-server-debuginfo >= 5.6.34-2.23.1
  • mysql-community-server-debugsource >= 5.6.34-2.23.1
  • mysql-community-server-errormessages >= 5.6.34-2.23.1
  • mysql-community-server-test >= 5.6.34-2.23.1
  • mysql-community-server-test-debuginfo >= 5.6.34-2.23.1
  • mysql-community-server-tools >= 5.6.34-2.23.1
  • mysql-community-server-tools-debuginfo >= 5.6.34-2.23.1
  • nodejs >= 4.4.5-18.1
  • nodejs-debuginfo >= 4.4.5-18.1
  • nodejs-debugsource >= 4.4.5-18.1
  • nodejs-devel >= 4.4.5-18.1
  • nodejs-doc >= 4.4.5-18.1
  • openssl >= 1.0.1k-2.36.1
  • openssl-debuginfo >= 1.0.1k-2.36.1
  • openssl-debugsource >= 1.0.1k-2.36.1
  • openssl-doc >= 1.0.1k-2.36.1
Patchnames:
openSUSE-2016-1283
openSUSE-2016-561
openSUSE-2016-565
openSUSE-2016-715
openSUSE Evergreen 11.4
  • libopenssl-devel >= 1.0.1p-74.1
  • libopenssl-devel-32bit >= 1.0.1p-74.1
  • libopenssl0_9_8 >= 0.9.8zh-14.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo-x86 >= 0.9.8zh-14.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-14.1
  • libopenssl0_9_8-x86 >= 0.9.8zh-14.1
  • libopenssl1_0_0 >= 1.0.1p-74.1
  • libopenssl1_0_0-32bit >= 1.0.1p-74.1
  • libopenssl1_0_0-debuginfo >= 1.0.1p-74.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1p-74.1
  • libopenssl1_0_0-debuginfo-x86 >= 1.0.1p-74.1
  • libopenssl1_0_0-x86 >= 1.0.1p-74.1
  • openssl >= 1.0.1p-74.1
  • openssl-debuginfo >= 1.0.1p-74.1
  • openssl-debugsource >= 1.0.1p-74.1
  • openssl-doc >= 1.0.1p-74.1
Patchnames:
2016-562
2016-563
openSUSE Leap 42.1
  • compat-openssl098 >= 0.9.8j-12.2
  • compat-openssl098-debugsource >= 0.9.8j-12.2
  • libmysql56client18 >= 5.6.34-19.2
  • libmysql56client18-32bit >= 5.6.34-19.2
  • libmysql56client18-debuginfo >= 5.6.34-19.2
  • libmysql56client18-debuginfo-32bit >= 5.6.34-19.2
  • libmysql56client_r18 >= 5.6.34-19.2
  • libmysql56client_r18-32bit >= 5.6.34-19.2
  • libopenssl-devel >= 1.0.1i-15.1
  • libopenssl-devel-32bit >= 1.0.1i-15.1
  • libopenssl0_9_8 >= 0.9.8j-12.2
  • libopenssl0_9_8-32bit >= 0.9.8j-12.2
  • libopenssl0_9_8-debuginfo >= 0.9.8j-12.2
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8j-12.2
  • libopenssl0_9_8-debugsource >= 0.9.8zh-17.1
  • libopenssl1_0_0 >= 1.0.1i-15.1
  • libopenssl1_0_0-32bit >= 1.0.1i-15.1
  • libopenssl1_0_0-debuginfo >= 1.0.1i-15.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1i-15.1
  • libopenssl1_0_0-hmac >= 1.0.1i-15.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-15.1
  • mysql-community-server >= 5.6.34-19.2
  • mysql-community-server-bench >= 5.6.34-19.2
  • mysql-community-server-bench-debuginfo >= 5.6.34-19.2
  • mysql-community-server-client >= 5.6.34-19.2
  • mysql-community-server-client-debuginfo >= 5.6.34-19.2
  • mysql-community-server-debuginfo >= 5.6.34-19.2
  • mysql-community-server-debugsource >= 5.6.34-19.2
  • mysql-community-server-errormessages >= 5.6.34-19.2
  • mysql-community-server-test >= 5.6.34-19.2
  • mysql-community-server-test-debuginfo >= 5.6.34-19.2
  • mysql-community-server-tools >= 5.6.34-19.2
  • mysql-community-server-tools-debuginfo >= 5.6.34-19.2
  • nodejs >= 4.4.5-27.1
  • nodejs-debuginfo >= 4.4.5-27.1
  • nodejs-debugsource >= 4.4.5-27.1
  • nodejs-devel >= 4.4.5-27.1
  • nodejs-doc >= 4.4.5-18.1
  • nodejs-docs >= 4.4.5-27.1
  • npm >= 4.4.5-27.1
  • openssl >= 1.0.1i-15.1
  • openssl-debuginfo >= 1.0.1i-15.1
  • openssl-debugsource >= 1.0.1i-15.1
  • openssl-doc >= 1.0.1i-15.1
Patchnames:
openSUSE-2016-1283
openSUSE-2016-564
openSUSE-2016-565
openSUSE-2016-575
openSUSE-2016-715
openSUSE Leap 42.2
  • libmysql56client18 >= 5.6.34-19.2
  • libmysql56client18-32bit >= 5.6.34-19.2
  • libmysql56client18-debuginfo >= 5.6.34-19.2
  • libmysql56client18-debuginfo-32bit >= 5.6.34-19.2
  • libmysql56client_r18 >= 5.6.34-19.2
  • libmysql56client_r18-32bit >= 5.6.34-19.2
  • libopenssl-devel >= 1.0.2j-2.2
  • libopenssl1_0_0 >= 1.0.2j-2.2
  • libopenssl1_0_0-32bit >= 1.0.2j-2.2
  • mysql-community-server >= 5.6.34-19.2
  • mysql-community-server-bench >= 5.6.34-19.2
  • mysql-community-server-bench-debuginfo >= 5.6.34-19.2
  • mysql-community-server-client >= 5.6.34-19.2
  • mysql-community-server-client-debuginfo >= 5.6.34-19.2
  • mysql-community-server-debuginfo >= 5.6.34-19.2
  • mysql-community-server-debugsource >= 5.6.34-19.2
  • mysql-community-server-errormessages >= 5.6.34-19.2
  • mysql-community-server-test >= 5.6.34-19.2
  • mysql-community-server-test-debuginfo >= 5.6.34-19.2
  • mysql-community-server-tools >= 5.6.34-19.2
  • mysql-community-server-tools-debuginfo >= 5.6.34-19.2
  • openssl >= 1.0.2j-2.2
Patchnames:
openSUSE Leap 42.2 GA libopenssl-devel
openSUSE-2016-1289
openSUSE Tumbleweed
  • libmysql56client18 >= 5.6.34-1.1
  • libmysql56client18-32bit >= 5.6.34-1.1
  • libmysql56client_r18 >= 5.6.34-1.1
  • libmysql56client_r18-32bit >= 5.6.34-1.1
  • libopenssl-devel >= 1.0.2j-2.2
  • libopenssl-devel-32bit >= 1.0.2j-2.2
  • libopenssl1_0_0 >= 1.0.2j-2.2
  • libopenssl1_0_0-32bit >= 1.0.2j-2.2
  • libopenssl1_0_0-hmac >= 1.0.2j-2.2
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-2.2
  • libopenssl1_0_0-steam >= 1.0.2h-4.1
  • libopenssl1_0_0-steam-32bit >= 1.0.2h-4.1
  • mysql-community-server >= 5.6.34-1.1
  • mysql-community-server-bench >= 5.6.34-1.1
  • mysql-community-server-client >= 5.6.34-1.1
  • mysql-community-server-errormessages >= 5.6.34-1.1
  • mysql-community-server-test >= 5.6.34-1.1
  • mysql-community-server-tools >= 5.6.34-1.1
  • openssl >= 1.0.2j-2.2
  • openssl-doc >= 1.0.2j-2.2
Patchnames:
openSUSE Tumbleweed GA libmysql56client18-32bit
openSUSE Tumbleweed GA libopenssl-devel
openSUSE Tumbleweed GA libopenssl1_0_0-steam


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 10 SP4 LTSS
compat-openssl097g
  • SUSE Linux Enterprise Server 10 SP4 LTSS
openssl