Upstream information

CVE-2016-1983 at MITRE

Description

The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 963152 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • privoxy >= 3.0.24-2.23.1
  • privoxy-debuginfo >= 3.0.24-2.23.1
  • privoxy-debugsource >= 3.0.24-2.23.1
  • privoxy-doc >= 3.0.24-2.23.1
Patchnames:
2016-132
openSUSE Leap 42.1
  • privoxy >= 3.0.24-6.1
  • privoxy-debuginfo >= 3.0.24-6.1
  • privoxy-debugsource >= 3.0.24-6.1
  • privoxy-doc >= 3.0.24-6.1
Patchnames:
openSUSE-2016-130
openSUSE Leap 42.2
  • privoxy >= 3.0.24-7.1
Patchnames:
openSUSE Leap 42.2 GA privoxy
openSUSE Leap 42.3
  • privoxy >= 3.0.24-9.1
Patchnames:
openSUSE Leap 42.3 GA privoxy
openSUSE Tumbleweed
  • privoxy >= 3.0.26-1.1
  • privoxy-doc >= 3.0.26-1.1
Patchnames:
openSUSE Tumbleweed GA privoxy