Upstream information

CVE-2016-1931 at MITRE

Description

Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 44.0 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to uninitialized memory encountered during brotli data compression, and other vectors.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 963633 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Desktop 12 SP3
  • MozillaFirefox >= 52.2.0esr-108.3
  • MozillaFirefox-translations >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP3
  • MozillaFirefox >= 52.2.0esr-108.3
  • MozillaFirefox-translations >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA MozillaFirefox
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Software Development Kit 12 SP2
  • MozillaFirefox-devel >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • MozillaFirefox-devel >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA MozillaFirefox-devel
openSUSE 13.1
  • MozillaFirefox >= 44.0-103.1
  • MozillaFirefox-branding-upstream >= 44.0-103.1
  • MozillaFirefox-buildsymbols >= 44.0-103.1
  • MozillaFirefox-debuginfo >= 44.0-103.1
  • MozillaFirefox-debugsource >= 44.0-103.1
  • MozillaFirefox-devel >= 44.0-103.1
  • MozillaFirefox-translations-common >= 44.0-103.1
  • MozillaFirefox-translations-other >= 44.0-103.1
  • libfreebl3 >= 3.21-68.1
  • libfreebl3-32bit >= 3.21-68.1
  • libfreebl3-debuginfo >= 3.21-68.1
  • libfreebl3-debuginfo-32bit >= 3.21-68.1
  • libsoftokn3 >= 3.21-68.1
  • libsoftokn3-32bit >= 3.21-68.1
  • libsoftokn3-debuginfo >= 3.21-68.1
  • libsoftokn3-debuginfo-32bit >= 3.21-68.1
  • mozilla-nspr >= 4.11-28.1
  • mozilla-nspr-32bit >= 4.11-28.1
  • mozilla-nspr-debuginfo >= 4.11-28.1
  • mozilla-nspr-debuginfo-32bit >= 4.11-28.1
  • mozilla-nspr-debugsource >= 4.11-28.1
  • mozilla-nspr-devel >= 4.11-28.1
  • mozilla-nss >= 3.21-68.1
  • mozilla-nss-32bit >= 3.21-68.1
  • mozilla-nss-certs >= 3.21-68.1
  • mozilla-nss-certs-32bit >= 3.21-68.1
  • mozilla-nss-certs-debuginfo >= 3.21-68.1
  • mozilla-nss-certs-debuginfo-32bit >= 3.21-68.1
  • mozilla-nss-debuginfo >= 3.21-68.1
  • mozilla-nss-debuginfo-32bit >= 3.21-68.1
  • mozilla-nss-debugsource >= 3.21-68.1
  • mozilla-nss-devel >= 3.21-68.1
  • mozilla-nss-sysinit >= 3.21-68.1
  • mozilla-nss-sysinit-32bit >= 3.21-68.1
  • mozilla-nss-sysinit-debuginfo >= 3.21-68.1
  • mozilla-nss-sysinit-debuginfo-32bit >= 3.21-68.1
  • mozilla-nss-tools >= 3.21-68.1
  • mozilla-nss-tools-debuginfo >= 3.21-68.1
Patchnames:
2016-131
openSUSE Leap 42.1
  • MozillaFirefox >= 44.0-12.2
  • MozillaFirefox-branding-upstream >= 44.0-12.2
  • MozillaFirefox-buildsymbols >= 44.0-12.2
  • MozillaFirefox-debuginfo >= 44.0-12.2
  • MozillaFirefox-debugsource >= 44.0-12.2
  • MozillaFirefox-devel >= 44.0-12.2
  • MozillaFirefox-translations-common >= 44.0-12.2
  • MozillaFirefox-translations-other >= 44.0-12.2
  • libfreebl3 >= 3.21-9.1
  • libfreebl3-32bit >= 3.21-9.1
  • libfreebl3-debuginfo >= 3.21-9.1
  • libfreebl3-debuginfo-32bit >= 3.21-9.1
  • libsoftokn3 >= 3.21-9.1
  • libsoftokn3-32bit >= 3.21-9.1
  • libsoftokn3-debuginfo >= 3.21-9.1
  • libsoftokn3-debuginfo-32bit >= 3.21-9.1
  • mozilla-nspr >= 4.11-7.1
  • mozilla-nspr-32bit >= 4.11-7.1
  • mozilla-nspr-debuginfo >= 4.11-7.1
  • mozilla-nspr-debuginfo-32bit >= 4.11-7.1
  • mozilla-nspr-debugsource >= 4.11-7.1
  • mozilla-nspr-devel >= 4.11-7.1
  • mozilla-nss >= 3.21-9.1
  • mozilla-nss-32bit >= 3.21-9.1
  • mozilla-nss-certs >= 3.21-9.1
  • mozilla-nss-certs-32bit >= 3.21-9.1
  • mozilla-nss-certs-debuginfo >= 3.21-9.1
  • mozilla-nss-certs-debuginfo-32bit >= 3.21-9.1
  • mozilla-nss-debuginfo >= 3.21-9.1
  • mozilla-nss-debuginfo-32bit >= 3.21-9.1
  • mozilla-nss-debugsource >= 3.21-9.1
  • mozilla-nss-devel >= 3.21-9.1
  • mozilla-nss-sysinit >= 3.21-9.1
  • mozilla-nss-sysinit-32bit >= 3.21-9.1
  • mozilla-nss-sysinit-debuginfo >= 3.21-9.1
  • mozilla-nss-sysinit-debuginfo-32bit >= 3.21-9.1
  • mozilla-nss-tools >= 3.21-9.1
  • mozilla-nss-tools-debuginfo >= 3.21-9.1
Patchnames:
openSUSE-2016-128
openSUSE Leap 42.2
  • MozillaFirefox >= 49.0.2-37.1
  • MozillaFirefox-translations-common >= 49.0.2-37.1
Patchnames:
openSUSE Leap 42.2 GA MozillaFirefox
openSUSE Leap 42.3
  • MozillaFirefox >= 52.2-58.2
  • MozillaFirefox-translations-common >= 52.2-58.2
Patchnames:
openSUSE Leap 42.3 GA MozillaFirefox
openSUSE Tumbleweed
  • MozillaFirefox >= 50.1.0-1.1
  • MozillaFirefox-branding-upstream >= 50.1.0-1.1
  • MozillaFirefox-buildsymbols >= 50.1.0-1.1
  • MozillaFirefox-devel >= 50.1.0-1.1
  • MozillaFirefox-translations-common >= 50.1.0-1.1
  • MozillaFirefox-translations-other >= 50.1.0-1.1
Patchnames:
openSUSE Tumbleweed GA MozillaFirefox


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 MozillaFirefox Analysis
SUSE Linux Enterprise Desktop 11 SP3 MozillaFirefox Analysis
SUSE Linux Enterprise Desktop 11 SP4 MozillaFirefox Analysis
SUSE Linux Enterprise Desktop 12 GA MozillaFirefox Analysis
SUSE Linux Enterprise Desktop 12 SP1 MozillaFirefox Unsupported
SUSE Linux Enterprise SDK 11 SP3 MozillaFirefox Analysis
SUSE Linux Enterprise SDK 11 SP4 MozillaFirefox Analysis
SUSE Linux Enterprise SDK 12 GA MozillaFirefox Analysis
SUSE Linux Enterprise Server 11 SP2 MozillaFirefox Analysis
SUSE Linux Enterprise Server 11 SP2 LTSS MozillaFirefox Analysis
SUSE Linux Enterprise Server 11 SP3 MozillaFirefox Analysis
SUSE Linux Enterprise Server 11 SP4 MozillaFirefox Analysis
SUSE Linux Enterprise Server 12 GA MozillaFirefox Analysis
SUSE Linux Enterprise Server 12 SP1 MozillaFirefox Unsupported