Upstream information

CVE-2016-1867 at MITRE

Description

The jpc_pi_nextcprl function in JasPer 1.900.1 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted JPEG 2000 image.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.30 4.30
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 961886 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1639
SUSE Linux Enterprise Desktop 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1639
SUSE Linux Enterprise Server 11 SP4
  • jasper >= 1.900.14-134.25.1
  • libjasper >= 1.900.14-134.25.1
  • libjasper-32bit >= 1.900.14-134.25.1
  • libjasper-x86 >= 1.900.14-134.25.1
Patchnames:
slessp4-jasper-12846
SUSE Linux Enterprise Server 12 SP1
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1639
SUSE Linux Enterprise Server 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1639
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1639
SUSE Linux Enterprise Software Development Kit 11 SP4
  • jasper >= 1.900.14-134.25.1
  • libjasper-devel >= 1.900.14-134.25.1
Patchnames:
sdksp4-jasper-12846
SUSE Linux Enterprise Software Development Kit 12 SP1
  • jasper >= 1.900.14-181.1
  • libjasper-devel >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1639
SUSE Linux Enterprise Software Development Kit 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper-devel >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1639
openSUSE 13.1
  • jasper >= 1.900.14-160.25.1
  • jasper-debuginfo >= 1.900.14-160.25.1
  • jasper-debugsource >= 1.900.14-160.25.1
  • libjasper-devel >= 1.900.14-160.25.1
  • libjasper1 >= 1.900.14-160.25.1
  • libjasper1-32bit >= 1.900.14-160.25.1
  • libjasper1-debuginfo >= 1.900.14-160.25.1
  • libjasper1-debuginfo-32bit >= 1.900.14-160.25.1
Patchnames:
2016-1270
2016-83
openSUSE 13.2
  • jasper >= 1.900.1-163.16.1
  • jasper-debuginfo >= 1.900.1-163.16.1
  • jasper-debugsource >= 1.900.1-163.16.1
  • libjasper-devel >= 1.900.1-163.16.1
  • libjasper1 >= 1.900.1-163.16.1
  • libjasper1-32bit >= 1.900.1-163.16.1
  • libjasper1-debuginfo >= 1.900.1-163.16.1
  • libjasper1-debuginfo-32bit >= 1.900.1-163.16.1
Patchnames:
openSUSE-2016-78
openSUSE Leap 42.1
  • jasper >= 1.900.14-166.1
  • jasper-debuginfo >= 1.900.14-166.1
  • jasper-debugsource >= 1.900.14-166.1
  • libjasper-devel >= 1.900.14-166.1
  • libjasper1 >= 1.900.14-166.1
  • libjasper1-32bit >= 1.900.14-166.1
  • libjasper1-debuginfo >= 1.900.14-166.1
  • libjasper1-debuginfo-32bit >= 1.900.14-166.1
Patchnames:
openSUSE-2016-1309
openSUSE Leap 42.2
  • jasper >= 1.900.14-167.1
  • jasper-debuginfo >= 1.900.14-167.1
  • jasper-debugsource >= 1.900.14-167.1
  • libjasper-devel >= 1.900.14-167.1
  • libjasper1 >= 1.900.14-167.1
  • libjasper1-32bit >= 1.900.14-167.1
  • libjasper1-debuginfo >= 1.900.14-167.1
  • libjasper1-debuginfo-32bit >= 1.900.14-167.1
Patchnames:
openSUSE-2016-1309
openSUSE Tumbleweed
  • jasper >= 1.900.14-3.1
  • libjasper-devel >= 1.900.14-3.1
  • libjasper1 >= 1.900.14-3.1
  • libjasper1-32bit >= 1.900.14-3.1
Patchnames:
openSUSE Tumbleweed GA jasper