Upstream information

CVE-2016-1836 at MITRE

Description

Use-after-free vulnerability in the xmlDictComputeFastKey function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to cause a denial of service via a crafted XML document.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 981110 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-2-32bit >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
  • python-libxml2 >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libxml2-2
SUSE Linux Enterprise Desktop 12 SP2 GA python-libxml2
SUSE Linux Enterprise Desktop 12 SP3
  • libxml2-2 >= 2.9.4-45.1
  • libxml2-2-32bit >= 2.9.4-45.1
  • libxml2-tools >= 2.9.4-45.1
  • python-libxml2 >= 2.9.4-45.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libxml2-2
SUSE Linux Enterprise Desktop 12 SP3 GA python-libxml2
SUSE Linux Enterprise Server 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-2-32bit >= 2.9.4-27.1
  • libxml2-doc >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
  • python-libxml2 >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libxml2-2
SUSE Linux Enterprise Server 12 SP2 GA python-libxml2
SUSE Linux Enterprise Server 12 SP3
  • libxml2-2 >= 2.9.4-45.1
  • libxml2-2-32bit >= 2.9.4-45.1
  • libxml2-doc >= 2.9.4-45.1
  • libxml2-tools >= 2.9.4-45.1
  • python-libxml2 >= 2.9.4-45.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libxml2-2
SUSE Linux Enterprise Server 12 SP3 GA python-libxml2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-doc >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
  • python-libxml2 >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libxml2-2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA python-libxml2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2-devel >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libxml2-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libxml2-devel >= 2.9.4-45.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libxml2-devel
openSUSE Leap 42.2
  • libxml2-2 >= 2.9.4-1.4
  • libxml2-2-32bit >= 2.9.4-1.4
  • libxml2-devel >= 2.9.4-1.4
  • libxml2-tools >= 2.9.4-1.4
  • python-libxml2 >= 2.9.4-1.3
Patchnames:
openSUSE Leap 42.2 GA libxml2-2
openSUSE Leap 42.2 GA python-libxml2
openSUSE Leap 42.3
  • libxml2-2 >= 2.9.4-10.1
  • libxml2-2-32bit >= 2.9.4-10.1
  • libxml2-devel >= 2.9.4-10.1
  • libxml2-tools >= 2.9.4-10.1
  • python-libxml2 >= 2.9.4-10.1
Patchnames:
openSUSE Leap 42.3 GA libxml2-2
openSUSE Leap 42.3 GA python-libxml2
openSUSE Tumbleweed
  • libxml2-2 >= 2.9.4-1.22
  • libxml2-2-32bit >= 2.9.4-1.22
  • libxml2-devel >= 2.9.4-1.22
  • libxml2-devel-32bit >= 2.9.4-1.22
  • libxml2-doc >= 2.9.4-1.22
  • libxml2-tools >= 2.9.4-1.22
  • python-libxml2 >= 2.9.4-1.4
Patchnames:
openSUSE Tumbleweed GA libxml2-2
openSUSE Tumbleweed GA python-libxml2


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 libxml2 Affected
SUSE Linux Enterprise Desktop 12 GA libxml2 Affected
SUSE Linux Enterprise Desktop 12 SP1 libxml2 Unsupported
SUSE Linux Enterprise SDK 11 SP4 libxml2 Affected
SUSE Linux Enterprise SDK 12 GA libxml2 Affected
SUSE Linux Enterprise SDK 12 SP1 libxml2 Unsupported
SUSE Linux Enterprise Server 10 SP4 LTSS libxml2 Affected
SUSE Linux Enterprise Server 11 SP2 LTSS libxml2 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS libxml2 Affected
SUSE Linux Enterprise Server 11 SP4 libxml2 Affected
SUSE Linux Enterprise Server 12 GA libxml2 Affected
SUSE Linux Enterprise Server 12 SP1 libxml2 Unsupported