Upstream information

CVE-2016-1688 at MITRE

Description

The regexp (aka regular expression) implementation in Google V8 before 5.0.71.40, as used in Google Chrome before 51.0.2704.63, mishandles external string sizes, which allows remote attackers to cause a denial of service (out-of-bounds read) via crafted JavaScript code.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 981886 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • chromium >= 66.0.3359.170-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA chromium
openSUSE Leap 42.1
  • chromedriver >= 51.0.2704.63-51.1
  • chromedriver-debuginfo >= 51.0.2704.63-51.1
  • chromium >= 51.0.2704.63-51.1
  • chromium-debuginfo >= 51.0.2704.63-51.1
  • chromium-debugsource >= 51.0.2704.63-51.1
  • chromium-desktop-gnome >= 51.0.2704.63-51.1
  • chromium-desktop-kde >= 51.0.2704.63-51.1
  • chromium-ffmpegsumo >= 51.0.2704.63-51.1
  • chromium-ffmpegsumo-debuginfo >= 51.0.2704.63-51.1
Patchnames:
openSUSE-2016-652
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
Patchnames:
openSUSE Tumbleweed GA chromedriver