Upstream information

CVE-2016-1669 at MITRE

Description

The Zone::New function in zone.cc in Google V8 before 5.0.71.47, as used in Google Chrome before 50.0.2661.102, does not properly determine when to expand certain memory allocations, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted JavaScript code.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.3 6.8
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 979859 [RESOLVED / FIXED], 987919 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.5.0-5.1
  • nodejs4-devel >= 4.5.0-5.1
  • nodejs4-docs >= 4.5.0-5.1
  • npm4 >= 4.5.0-5.1
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 12 GA nodejs4
openSUSE 13.1
  • chromedriver >= 51.0.2704.103-147.1
  • chromedriver-debuginfo >= 51.0.2704.103-147.1
  • chromium >= 51.0.2704.103-147.1
  • chromium-debuginfo >= 51.0.2704.103-147.1
  • chromium-debugsource >= 51.0.2704.103-147.1
  • chromium-desktop-gnome >= 51.0.2704.103-147.1
  • chromium-desktop-kde >= 51.0.2704.103-147.1
  • chromium-ffmpegsumo >= 51.0.2704.103-147.1
  • chromium-ffmpegsumo-debuginfo >= 51.0.2704.103-147.1
Patchnames:
2016-756
openSUSE Leap 42.1
  • chromedriver >= 50.0.2661.102-48.1
  • chromedriver-debuginfo >= 50.0.2661.102-48.1
  • chromium >= 50.0.2661.102-48.1
  • chromium-debuginfo >= 50.0.2661.102-48.1
  • chromium-debugsource >= 50.0.2661.102-48.1
  • chromium-desktop-gnome >= 50.0.2661.102-48.1
  • chromium-desktop-kde >= 50.0.2661.102-48.1
  • chromium-ffmpegsumo >= 50.0.2661.102-48.1
  • chromium-ffmpegsumo-debuginfo >= 50.0.2661.102-48.1
  • nodejs >= 4.6.0-33.1
  • nodejs-debuginfo >= 4.6.0-33.1
  • nodejs-debugsource >= 4.6.0-33.1
  • nodejs-devel >= 4.6.0-33.1
  • nodejs-docs >= 4.6.0-33.1
  • npm >= 4.6.0-33.1
Patchnames:
openSUSE-2016-1172
openSUSE-2016-584
openSUSE-2016-884
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
  • nodejs4 >= 4.7.0-1.1
  • nodejs4-devel >= 4.7.0-1.1
  • nodejs4-docs >= 4.7.0-1.1
  • npm4 >= 4.7.0-1.1
Patchnames:
openSUSE Tumbleweed GA chromedriver
openSUSE Tumbleweed GA nodejs4