Upstream information

CVE-2016-1251 at MITRE

Description

There is a vulnerability of type use-after-free affecting DBD::mysql (aka DBD-mysql or the Database Interface (DBI) MySQL driver for Perl) 3.x and 4.x before 4.041 when used with mysql_server_prepare=1.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.82 5.10
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1012546 [RESOLVED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
  • perl-DBD-mysql >= 4.008-6.1
Patchnames:
slessp4-perl-DBD-mysql-12927
SUSE Linux Enterprise Server 12 SP1
  • perl-DBD-mysql >= 4.021-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-65
SUSE Linux Enterprise Server 12 SP2
  • perl-DBD-mysql >= 4.021-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-65
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • perl-DBD-mysql >= 4.021-11.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-65
SUSE Linux Enterprise Software Development Kit 11 SP4
  • perl-DBD-mysql >= 4.008-6.1
Patchnames:
sdksp4-perl-DBD-mysql-12927
openSUSE 13.2
  • perl-DBD-mysql >= 4.021-8.3.1
  • perl-DBD-mysql-debuginfo >= 4.021-8.3.1
  • perl-DBD-mysql-debugsource >= 4.021-8.3.1
Patchnames:
openSUSE-2016-1441
openSUSE Leap 42.1
  • perl-DBD-mysql >= 4.021-13.1
  • perl-DBD-mysql-debuginfo >= 4.021-13.1
  • perl-DBD-mysql-debugsource >= 4.021-13.1
Patchnames:
openSUSE-2017-130
openSUSE Leap 42.2
  • perl-DBD-mysql >= 4.021-14.1
  • perl-DBD-mysql-debuginfo >= 4.021-14.1
  • perl-DBD-mysql-debugsource >= 4.021-14.1
Patchnames:
openSUSE-2017-130
openSUSE Tumbleweed
  • perl-DBD-mysql >= 4.041-2.1
Patchnames:
openSUSE Tumbleweed GA perl-DBD-mysql


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
perl-DBD-mysql