Upstream information

CVE-2016-1248 at MITRE

Description

vim before patch 8.0.0056 does not properly validate values for the 'filetype', 'syntax' and 'keymap' options, which may result in the execution of arbitrary code if a file with a specially crafted modeline is opened.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.6
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1010685 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gvim >= 7.4.326-7.1
  • vim >= 7.4.326-7.1
  • vim-data >= 7.4.326-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1721
SUSE Linux Enterprise Desktop 12 SP2
  • gvim >= 7.4.326-7.1
  • vim >= 7.4.326-7.1
  • vim-data >= 7.4.326-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1721
SUSE Linux Enterprise Desktop 12 SP3
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gvim
SUSE Linux Enterprise Server 11 SP4
  • gvim >= 7.2-8.17.1
  • vim >= 7.2-8.17.1
  • vim-base >= 7.2-8.17.1
  • vim-data >= 7.2-8.17.1
Patchnames:
slessp4-vim-12862
SUSE Linux Enterprise Server 12 SP1
  • gvim >= 7.4.326-7.1
  • vim >= 7.4.326-7.1
  • vim-data >= 7.4.326-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1721
SUSE Linux Enterprise Server 12 SP2
  • gvim >= 7.4.326-7.1
  • vim >= 7.4.326-7.1
  • vim-data >= 7.4.326-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1721
SUSE Linux Enterprise Server 12 SP3
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gvim
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gvim >= 7.4.326-7.1
  • vim >= 7.4.326-7.1
  • vim-data >= 7.4.326-7.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1721
openSUSE Leap 42.1
  • gvim >= 7.4.326-8.1
  • gvim-debuginfo >= 7.4.326-8.1
  • vim >= 7.4.326-8.1
  • vim-data >= 7.4.326-8.1
  • vim-debuginfo >= 7.4.326-8.1
  • vim-debugsource >= 7.4.326-8.1
Patchnames:
openSUSE-2016-1391
openSUSE Leap 42.2
  • gvim >= 7.4.326-8.2
  • gvim-debuginfo >= 7.4.326-8.2
  • vim >= 7.4.326-8.2
  • vim-data >= 7.4.326-8.2
  • vim-debuginfo >= 7.4.326-8.2
  • vim-debugsource >= 7.4.326-8.2
Patchnames:
openSUSE-2016-1390
openSUSE Leap 42.3
  • gvim >= 7.4.326-12.1
  • vim >= 7.4.326-12.1
  • vim-data >= 7.4.326-12.1
Patchnames:
openSUSE Leap 42.3 GA gvim


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 vim Released
SUSE Linux Enterprise Desktop 12 SP2 vim Released
SUSE Linux Enterprise Server 11 SP4 vim Released
SUSE Linux Enterprise Server 12 SP1 vim Released
SUSE Linux Enterprise Server 12 SP2 vim Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI vim Released