Upstream information

CVE-2016-1245 at MITRE

Description

It was discovered that the zebra daemon in Quagga before 1.0.20161017 suffered from a stack-based buffer overflow when processing IPv6 Neighbor Discovery messages. The root cause was relying on BUFSIZ to be compatible with a message size; however, BUFSIZ is system-dependent.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 6.82
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having important severity.

SUSE Bugzilla entry: 1005258 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
  • quagga >= 0.99.15-0.29.1
Patchnames:
slessp4-quagga-12800
SUSE Linux Enterprise Server 12 SP1
  • quagga >= 0.99.22.1-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1537
SUSE Linux Enterprise Software Development Kit 11 SP4
  • quagga >= 0.99.15-0.29.1
  • quagga-devel >= 0.99.15-0.29.1
Patchnames:
sdksp4-quagga-12800
SUSE Linux Enterprise Software Development Kit 12 SP1
  • quagga >= 0.99.22.1-15.1
  • quagga-devel >= 0.99.22.1-15.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1537
openSUSE 13.2
  • quagga >= 0.99.23-2.12.1
  • quagga-debuginfo >= 0.99.23-2.12.1
  • quagga-debugsource >= 0.99.23-2.12.1
  • quagga-devel >= 0.99.23-2.12.1
Patchnames:
openSUSE-2016-1225
openSUSE Leap 42.1
  • quagga >= 0.99.24.1-14.1
  • quagga-debuginfo >= 0.99.24.1-14.1
  • quagga-debugsource >= 0.99.24.1-14.1
  • quagga-devel >= 0.99.24.1-14.1
Patchnames:
openSUSE-2016-1233
openSUSE Leap 42.2
  • quagga >= 0.99.24.1-15.1
Patchnames:
openSUSE Leap 42.2 GA quagga
openSUSE Tumbleweed
  • libospf0 >= 1.0.20160315-5.1
  • libospfapiclient0 >= 1.0.20160315-5.1
  • libzebra0 >= 1.0.20160315-5.1
  • quagga >= 1.0.20160315-5.1
  • quagga-devel >= 1.0.20160315-5.1
Patchnames:
openSUSE Tumbleweed GA libospf0


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 10 SP4 LTSS
quagga