Upstream information

CVE-2016-1238 at MITRE

Description

(1) cpan/Archive-Tar/bin/ptar, (2) cpan/Archive-Tar/bin/ptardiff, (3) cpan/Archive-Tar/bin/ptargrep, (4) cpan/CPAN/scripts/cpan, (5) cpan/Digest-SHA/shasum, (6) cpan/Encode/bin/enc2xs, (7) cpan/Encode/bin/encguess, (8) cpan/Encode/bin/piconv, (9) cpan/Encode/bin/ucmlint, (10) cpan/Encode/bin/unidump, (11) cpan/ExtUtils-MakeMaker/bin/instmodsh, (12) cpan/IO-Compress/bin/zipdetails, (13) cpan/JSON-PP/bin/json_pp, (14) cpan/Test-Harness/bin/prove, (15) dist/ExtUtils-ParseXS/lib/ExtUtils/xsubpp, (16) dist/Module-CoreList/corelist, (17) ext/Pod-Html/bin/pod2html, (18) utils/c2ph.PL, (19) utils/h2ph.PL, (20) utils/h2xs.PL, (21) utils/libnetcfg.PL, (22) utils/perlbug.PL, (23) utils/perldoc.PL, (24) utils/perlivp.PL, and (25) utils/splain.PL in Perl 5.x before 5.22.3-RC2 and 5.24 before 5.24.1-RC2 do not properly remove . (period) characters from the end of the includes directory array, which might allow local users to gain privileges via a Trojan horse module under the current working directory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.2 4.6
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 6.7
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low High
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entries: 1108749 [NEW], 987887 [NEW], 988311 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1326
SUSE Linux Enterprise Desktop 12 SP2
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA perl-32bit
SUSE Linux Enterprise Desktop 12 SP3
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA perl-32bit
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE Linux Enterprise Module for Desktop Applications 15
  • perl-MIME-Charset >= 1.012.2-1.24
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA perl-MIME-Charset
SUSE Linux Enterprise Module for Development Tools 15
  • perl-Archive-Extract >= 0.80-1.24
  • perl-ExtUtils-MakeMaker >= 7.30-1.24
  • perl-Module-Load-Conditional >= 0.68-1.25
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA perl-Archive-Extract
SUSE Linux Enterprise Server 11 SP4
  • perl >= 5.10.0-64.80.1
  • perl-32bit >= 5.10.0-64.80.1
  • perl-Module-Build >= 0.2808.01-0.80.1
  • perl-Test-Simple >= 0.72-0.80.1
  • perl-base >= 5.10.0-64.80.1
  • perl-doc >= 5.10.0-64.80.1
  • perl-x86 >= 5.10.0-64.80.1
Patchnames:
slessp4-perl-12729
SUSE Linux Enterprise Server 12 SP1
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1326
SUSE Linux Enterprise Server 12 SP2
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA perl-32bit
SUSE Linux Enterprise Server 12 SP3
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA perl-32bit
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • perl >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA perl
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • perl >= 5.10.0-64.80.1
  • perl-32bit >= 5.10.0-64.80.1
  • perl-Module-Build >= 0.2808.01-0.80.1
  • perl-Test-Simple >= 0.72-0.80.1
  • perl-base >= 5.10.0-64.80.1
  • perl-doc >= 5.10.0-64.80.1
  • perl-x86 >= 5.10.0-64.80.1
Patchnames:
slessp4-perl-12729
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1326
SUSE Linux Enterprise Software Development Kit 11 SP4
  • perl >= 5.10.0-64.80.1
  • perl-base-32bit >= 5.10.0-64.80.1
Patchnames:
sdksp4-perl-12729
openSUSE Leap 42.1
  • perl >= 5.18.2-5.1
  • perl-32bit >= 5.18.2-5.1
  • perl-base >= 5.18.2-5.1
  • perl-base-32bit >= 5.18.2-5.1
  • perl-base-debuginfo >= 5.18.2-5.1
  • perl-base-debuginfo-32bit >= 5.18.2-5.1
  • perl-debuginfo >= 5.18.2-5.1
  • perl-debuginfo-32bit >= 5.18.2-5.1
  • perl-debugsource >= 5.18.2-5.1
  • perl-doc >= 5.18.2-5.1
Patchnames:
openSUSE-2016-1086
openSUSE Leap 42.2
  • perl >= 5.18.2-5.6
  • perl-32bit >= 5.18.2-5.6
  • perl-base >= 5.18.2-5.6
  • perl-doc >= 5.18.2-5.6
Patchnames:
openSUSE Leap 42.2 GA perl-32bit
openSUSE Leap 42.3
  • perl >= 5.18.2-7.15
  • perl-32bit >= 5.18.2-7.15
  • perl-base >= 5.18.2-7.15
  • perl-doc >= 5.18.2-7.15
Patchnames:
openSUSE Leap 42.3 GA perl-32bit
openSUSE Tumbleweed
  • perl-Archive-Extract >= 0.78-1.1
  • perl-HTTP-Tiny >= 0.070-1.1
  • perl-Module-Load-Conditional >= 0.68-1.1
Patchnames:
openSUSE Tumbleweed GA perl-Archive-Extract


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 spamassassin Affected
SUSE Linux Enterprise Module for Basesystem 15 GA spamassassin Affected
SUSE Linux Enterprise Module for Development Tools 15 GA spamassassin Affected
SUSE Linux Enterprise Server 11 SP3 LTSS spamassassin Affected
SUSE Linux Enterprise Server 11 SP4 spamassassin Affected
SUSE Linux Enterprise Server 12 GA LTSS spamassassin Affected
SUSE Linux Enterprise Server 12 SP1 LTSS spamassassin Affected
SUSE Linux Enterprise Server 12 SP2 LTSS spamassassin Affected
SUSE Linux Enterprise Server 12 SP3 spamassassin Affected