Upstream information

CVE-2016-10171 at MITRE

Description

The unreorder_channels function in cli/wvunpack.c in Wavpack before 5.1.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted WV file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 4.4
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1021483 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-414
SUSE Linux Enterprise Desktop 12 SP3
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-414
SUSE Linux Enterprise Server 11 SP4
  • libwavpack1 >= 4.50.1-1.27.1
  • wavpack >= 4.50.1-1.27.1
Patchnames:
slessp4-wavpack-13499
SUSE Linux Enterprise Server 12 SP2
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-414
SUSE Linux Enterprise Server 12 SP3
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-414
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-414
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libwavpack1 >= 4.50.1-1.27.1
  • wavpack >= 4.50.1-1.27.1
Patchnames:
slessp4-wavpack-13499
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-414
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libwavpack1 >= 4.60.99-5.3.1
  • wavpack >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-414
SUSE Linux Enterprise Software Development Kit 11 SP4
  • wavpack >= 4.50.1-1.27.1
  • wavpack-devel >= 4.50.1-1.27.1
Patchnames:
sdksp4-wavpack-13499
SUSE Linux Enterprise Software Development Kit 12 SP2
  • wavpack >= 4.60.99-5.3.1
  • wavpack-devel >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-414
SUSE Linux Enterprise Software Development Kit 12 SP3
  • wavpack >= 4.60.99-5.3.1
  • wavpack-devel >= 4.60.99-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-414
openSUSE Leap 42.3
  • libwavpack1 >= 4.60.99-9.3.1
  • libwavpack1-32bit >= 4.60.99-9.3.1
  • libwavpack1-debuginfo >= 4.60.99-9.3.1
  • libwavpack1-debuginfo-32bit >= 4.60.99-9.3.1
  • wavpack >= 4.60.99-9.3.1
  • wavpack-debuginfo >= 4.60.99-9.3.1
  • wavpack-debugsource >= 4.60.99-9.3.1
  • wavpack-devel >= 4.60.99-9.3.1
Patchnames:
openSUSE-2018-227


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 wavpack Unsupported
SUSE Linux Enterprise Desktop 12 SP2 wavpack Released
SUSE Linux Enterprise Desktop 12 SP3 wavpack Released
SUSE Linux Enterprise SDK 11 SP4 wavpack Released
SUSE Linux Enterprise SDK 12 SP1 wavpack Unsupported
SUSE Linux Enterprise SDK 12 SP2 wavpack Released
SUSE Linux Enterprise SDK 12 SP3 wavpack Released
SUSE Linux Enterprise Server 11 SP4 wavpack Released
SUSE Linux Enterprise Server 12 SP1 wavpack Unsupported
SUSE Linux Enterprise Server 12 SP2 wavpack Released
SUSE Linux Enterprise Server 12 SP3 wavpack Released