Upstream information

CVE-2016-10040 at MITRE

Description

Stack-based buffer overflow in QXmlSimpleReader in Qt 4.8.5 allows remote attackers to cause a denial of service (application crash) via a xml file with multiple nested open tags.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 2.6
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:H/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 3.7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1039291 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libQtWebKit4 >= 4.8.7+2.3.4-4.5.1
  • libQtWebKit4-32bit >= 4.8.7+2.3.4-4.5.1
  • libqca2 >= 2.0.3-17.2.1
  • libqca2-32bit >= 2.0.3-17.2.1
  • libqt4 >= 4.8.7-8.6.1
  • libqt4-32bit >= 4.8.7-8.6.1
  • libqt4-qt3support >= 4.8.7-8.6.1
  • libqt4-qt3support-32bit >= 4.8.7-8.6.1
  • libqt4-sql >= 4.8.7-8.6.1
  • libqt4-sql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-mysql >= 4.8.7-8.6.1
  • libqt4-sql-mysql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-plugins >= 4.8.7-8.6.1
  • libqt4-sql-postgresql >= 4.8.7-8.6.1
  • libqt4-sql-postgresql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-sqlite >= 4.8.7-8.6.1
  • libqt4-sql-sqlite-32bit >= 4.8.7-8.6.1
  • libqt4-sql-unixODBC >= 4.8.7-8.6.1
  • libqt4-sql-unixODBC-32bit >= 4.8.7-8.6.1
  • libqt4-x11 >= 4.8.7-8.6.1
  • libqt4-x11-32bit >= 4.8.7-8.6.1
  • qt4-qtscript >= 0.2.0-11.2.4
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1288
SUSE Linux Enterprise Server 12 SP3
  • libQtWebKit4 >= 4.8.7+2.3.4-4.5.1
  • libQtWebKit4-32bit >= 4.8.7+2.3.4-4.5.1
  • libqca2 >= 2.0.3-17.2.1
  • libqca2-32bit >= 2.0.3-17.2.1
  • libqt4 >= 4.8.7-8.6.1
  • libqt4-32bit >= 4.8.7-8.6.1
  • libqt4-devel-doc >= 4.8.7-8.6.4
  • libqt4-qt3support >= 4.8.7-8.6.1
  • libqt4-qt3support-32bit >= 4.8.7-8.6.1
  • libqt4-sql >= 4.8.7-8.6.1
  • libqt4-sql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-mysql >= 4.8.7-8.6.1
  • libqt4-sql-plugins >= 4.8.7-8.6.1
  • libqt4-sql-sqlite >= 4.8.7-8.6.1
  • libqt4-x11 >= 4.8.7-8.6.1
  • libqt4-x11-32bit >= 4.8.7-8.6.1
  • qt4-x11-tools >= 4.8.7-8.6.4
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1288
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libQtWebKit4 >= 4.8.7+2.3.4-4.5.1
  • libQtWebKit4-32bit >= 4.8.7+2.3.4-4.5.1
  • libqca2 >= 2.0.3-17.2.1
  • libqca2-32bit >= 2.0.3-17.2.1
  • libqt4 >= 4.8.7-8.6.1
  • libqt4-32bit >= 4.8.7-8.6.1
  • libqt4-devel-doc >= 4.8.7-8.6.4
  • libqt4-qt3support >= 4.8.7-8.6.1
  • libqt4-qt3support-32bit >= 4.8.7-8.6.1
  • libqt4-sql >= 4.8.7-8.6.1
  • libqt4-sql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-mysql >= 4.8.7-8.6.1
  • libqt4-sql-plugins >= 4.8.7-8.6.1
  • libqt4-sql-sqlite >= 4.8.7-8.6.1
  • libqt4-x11 >= 4.8.7-8.6.1
  • libqt4-x11-32bit >= 4.8.7-8.6.1
  • qt4-x11-tools >= 4.8.7-8.6.4
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1288
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libQtWebKit-devel >= 4.8.7+2.3.4-4.5.1
  • libQtWebKit4 >= 4.8.7+2.3.4-4.5.1
  • libqca2 >= 2.0.3-17.2.1
  • libqca2-devel >= 2.0.3-17.2.1
  • libqt4 >= 4.8.7-8.6.1
  • libqt4-devel >= 4.8.7-8.6.1
  • libqt4-devel-doc >= 4.8.7-8.6.4
  • libqt4-devel-doc-data >= 4.8.7-8.6.4
  • libqt4-linguist >= 4.8.7-8.6.1
  • libqt4-private-headers-devel >= 4.8.7-8.6.1
  • libqt4-sql-plugins >= 4.8.7-8.6.1
  • libqt4-sql-postgresql >= 4.8.7-8.6.1
  • libqt4-sql-postgresql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-unixODBC >= 4.8.7-8.6.1
  • libqt4-sql-unixODBC-32bit >= 4.8.7-8.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1288
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libqt4 >= 4.8.7-8.6.1
  • libqt4-sql-mysql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-plugins >= 4.8.7-8.6.1
  • libqt4-sql-postgresql >= 4.8.7-8.6.1
  • libqt4-sql-postgresql-32bit >= 4.8.7-8.6.1
  • libqt4-sql-sqlite-32bit >= 4.8.7-8.6.1
  • libqt4-sql-unixODBC >= 4.8.7-8.6.1
  • libqt4-sql-unixODBC-32bit >= 4.8.7-8.6.1
  • qt4-qtscript >= 0.2.0-11.2.4
Patchnames:
SUSE-SLE-WE-12-SP3-2018-1288
openSUSE Leap 42.3
  • libQtWebKit-devel >= 4.8.7+2.3.4-7.3.2
  • libQtWebKit4 >= 4.8.7+2.3.4-7.3.2
  • libQtWebKit4-32bit >= 4.8.7+2.3.4-7.3.2
  • libQtWebKit4-debuginfo >= 4.8.7+2.3.4-7.3.2
  • libQtWebKit4-debuginfo-32bit >= 4.8.7+2.3.4-7.3.2
  • libQtWebKit4-debugsource >= 4.8.7+2.3.4-7.3.2
  • libqca2 >= 2.0.3-22.2.1
  • libqca2-32bit >= 2.0.3-22.2.1
  • libqca2-debuginfo >= 2.0.3-22.2.1
  • libqca2-debuginfo-32bit >= 2.0.3-22.2.1
  • libqca2-debugsource >= 2.0.3-22.2.1
  • libqca2-devel >= 2.0.3-22.2.1
  • libqca2-devel-debuginfo >= 2.0.3-22.2.1
  • libqca2-plugin-cyrus-sasl >= 2.0.3-22.2.1
  • libqca2-plugin-cyrus-sasl-32bit >= 2.0.3-22.2.1
  • libqca2-plugin-cyrus-sasl-debuginfo >= 2.0.3-22.2.1
  • libqca2-plugin-cyrus-sasl-debuginfo-32bit >= 2.0.3-22.2.1
  • libqca2-plugin-pkcs11 >= 2.0.3-22.2.1
  • libqca2-plugin-pkcs11-32bit >= 2.0.3-22.2.1
  • libqca2-plugin-pkcs11-debuginfo >= 2.0.3-22.2.1
  • libqca2-plugin-pkcs11-debuginfo-32bit >= 2.0.3-22.2.1
  • libqt4 >= 4.8.7-17.3.1
  • libqt4-32bit >= 4.8.7-17.3.1
  • libqt4-debuginfo >= 4.8.7-17.3.1
  • libqt4-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-debugsource >= 4.8.7-17.3.1
  • libqt4-devel >= 4.8.7-17.3.1
  • libqt4-devel-32bit >= 4.8.7-17.3.1
  • libqt4-devel-debuginfo >= 4.8.7-17.3.1
  • libqt4-devel-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-devel-doc >= 4.8.7-17.3.2
  • libqt4-devel-doc-data >= 4.8.7-17.3.2
  • libqt4-devel-doc-debuginfo >= 4.8.7-17.3.2
  • libqt4-devel-doc-debugsource >= 4.8.7-17.3.2
  • libqt4-linguist >= 4.8.7-17.3.1
  • libqt4-linguist-debuginfo >= 4.8.7-17.3.1
  • libqt4-private-headers-devel >= 4.8.7-17.3.1
  • libqt4-qt3support >= 4.8.7-17.3.1
  • libqt4-qt3support-32bit >= 4.8.7-17.3.1
  • libqt4-qt3support-debuginfo >= 4.8.7-17.3.1
  • libqt4-qt3support-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-sql >= 4.8.7-17.3.1
  • libqt4-sql-32bit >= 4.8.7-17.3.1
  • libqt4-sql-debuginfo >= 4.8.7-17.3.1
  • libqt4-sql-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-sql-mysql >= 4.8.7-17.3.1
  • libqt4-sql-mysql-32bit >= 4.8.7-17.3.1
  • libqt4-sql-mysql-debuginfo >= 4.8.7-17.3.1
  • libqt4-sql-mysql-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-sql-plugins >= 4.8.7-17.3.1
  • libqt4-sql-plugins-debugsource >= 4.8.7-17.3.1
  • libqt4-sql-postgresql >= 4.8.7-17.3.1
  • libqt4-sql-postgresql-32bit >= 4.8.7-17.3.1
  • libqt4-sql-postgresql-debuginfo >= 4.8.7-17.3.1
  • libqt4-sql-postgresql-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-sql-sqlite >= 4.8.7-17.3.1
  • libqt4-sql-sqlite-32bit >= 4.8.7-17.3.1
  • libqt4-sql-sqlite-debuginfo >= 4.8.7-17.3.1
  • libqt4-sql-sqlite-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-sql-unixODBC >= 4.8.7-17.3.1
  • libqt4-sql-unixODBC-32bit >= 4.8.7-17.3.1
  • libqt4-sql-unixODBC-debuginfo >= 4.8.7-17.3.1
  • libqt4-sql-unixODBC-debuginfo-32bit >= 4.8.7-17.3.1
  • libqt4-x11 >= 4.8.7-17.3.1
  • libqt4-x11-32bit >= 4.8.7-17.3.1
  • libqt4-x11-debuginfo >= 4.8.7-17.3.1
  • libqt4-x11-debuginfo-32bit >= 4.8.7-17.3.1
  • qt4-qtscript >= 0.2.0-15.2.1
  • qt4-qtscript-debuginfo >= 0.2.0-15.2.1
  • qt4-qtscript-debugsource >= 0.2.0-15.2.1
  • qt4-qtscript-doc >= 0.2.0-15.2.1
  • qt4-x11-tools >= 4.8.7-17.3.2
  • qt4-x11-tools-debuginfo >= 4.8.7-17.3.2
Patchnames:
openSUSE-2018-726


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 libqt4 Affected
SUSE Linux Enterprise Desktop 12 SP1 libqt5-qtbase Ignore
SUSE Linux Enterprise Desktop 12 SP2 libqt4 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 libqt5-qtbase Affected
SUSE Linux Enterprise Desktop 12 SP3 libqt4 Released
SUSE Linux Enterprise SDK 11 SP4 libqt4 Not affected
SUSE Linux Enterprise SDK 12 SP1 libqt4 Affected
SUSE Linux Enterprise SDK 12 SP1 libqt5-qtbase Ignore
SUSE Linux Enterprise SDK 12 SP2 libqt4 Unsupported
SUSE Linux Enterprise SDK 12 SP2 libqt5-qtbase Affected
SUSE Linux Enterprise SDK 12 SP3 libqt4 Released
SUSE Linux Enterprise Server 11 SP3 LTSS libqt4 Not affected
SUSE Linux Enterprise Server 11 SP4 libqt4 Not affected
SUSE Linux Enterprise Server 12 GA LTSS libqt4 Affected
SUSE Linux Enterprise Server 12 SP1 libqt4 Affected
SUSE Linux Enterprise Server 12 SP1 libqt5-qtbase Ignore
SUSE Linux Enterprise Server 12 SP2 libqt4 Unsupported
SUSE Linux Enterprise Server 12 SP2 libqt5-qtbase Affected
SUSE Linux Enterprise Server 12 SP3 libqt4 Released
SUSE Linux Enterprise Workstation Extension 12 SP1 libqt4 Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libqt4 Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 libqt4 Released