Upstream information

CVE-2016-10030 at MITRE

Description

The _prolog_error function in slurmd/req.c in Slurm before 15.08.13, 16.x before 16.05.7, and 17.x before 17.02.0-pre4 has a vulnerability in how the slurmd daemon informs users of a Prolog failure on a compute node. That vulnerability could allow a user to assume control of an arbitrary file on the system. Any exploitation of this is dependent on the user being able to cause or anticipate the failure (non-zero return code) of a Prolog script that their job would run on. This issue affects all Slurm versions from 0.6.0 (September 2005) to present. Workarounds to prevent exploitation of this are to either disable your Prolog script, or modify it such that it always returns 0 ("success") and adjust it to set the node as down using scontrol instead of relying on the slurmd to handle that automatically. If you do not have a Prolog set you are unaffected by this issue.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.6
Vector AV:N/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 1018371 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for High Performance Computing 12
  • libslurm29 >= 16.05.8.1-5.2
  • perl-slurm >= 16.05.8.1-5.2
  • slurm >= 16.05.8.1-5.2
  • slurm-auth-none >= 16.05.8.1-5.2
  • slurm-devel >= 16.05.8.1-5.2
  • slurm-doc >= 16.05.8.1-5.2
  • slurm-lua >= 16.05.8.1-5.2
  • slurm-munge >= 16.05.8.1-5.2
  • slurm-pam_slurm >= 16.05.8.1-5.2
  • slurm-plugins >= 16.05.8.1-5.2
  • slurm-sched-wiki >= 16.05.8.1-5.2
  • slurm-slurmdbd >= 16.05.8.1-5.2
Patchnames:
SUSE Linux Enterprise Module for High Performance Computing 12 GA libslurm29
SUSE Linux Enterprise Module for High Performance Computing 15
  • libpmi0 >= 17.11.5-4.28
  • libslurm32 >= 17.11.5-4.28
  • perl-slurm >= 17.11.5-4.28
  • slurm >= 17.11.5-4.28
  • slurm-auth-none >= 17.11.5-4.28
  • slurm-config >= 17.11.5-4.28
  • slurm-devel >= 17.11.5-4.28
  • slurm-doc >= 17.11.5-4.28
  • slurm-lua >= 17.11.5-4.28
  • slurm-munge >= 17.11.5-4.28
  • slurm-node >= 17.11.5-4.28
  • slurm-pam_slurm >= 17.11.5-4.28
  • slurm-plugins >= 17.11.5-4.28
  • slurm-slurmdbd >= 17.11.5-4.28
  • slurm-sql >= 17.11.5-4.28
  • slurm-torque >= 17.11.5-4.28
Patchnames:
SUSE Linux Enterprise Module for High Performance Computing 15 GA libpmi0