Upstream information

CVE-2016-10009 at MITRE

Description

Untrusted search path vulnerability in ssh-agent.c in ssh-agent in OpenSSH before 7.4 allows remote attackers to execute arbitrary local PKCS#11 modules by leveraging control over a forwarded agent-socket.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4.6
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial

Note from the SUSE Security Team

The option of pkcs11 module handling was added in the openssh 6.x series. Older versions of openssh (like 5.1) are not affected.

SUSE Bugzilla entries: 1016336 [IN_PROGRESS], 1016366 [RESOLVED], 1016370 [IN_PROGRESS], 1017555, 1017870 [RESOLVED / FIXED], 1021751 [RESOLVED / FIXED], 1025354 [RESOLVED / WORKSFORME], 1026634 [RESOLVED / FIXED], 1087412 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-325
SUSE Linux Enterprise Desktop 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-138
SUSE Linux Enterprise Desktop 12 SP3
  • openssh >= 7.2p2-69.1
  • openssh-helpers >= 7.2p2-69.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA openssh
SUSE Linux Enterprise Module for Basesystem 15
  • openssh >= 7.6p1-7.8
  • openssh-helpers >= 7.6p1-7.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA openssh
SUSE Linux Enterprise Module for Server Applications 15
  • openssh-fips >= 7.6p1-7.8
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA openssh-fips
SUSE Linux Enterprise Point of Sale 11 SP3
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
sleposp3-openssh-13005
SUSE Linux Enterprise Server 11 SP3-LTSS
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
slessp3-openssh-13005
SUSE Linux Enterprise Server 11 SP4
  • openssh >= 6.6p1-35.1
  • openssh-askpass-gnome >= 6.6p1-35.4
  • openssh-fips >= 6.6p1-35.1
  • openssh-helpers >= 6.6p1-35.1
Patchnames:
slessp4-openssh-13002
SUSE Linux Enterprise Server 11-SECURITY
  • openssh-openssl1 >= 6.6p1-18.1
  • openssh-openssl1-helpers >= 6.6p1-18.1
Patchnames:
secsp3-openssh-openssl1-13169
SUSE Linux Enterprise Server 12 SP1
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-325
SUSE Linux Enterprise Server 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-138
SUSE Linux Enterprise Server 12 SP3
  • openssh >= 7.2p2-69.1
  • openssh-fips >= 7.2p2-69.1
  • openssh-helpers >= 7.2p2-69.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA openssh
SUSE Linux Enterprise Server 12-LTSS
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SERVER-12-2017-325
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-138
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
slessp3-openssh-13005
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • openssh >= 6.6p1-35.1
  • openssh-askpass-gnome >= 6.6p1-35.4
  • openssh-fips >= 6.6p1-35.1
  • openssh-helpers >= 6.6p1-35.1
Patchnames:
slessp4-openssh-13002
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • openssh-openssl1 >= 6.6p1-18.1
  • openssh-openssl1-helpers >= 6.6p1-18.1
Patchnames:
secsp3-openssh-openssl1-13169
SUSE Linux Enterprise Server for SAP Applications 12
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SAP-12-2017-325
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-325
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-138
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SERVER-12-2017-325
SUSE Manager 2.1
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
sleman21-openssh-13005
SUSE Manager Proxy 2.1
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
slemap21-openssh-13005
SUSE OpenStack Cloud 5
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
sleclo50sp3-openssh-13005
openSUSE Leap 15.0
  • openssh >= 7.6p1-lp150.7.4
  • openssh-helpers >= 7.6p1-lp150.7.4
Patchnames:
openSUSE Leap 15.0 GA openssh
openSUSE Leap 42.1
  • openssh >= 6.6p1-17.1
  • openssh-askpass-gnome >= 6.6p1-17.1
  • openssh-askpass-gnome-debuginfo >= 6.6p1-17.1
  • openssh-cavs >= 6.6p1-17.1
  • openssh-cavs-debuginfo >= 6.6p1-17.1
  • openssh-debuginfo >= 6.6p1-17.1
  • openssh-debugsource >= 6.6p1-17.1
  • openssh-fips >= 6.6p1-17.1
  • openssh-helpers >= 6.6p1-17.1
  • openssh-helpers-debuginfo >= 6.6p1-17.1
Patchnames:
openSUSE-2017-339
openSUSE Leap 42.2
  • openssh >= 7.2p2-9.1
  • openssh-askpass-gnome >= 7.2p2-9.1
  • openssh-askpass-gnome-debuginfo >= 7.2p2-9.1
  • openssh-cavs >= 7.2p2-9.1
  • openssh-debuginfo >= 7.2p2-9.1
  • openssh-debugsource >= 7.2p2-9.1
  • openssh-fips >= 7.2p2-9.1
  • openssh-helpers >= 7.2p2-9.1
  • openssh-helpers-debuginfo >= 7.2p2-9.1
Patchnames:
openSUSE-2017-184
openSUSE Leap 42.3
  • openssh >= 7.2p2-13.1
  • openssh-helpers >= 7.2p2-13.1
Patchnames:
openSUSE Leap 42.3 GA openssh


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 openssh Released
SUSE Linux Enterprise Desktop 12 SP2 openssh Released
SUSE Linux Enterprise Security Module 11.3 GA openssh-openssl1 Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP4 openssh Released
SUSE Linux Enterprise Server 12 GA LTSS openssh Released
SUSE Linux Enterprise Server 12 SP1 openssh Released
SUSE Linux Enterprise Server 12 SP2 openssh Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI openssh Released