Upstream information

CVE-2016-0763 at MITRE

Description

The setGlobalContext method in org/apache/naming/factory/ResourceLinkFactory.java in Apache Tomcat 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M3 does not consider whether ResourceLinkFactory.setGlobalContext callers are authorized, which allows remote authenticated users to bypass intended SecurityManager restrictions and read or write to arbitrary application data, or cause a denial of service (application disruption), via a web application that sets a crafted global context.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.52 4.33
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P AV:A/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network Adjacent Network
Access Complexity Low Medium
Authentication Single None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.3
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 967966 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12
  • tomcat >= 7.0.68-7.6.1
  • tomcat-admin-webapps >= 7.0.68-7.6.1
  • tomcat-docs-webapp >= 7.0.68-7.6.1
  • tomcat-el-2_2-api >= 7.0.68-7.6.1
  • tomcat-javadoc >= 7.0.68-7.6.1
  • tomcat-jsp-2_2-api >= 7.0.68-7.6.1
  • tomcat-lib >= 7.0.68-7.6.1
  • tomcat-servlet-3_0-api >= 7.0.68-7.6.1
  • tomcat-webapps >= 7.0.68-7.6.1
Patchnames:
SUSE-SLE-SERVER-12-2016-478
SUSE Linux Enterprise Server 12 SP1
  • tomcat >= 8.0.32-3.1
  • tomcat-admin-webapps >= 8.0.32-3.1
  • tomcat-docs-webapp >= 8.0.32-3.1
  • tomcat-el-3_0-api >= 8.0.32-3.1
  • tomcat-javadoc >= 8.0.32-3.1
  • tomcat-jsp-2_3-api >= 8.0.32-3.1
  • tomcat-lib >= 8.0.32-3.1
  • tomcat-servlet-3_1-api >= 8.0.32-3.1
  • tomcat-webapps >= 8.0.32-3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-448
SUSE Linux Enterprise Server 12 SP2
  • tomcat >= 8.0.36-11.4
  • tomcat-admin-webapps >= 8.0.36-11.4
  • tomcat-docs-webapp >= 8.0.36-11.4
  • tomcat-el-3_0-api >= 8.0.36-11.4
  • tomcat-javadoc >= 8.0.36-11.4
  • tomcat-jsp-2_3-api >= 8.0.36-11.4
  • tomcat-lib >= 8.0.36-11.4
  • tomcat-servlet-3_1-api >= 8.0.36-11.4
  • tomcat-webapps >= 8.0.36-11.4
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA tomcat
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • tomcat >= 8.0.36-11.4
  • tomcat-admin-webapps >= 8.0.36-11.4
  • tomcat-docs-webapp >= 8.0.36-11.4
  • tomcat-el-3_0-api >= 8.0.36-11.4
  • tomcat-javadoc >= 8.0.36-11.4
  • tomcat-jsp-2_3-api >= 8.0.36-11.4
  • tomcat-lib >= 8.0.36-11.4
  • tomcat-servlet-3_1-api >= 8.0.36-11.4
  • tomcat-webapps >= 8.0.36-11.4
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA tomcat
openSUSE Leap 42.1
  • tomcat >= 8.0.32-5.1
  • tomcat-admin-webapps >= 8.0.32-5.1
  • tomcat-docs-webapp >= 8.0.32-5.1
  • tomcat-el-3_0-api >= 8.0.32-5.1
  • tomcat-embed >= 8.0.32-5.1
  • tomcat-javadoc >= 8.0.32-5.1
  • tomcat-jsp-2_3-api >= 8.0.32-5.1
  • tomcat-jsvc >= 8.0.32-5.1
  • tomcat-lib >= 8.0.32-5.1
  • tomcat-servlet-3_1-api >= 8.0.32-5.1
  • tomcat-webapps >= 8.0.32-5.1
Patchnames:
openSUSE-2016-384
openSUSE Leap 42.2
  • tomcat >= 8.0.36-2.7
  • tomcat-admin-webapps >= 8.0.36-2.7
  • tomcat-el-3_0-api >= 8.0.36-2.7
  • tomcat-jsp-2_3-api >= 8.0.36-2.7
  • tomcat-lib >= 8.0.36-2.7
  • tomcat-servlet-3_1-api >= 8.0.36-2.7
  • tomcat-webapps >= 8.0.36-2.7
Patchnames:
openSUSE Leap 42.2 GA tomcat
openSUSE Tumbleweed
  • tomcat >= 8.0.36-3.3
  • tomcat-admin-webapps >= 8.0.36-3.3
  • tomcat-docs-webapp >= 8.0.36-3.3
  • tomcat-el-3_0-api >= 8.0.36-3.3
  • tomcat-embed >= 8.0.36-3.3
  • tomcat-javadoc >= 8.0.36-3.3
  • tomcat-jsp-2_3-api >= 8.0.36-3.3
  • tomcat-jsvc >= 8.0.36-3.3
  • tomcat-lib >= 8.0.36-3.3
  • tomcat-servlet-3_1-api >= 8.0.36-3.3
  • tomcat-webapps >= 8.0.36-3.3
Patchnames:
openSUSE Tumbleweed GA tomcat