Upstream information

CVE-2016-0718 at MITRE

Description

Expat allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a malformed input document, which triggers a buffer overflow.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 6.82
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having important severity.

SUSE Bugzilla entries: 979441 [RESOLVED / FIXED], 991809 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-898
SUSE Linux Enterprise Desktop 12 SP1
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-898
SUSE Linux Enterprise Desktop 12 SP2
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA expat
SUSE Linux Enterprise Server 11 SP4
  • expat >= 2.0.1-88.38.1
  • libexpat1 >= 2.0.1-88.38.1
  • libexpat1-32bit >= 2.0.1-88.38.1
  • libexpat1-x86 >= 2.0.1-88.38.1
Patchnames:
slessp4-expat-12600
SUSE Linux Enterprise Server 12
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SERVER-12-2016-898
SUSE Linux Enterprise Server 12 SP1
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-898
SUSE Linux Enterprise Server 12 SP2
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA expat
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA expat
SUSE Linux Enterprise Software Development Kit 11 SP4
  • expat >= 2.0.1-88.38.1
  • libexpat-devel >= 2.0.1-88.38.1
Patchnames:
sdksp4-expat-12600
SUSE Linux Enterprise Software Development Kit 12
  • expat >= 2.1.0-17.1
  • libexpat-devel >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SDK-12-2016-898
SUSE Linux Enterprise Software Development Kit 12 SP1
  • expat >= 2.1.0-17.1
  • libexpat-devel >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-898
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libexpat-devel >= 2.1.0-17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libexpat-devel
SUSE Studio Onsite 1.3
  • expat >= 2.0.1-88.38.1
  • libexpat-devel >= 2.0.1-88.38.1
Patchnames:
slestso13-expat-12600
openSUSE 13.1
  • MozillaFirefox >= 48.0-119.1
  • MozillaFirefox-branding-upstream >= 48.0-119.1
  • MozillaFirefox-buildsymbols >= 48.0-119.1
  • MozillaFirefox-debuginfo >= 48.0-119.1
  • MozillaFirefox-debugsource >= 48.0-119.1
  • MozillaFirefox-devel >= 48.0-119.1
  • MozillaFirefox-translations-common >= 48.0-119.1
  • MozillaFirefox-translations-other >= 48.0-119.1
  • libfreebl3 >= 3.24-83.1
  • libfreebl3-32bit >= 3.24-83.1
  • libfreebl3-debuginfo >= 3.24-83.1
  • libfreebl3-debuginfo-32bit >= 3.24-83.1
  • libsoftokn3 >= 3.24-83.1
  • libsoftokn3-32bit >= 3.24-83.1
  • libsoftokn3-debuginfo >= 3.24-83.1
  • libsoftokn3-debuginfo-32bit >= 3.24-83.1
  • mozilla-nss >= 3.24-83.1
  • mozilla-nss-32bit >= 3.24-83.1
  • mozilla-nss-certs >= 3.24-83.1
  • mozilla-nss-certs-32bit >= 3.24-83.1
  • mozilla-nss-certs-debuginfo >= 3.24-83.1
  • mozilla-nss-certs-debuginfo-32bit >= 3.24-83.1
  • mozilla-nss-debuginfo >= 3.24-83.1
  • mozilla-nss-debuginfo-32bit >= 3.24-83.1
  • mozilla-nss-debugsource >= 3.24-83.1
  • mozilla-nss-devel >= 3.24-83.1
  • mozilla-nss-sysinit >= 3.24-83.1
  • mozilla-nss-sysinit-32bit >= 3.24-83.1
  • mozilla-nss-sysinit-debuginfo >= 3.24-83.1
  • mozilla-nss-sysinit-debuginfo-32bit >= 3.24-83.1
  • mozilla-nss-tools >= 3.24-83.1
  • mozilla-nss-tools-debuginfo >= 3.24-83.1
Patchnames:
2016-960
openSUSE 13.2
  • MozillaFirefox >= 48.0-74.1
  • MozillaFirefox-branding-upstream >= 48.0-74.1
  • MozillaFirefox-buildsymbols >= 48.0-74.1
  • MozillaFirefox-debuginfo >= 48.0-74.1
  • MozillaFirefox-debugsource >= 48.0-74.1
  • MozillaFirefox-devel >= 48.0-74.1
  • MozillaFirefox-translations-common >= 48.0-74.1
  • MozillaFirefox-translations-other >= 48.0-74.1
  • expat >= 2.1.0-14.3.1
  • expat-debuginfo >= 2.1.0-14.3.1
  • expat-debuginfo-32bit >= 2.1.0-14.3.1
  • expat-debugsource >= 2.1.0-14.3.1
  • libexpat-devel >= 2.1.0-14.3.1
  • libexpat-devel-32bit >= 2.1.0-14.3.1
  • libexpat1 >= 2.1.0-14.3.1
  • libexpat1-32bit >= 2.1.0-14.3.1
  • libexpat1-debuginfo >= 2.1.0-14.3.1
  • libexpat1-debuginfo-32bit >= 2.1.0-14.3.1
  • libfreebl3 >= 3.24-37.1
  • libfreebl3-32bit >= 3.24-37.1
  • libfreebl3-debuginfo >= 3.24-37.1
  • libfreebl3-debuginfo-32bit >= 3.24-37.1
  • libsoftokn3 >= 3.24-37.1
  • libsoftokn3-32bit >= 3.24-37.1
  • libsoftokn3-debuginfo >= 3.24-37.1
  • libsoftokn3-debuginfo-32bit >= 3.24-37.1
  • mozilla-nss >= 3.24-37.1
  • mozilla-nss-32bit >= 3.24-37.1
  • mozilla-nss-certs >= 3.24-37.1
  • mozilla-nss-certs-32bit >= 3.24-37.1
  • mozilla-nss-certs-debuginfo >= 3.24-37.1
  • mozilla-nss-certs-debuginfo-32bit >= 3.24-37.1
  • mozilla-nss-debuginfo >= 3.24-37.1
  • mozilla-nss-debuginfo-32bit >= 3.24-37.1
  • mozilla-nss-debugsource >= 3.24-37.1
  • mozilla-nss-devel >= 3.24-37.1
  • mozilla-nss-sysinit >= 3.24-37.1
  • mozilla-nss-sysinit-32bit >= 3.24-37.1
  • mozilla-nss-sysinit-debuginfo >= 3.24-37.1
  • mozilla-nss-sysinit-debuginfo-32bit >= 3.24-37.1
  • mozilla-nss-tools >= 3.24-37.1
  • mozilla-nss-tools-debuginfo >= 3.24-37.1
Patchnames:
openSUSE-2016-660
openSUSE-2016-937
openSUSE Leap 42.1
  • MozillaFirefox >= 48.0-27.1
  • MozillaFirefox-branding-upstream >= 48.0-27.1
  • MozillaFirefox-buildsymbols >= 48.0-27.1
  • MozillaFirefox-debuginfo >= 48.0-27.1
  • MozillaFirefox-debugsource >= 48.0-27.1
  • MozillaFirefox-devel >= 48.0-27.1
  • MozillaFirefox-translations-common >= 48.0-27.1
  • MozillaFirefox-translations-other >= 48.0-27.1
  • expat >= 2.1.0-17.1
  • expat-debuginfo >= 2.1.0-17.1
  • expat-debuginfo-32bit >= 2.1.0-17.1
  • expat-debugsource >= 2.1.0-17.1
  • libexpat-devel >= 2.1.0-17.1
  • libexpat-devel-32bit >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
  • libexpat1-debuginfo >= 2.1.0-17.1
  • libexpat1-debuginfo-32bit >= 2.1.0-17.1
  • libfreebl3 >= 3.24-21.1
  • libfreebl3-32bit >= 3.24-21.1
  • libfreebl3-debuginfo >= 3.24-21.1
  • libfreebl3-debuginfo-32bit >= 3.24-21.1
  • libsoftokn3 >= 3.24-21.1
  • libsoftokn3-32bit >= 3.24-21.1
  • libsoftokn3-debuginfo >= 3.24-21.1
  • libsoftokn3-debuginfo-32bit >= 3.24-21.1
  • mozilla-nss >= 3.24-21.1
  • mozilla-nss-32bit >= 3.24-21.1
  • mozilla-nss-certs >= 3.24-21.1
  • mozilla-nss-certs-32bit >= 3.24-21.1
  • mozilla-nss-certs-debuginfo >= 3.24-21.1
  • mozilla-nss-certs-debuginfo-32bit >= 3.24-21.1
  • mozilla-nss-debuginfo >= 3.24-21.1
  • mozilla-nss-debuginfo-32bit >= 3.24-21.1
  • mozilla-nss-debugsource >= 3.24-21.1
  • mozilla-nss-devel >= 3.24-21.1
  • mozilla-nss-sysinit >= 3.24-21.1
  • mozilla-nss-sysinit-32bit >= 3.24-21.1
  • mozilla-nss-sysinit-debuginfo >= 3.24-21.1
  • mozilla-nss-sysinit-debuginfo-32bit >= 3.24-21.1
  • mozilla-nss-tools >= 3.24-21.1
  • mozilla-nss-tools-debuginfo >= 3.24-21.1
Patchnames:
openSUSE-2016-695
openSUSE-2016-937
openSUSE Leap 42.2
  • MozillaFirefox >= 49.0.2-37.1
  • MozillaFirefox-translations-common >= 49.0.2-37.1
  • expat >= 2.1.0-17.9
  • libexpat-devel >= 2.1.0-17.9
  • libexpat1 >= 2.1.0-17.9
  • libexpat1-32bit >= 2.1.0-17.9
Patchnames:
openSUSE Leap 42.2 GA MozillaFirefox
openSUSE Leap 42.2 GA expat
openSUSE Tumbleweed
  • MozillaFirefox >= 50.1.0-1.1
  • MozillaFirefox-branding-upstream >= 50.1.0-1.1
  • MozillaFirefox-buildsymbols >= 50.1.0-1.1
  • MozillaFirefox-devel >= 50.1.0-1.1
  • MozillaFirefox-translations-common >= 50.1.0-1.1
  • MozillaFirefox-translations-other >= 50.1.0-1.1
  • expat >= 2.2.0-3.1
  • libexpat-devel >= 2.2.0-3.1
  • libexpat-devel-32bit >= 2.2.0-3.1
  • libexpat1 >= 2.2.0-3.1
  • libexpat1-32bit >= 2.2.0-3.1
Patchnames:
openSUSE Tumbleweed GA MozillaFirefox
openSUSE Tumbleweed GA expat