Upstream information

CVE-2015-8980 at MITRE

Description

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1

Note from the SUSE Security Team

This CVE This bug relates to the "php-gettext", a gettext emulation in pure PHP code.

The binary packages php5-gettext, php53-gettext, php7-gettext, as shipped in SUSE Linux Enterprise and openSUSE, however, contain the native PHP gettext extension built from C sources. By it's nature it does not contain the vulnerable code for this CVE.

SUSE Bugzilla entries: 1020489 [RESOLVED], 1021597 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • phpMyAdmin >= 4.4.15.10-31.2
Patchnames:
openSUSE-2017-198
openSUSE Leap 42.2
  • phpMyAdmin >= 4.4.15.10-31.2
Patchnames:
openSUSE-2017-198