Upstream information

CVE-2015-8936 at MITRE

Description

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 6.8
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None Partial
SUSE Bugzilla entries: 1040287 [RESOLVED], 985612 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • squidGuard >= 1.4-30.6.1
  • squidGuard-doc >= 1.4-30.6.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • squidGuard >= 1.4-13.10.1
  • squidGuard-doc >= 1.4-13.10.1
Patchnames:
slessp4-squidGuard-12783
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • squidGuard >= 1.4-27.1
  • squidGuard-doc >= 1.4-27.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1465
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • squidGuard >= 1.4-29.1
  • squidGuard-doc >= 1.4-29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-868
SUSE Linux Enterprise Server 12 SP3
  • squidGuard >= 1.4-29.1
  • squidGuard-doc >= 1.4-29.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • squidGuard >= 1.4-29.1
  • squidGuard-doc >= 1.4-29.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-868
openSUSE Leap 42.1
  • squidGuard >= 1.4-3.1
  • squidGuard-debuginfo >= 1.4-3.1
  • squidGuard-debugsource >= 1.4-3.1
  • squidGuard-doc >= 1.4-3.1
Patchnames:
openSUSE-2016-1210
openSUSE Leap 42.2
  • squidGuard >= 1.4-4.1
Patchnames:
openSUSE Leap 42.2 GA squidGuard
openSUSE Leap 42.3
  • squidGuard >= 1.4-6.1
Patchnames:
openSUSE Leap 42.3 GA squidGuard


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications squidGuard Released
SLES_LTSS-10-SP4 squidGuard Affected
SUSE Linux Enterprise Server 11 SP1 squidGuard Released
SUSE Linux Enterprise Server 11 SP1 LTSS squidGuard Released
SUSE Linux Enterprise Server 11 SP2 squidGuard Released
SUSE Linux Enterprise Server 11 SP2 LTSS squidGuard Released
SUSE Linux Enterprise Server 11 SP2 for VMware squidGuard Released
SUSE Linux Enterprise Server 11 SP3 squidGuard Released
SUSE Linux Enterprise Server 11 SP3 LTSS squidGuard Released
SUSE Linux Enterprise Server 11 SP3 for VMware squidGuard Released
SUSE Linux Enterprise Server 11 SP4 squidGuard Released
SUSE Linux Enterprise Server 12 squidGuard Released
SUSE Linux Enterprise Server 12 LTSS squidGuard Released
SUSE Linux Enterprise Server 12 SP1 squidGuard Released
SUSE Linux Enterprise Server 12 SP2 squidGuard Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 squidGuard Already fixed
SUSE Linux Enterprise Server for the Raspberry Pi squidGuard Released