Upstream information

CVE-2015-8869 at MITRE

Description

OCaml before 4.03.0 does not properly handle sign extensions, which allows remote attackers to conduct buffer overflow attacks or obtain sensitive information as demonstrated by a long string to the String.copy function.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 3.7
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:L/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None Partial
Availability Impact Partial Partial
SUSE Bugzilla entry: 977990 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP1
  • ocaml >= 4.02.3-6.6.14
  • ocaml-ocamldoc >= 4.02.3-6.6.14
Patchnames:
SUSE-SLE-BSK-12-SP1-2016-1297
SUSE Linux Enterprise Module for Development Tools 15
  • ocaml >= 4.05.0-4.25
  • ocaml-compiler-libs >= 4.05.0-4.25
  • ocaml-compiler-libs-devel >= 4.05.0-4.25
  • ocaml-rpm-macros >= 4.05.0-4.25
  • ocaml-runtime >= 4.05.0-4.25
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA ocaml
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ocaml >= 4.02.1-3.4
  • ocaml-compiler-libs >= 4.02.1-3.4
  • ocaml-runtime >= 4.02.1-3.4
Patchnames:
sdksp4-ocaml-12721
SUSE Linux Enterprise Software Development Kit 12 SP1
  • ocaml >= 4.02.3-6.6.14
  • ocaml-compiler-libs >= 4.02.3-6.6.14
  • ocaml-runtime >= 4.02.3-6.6.14
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1297
SUSE Linux Enterprise Software Development Kit 12 SP2
  • ocaml >= 4.03.0-6.9.1
  • ocaml-compiler-libs >= 4.03.0-6.9.1
  • ocaml-rpm-macros >= 4.03.0-6.9.1
  • ocaml-runtime >= 4.03.0-6.9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA ocaml
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ocaml >= 4.03.0-6.9.1
  • ocaml-compiler-libs >= 4.03.0-6.9.1
  • ocaml-rpm-macros >= 4.03.0-6.9.1
  • ocaml-runtime >= 4.03.0-6.9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA ocaml
openSUSE Leap 42.1
  • ocaml >= 4.02.3-3.2
  • ocaml-compiler-libs >= 4.02.3-3.2
  • ocaml-compiler-libs-devel >= 4.02.3-3.2
  • ocaml-debuginfo >= 4.02.3-3.2
  • ocaml-debugsource >= 4.02.3-3.2
  • ocaml-docs >= 4.02.3-3.2
  • ocaml-emacs >= 4.02.3-3.2
  • ocaml-ocamldoc >= 4.02.3-3.2
  • ocaml-ocamldoc-debuginfo >= 4.02.3-3.2
  • ocaml-rpm-macros >= 4.02.3-3.2
  • ocaml-runtime >= 4.02.3-3.2
  • ocaml-runtime-debuginfo >= 4.02.3-3.2
  • ocaml-source >= 4.02.3-3.2
  • ocaml-x11 >= 4.02.3-3.2
Patchnames:
openSUSE-2016-1072
openSUSE Leap 42.2
  • ocaml >= 4.03.0-1.15
  • ocaml-compiler-libs >= 4.03.0-1.15
  • ocaml-runtime >= 4.03.0-1.15
Patchnames:
openSUSE Leap 42.2 GA ocaml
openSUSE Leap 42.3
  • ocaml >= 4.03.0-3.18
  • ocaml-compiler-libs >= 4.03.0-3.18
  • ocaml-runtime >= 4.03.0-3.18
Patchnames:
openSUSE Leap 42.3 GA ocaml
openSUSE Tumbleweed
  • ocaml >= 4.03.0-1.3
  • ocaml-compiler-libs >= 4.03.0-1.3
  • ocaml-compiler-libs-devel >= 4.03.0-1.3
  • ocaml-docs >= 4.03.0-1.3
  • ocaml-emacs >= 4.03.0-1.3
  • ocaml-ocamldoc >= 4.03.0-1.3
  • ocaml-rpm-macros >= 4.03.0-1.3
  • ocaml-runtime >= 4.03.0-1.3
  • ocaml-source >= 4.03.0-1.3
  • ocaml-x11 >= 4.03.0-1.3
Patchnames:
openSUSE Tumbleweed GA ocaml


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 GA ocaml Released
SUSE Linux Enterprise BSK 12 SP1 ocaml Released
SUSE Linux Enterprise SDK 11 SP4 ocaml In progress
SUSE Linux Enterprise SDK 12 GA ocaml Released
SUSE Linux Enterprise SDK 12 SP1 ocaml Released
SUSE Linux Enterprise SDK 12 SP2 ocaml Released