Upstream information

CVE-2015-8868 at MITRE

Description

Heap-based buffer overflow in the ExponentialFunction::ExponentialFunction function in Poppler before 0.40.0 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via an invalid blend mode in the ExtGState dictionary in a crafted PDF document.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.3 4.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Complete None
Integrity Impact Complete None
Availability Impact Complete Partial
SUSE Bugzilla entry: 976844 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12
  • libpoppler-cpp0 >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
Patchnames:
SUSE-SLE-BSK-12-2016-922
SUSE Linux Enterprise Build System Kit 12 SP1
  • libpoppler-cpp0 >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
Patchnames:
SUSE-SLE-BSK-12-SP1-2016-922
SUSE Linux Enterprise Desktop 12
  • libpoppler-glib8 >= 0.24.4-12.1
  • libpoppler-qt4-4 >= 0.24.4-12.1
  • libpoppler44 >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • poppler-tools >= 0.24.4-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-922
SUSE Linux Enterprise Desktop 12 SP1
  • libpoppler-glib8 >= 0.24.4-12.1
  • libpoppler-qt4-4 >= 0.24.4-12.1
  • libpoppler44 >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • poppler-tools >= 0.24.4-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-922
SUSE Linux Enterprise Desktop 12 SP2
  • libpoppler44 >= 0.24.4-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpoppler44
SUSE Linux Enterprise Server 11 SP4
  • libpoppler-glib4 >= 0.12.3-1.12.1
  • libpoppler-qt4-3 >= 0.12.3-1.12.1
  • libpoppler5 >= 0.12.3-1.12.1
  • poppler >= 0.12.3-1.12.1
  • poppler-tools >= 0.12.3-1.12.1
Patchnames:
slessp4-poppler-12609
SUSE Linux Enterprise Server 12
  • libpoppler-glib8 >= 0.24.4-12.1
  • libpoppler-qt4-4 >= 0.24.4-12.1
  • libpoppler44 >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • poppler-tools >= 0.24.4-12.1
Patchnames:
SUSE-SLE-SERVER-12-2016-922
SUSE Linux Enterprise Server 12 SP1
  • libpoppler-glib8 >= 0.24.4-12.1
  • libpoppler-qt4-4 >= 0.24.4-12.1
  • libpoppler44 >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • poppler-tools >= 0.24.4-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-922
SUSE Linux Enterprise Server 12 SP2
  • libpoppler44 >= 0.24.4-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpoppler44
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpoppler44 >= 0.24.4-12.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpoppler44
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpoppler-devel >= 0.12.3-1.12.1
  • libpoppler-glib-devel >= 0.12.3-1.12.1
  • libpoppler-qt2 >= 0.12.3-1.12.1
  • libpoppler-qt3-devel >= 0.12.3-1.12.1
  • libpoppler-qt4-devel >= 0.12.3-1.12.1
  • poppler >= 0.12.3-1.12.1
  • poppler-tools >= 0.12.3-1.12.1
Patchnames:
sdksp4-poppler-12609
SUSE Linux Enterprise Software Development Kit 12
  • libpoppler-devel >= 0.24.4-12.1
  • libpoppler-glib-devel >= 0.24.4-12.1
  • libpoppler-qt4-devel >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • typelib-1_0-Poppler-0_18 >= 0.24.4-12.1
Patchnames:
SUSE-SLE-SDK-12-2016-922
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpoppler-devel >= 0.24.4-12.1
  • libpoppler-glib-devel >= 0.24.4-12.1
  • libpoppler-qt4-devel >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • typelib-1_0-Poppler-0_18 >= 0.24.4-12.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-922
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpoppler44 >= 0.24.4-14.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libpoppler44
openSUSE Leap 42.1
  • libpoppler-cpp0 >= 0.24.4-12.1
  • libpoppler-cpp0-debuginfo >= 0.24.4-12.1
  • libpoppler-devel >= 0.24.4-12.1
  • libpoppler-glib-devel >= 0.24.4-12.1
  • libpoppler-glib8 >= 0.24.4-12.1
  • libpoppler-glib8-debuginfo >= 0.24.4-12.1
  • libpoppler-qt4-4 >= 0.24.4-12.1
  • libpoppler-qt4-4-debuginfo >= 0.24.4-12.1
  • libpoppler-qt4-devel >= 0.24.4-12.1
  • libpoppler-qt5-1 >= 0.24.4-12.1
  • libpoppler-qt5-1-debuginfo >= 0.24.4-12.1
  • libpoppler-qt5-devel >= 0.24.4-12.1
  • libpoppler44 >= 0.24.4-12.1
  • libpoppler44-debuginfo >= 0.24.4-12.1
  • poppler >= 0.24.4-12.1
  • poppler-debugsource >= 0.24.4-12.1
  • poppler-qt >= 0.24.4-12.1
  • poppler-qt-debugsource >= 0.24.4-12.1
  • poppler-qt5 >= 0.24.4-12.1
  • poppler-qt5-debugsource >= 0.24.4-12.1
  • poppler-tools >= 0.24.4-12.1
  • poppler-tools-debuginfo >= 0.24.4-12.1
  • typelib-1_0-Poppler-0_18 >= 0.24.4-12.1
Patchnames:
openSUSE-2016-745


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 GA poppler Released
SUSE Linux Enterprise BSK 12 SP1 poppler Released
SUSE Linux Enterprise Desktop 10 SP3 poppler In progress
SUSE Linux Enterprise Desktop 10 SP4 poppler In progress
SUSE Linux Enterprise Desktop 11 SP2 poppler Released
SUSE Linux Enterprise Desktop 11 SP3 poppler Released
SUSE Linux Enterprise Desktop 11 SP4 poppler Released
SUSE Linux Enterprise Desktop 12 GA poppler Released
SUSE Linux Enterprise Desktop 12 SP1 poppler Released
SUSE Linux Enterprise SDK 11 SP2 poppler Released
SUSE Linux Enterprise SDK 11 SP3 poppler Released
SUSE Linux Enterprise SDK 11 SP4 poppler Released
SUSE Linux Enterprise SDK 12 GA poppler Released
SUSE Linux Enterprise SDK 12 SP1 poppler Released
SUSE Linux Enterprise Server 10 SP3 poppler In progress
SUSE Linux Enterprise Server 10 SP4 poppler In progress
SUSE Linux Enterprise Server 10 SP4 LTSS poppler In progress
SUSE Linux Enterprise Server 11 SP1 LTSS poppler Released
SUSE Linux Enterprise Server 11 SP2 poppler Released
SUSE Linux Enterprise Server 11 SP2 LTSS poppler Released
SUSE Linux Enterprise Server 11 SP3 poppler Released
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Released
SUSE Linux Enterprise Server 11 SP4 poppler Released
SUSE Linux Enterprise Server 12 GA poppler Released
SUSE Linux Enterprise Server 12 SP1 poppler Released
SUSE Linux Enterprise Server for SAP 11 SP2 poppler Released
SUSE Linux Enterprise Server for VMWare 11 SP2 poppler Released
SUSE Linux Enterprise Server for VMWare 11 SP3 poppler Released