Upstream information

CVE-2015-8865 at MITRE

Description

The file_check_mem function in funcs.c in file before 5.23, as used in the Fileinfo component in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5, mishandles continuation-level jumps, which allows context-dependent attackers to cause a denial of service (buffer overflow and application crash) or possibly execute arbitrary code via a crafted magic file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entries: 974305 [RESOLVED / FIXED], 976994 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Already fixed
SUSE Linux Enterprise SDK 11 SP4 php53 Already fixed
SUSE Linux Enterprise SDK 12 GA php5 Already fixed
SUSE Linux Enterprise SDK 12 SP1 php5 Already fixed
SUSE Linux Enterprise Server 10 SP4 LTSS php5 Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Already fixed
SUSE Linux Enterprise Server 11 SP4 php53 Already fixed