Upstream information

CVE-2015-8833 at MITRE

Description

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 10 7.5
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
SUSE Bugzilla entry: 970498 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • pidgin-otr >= 4.0.0-8.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-523
SUSE Linux Enterprise Desktop 12 SP1
  • pidgin-otr >= 4.0.0-8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-523
SUSE Linux Enterprise Desktop 12 SP2
  • pidgin-otr >= 4.0.0-11.6
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA pidgin-otr
SUSE Linux Enterprise Desktop 12 SP3
  • pidgin-plugin-otr >= 4.0.2-1.29
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA pidgin-plugin-otr
SUSE Linux Enterprise Workstation Extension 12
  • pidgin-otr >= 4.0.0-8.1
Patchnames:
SUSE-SLE-WE-12-2016-523
SUSE Linux Enterprise Workstation Extension 12 SP1
  • pidgin-otr >= 4.0.0-8.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-523
SUSE Linux Enterprise Workstation Extension 12 SP2
  • pidgin-otr >= 4.0.0-11.6
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA pidgin-otr
SUSE Linux Enterprise Workstation Extension 12 SP3
  • pidgin-plugin-otr >= 4.0.2-1.29
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA pidgin-plugin-otr
SUSE Linux Enterprise Workstation Extension 15
  • pidgin-plugin-otr >= 4.0.2-1.61
  • pidgin-plugin-otr-lang >= 4.0.2-1.61
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA pidgin-plugin-otr
openSUSE Leap 42.1
  • pidgin-otr >= 4.0.2-7.1
  • pidgin-otr-debuginfo >= 4.0.2-7.1
  • pidgin-otr-debugsource >= 4.0.2-7.1
Patchnames:
openSUSE-2016-397
openSUSE Tumbleweed
  • pidgin-otr >= 4.0.2-1.5
Patchnames:
openSUSE Tumbleweed GA pidgin-otr


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 pidgin-otr Not affected
SUSE Linux Enterprise Desktop 12 GA pidgin-otr Released
SUSE Linux Enterprise Desktop 12 SP1 pidgin-otr Released
SUSE Linux Enterprise Workstation Extension 12 GA pidgin-otr Released
SUSE Linux Enterprise Workstation Extension 12 SP1 pidgin-otr Released