Upstream information

CVE-2015-8740 at MITRE

Description

The dissect_tds7_colmetadata_token function in epan/dissectors/packet-tds.c in the TDS dissector in Wireshark 2.0.x before 2.0.1 does not validate the number of columns, which allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) via a crafted packet.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libwireshark9 >= 2.4.6-1.31
  • libwiretap7 >= 2.4.6-1.31
  • libwscodecs1 >= 2.4.6-1.31
  • libwsutil8 >= 2.4.6-1.31
  • wireshark >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libwireshark9
SUSE Linux Enterprise Module for Desktop Applications 15
  • wireshark-devel >= 2.4.6-1.31
  • wireshark-ui-qt >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA wireshark-devel
openSUSE Leap 42.2
  • wireshark >= 2.2.1-1.1
  • wireshark-ui-gtk >= 2.2.1-1.1
Patchnames:
openSUSE Leap 42.2 GA wireshark
openSUSE Leap 42.3
  • wireshark >= 2.2.7-15.1
  • wireshark-ui-gtk >= 2.2.7-15.1
Patchnames:
openSUSE Leap 42.3 GA wireshark
openSUSE Tumbleweed
  • wireshark >= 2.2.2-1.1
  • wireshark-devel >= 2.2.2-1.1
  • wireshark-ui-gtk >= 2.2.2-1.1
  • wireshark-ui-qt >= 2.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA wireshark