Upstream information

CVE-2015-8390 at MITRE

Description

PCRE before 8.38 mishandles the [: and \\ substrings in character classes, which allows remote attackers to cause a denial of service (uninitialized memory read) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 957598 [NEW], 958373 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1744
SUSE-SLE-DESKTOP-12-SP1-2016-1827
SUSE Linux Enterprise Desktop 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1744
SUSE-SLE-DESKTOP-12-SP2-2016-1827
SUSE Linux Enterprise High Availability 12 SP1
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-HA-12-SP1-2016-1744
SUSE-SLE-HA-12-SP1-2016-1827
SUSE Linux Enterprise High Availability 12 SP2
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-HA-12-SP2-2016-1744
SUSE-SLE-HA-12-SP2-2016-1827
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE Linux Enterprise Server 12 SP1
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1744
SUSE-SLE-SERVER-12-SP1-2016-1827
SUSE Linux Enterprise Server 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1744
SUSE-SLE-SERVER-12-SP2-2016-1827
SUSE Linux Enterprise Server 12-LTSS
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-2016-1827
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1744
SUSE-SLE-RPI-12-SP2-2016-1827
SUSE Linux Enterprise Server for SAP Applications 12
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SAP-12-2016-1827
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1744
SUSE-SLE-SERVER-12-SP1-2016-1827
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1744
SUSE-SLE-SERVER-12-SP2-2016-1827
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libpcre1 >= 8.39-7.1
  • libpcre1-32bit >= 8.39-7.1
  • libpcre16-0 >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-SERVER-12-2016-1827
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpcrecpp0 >= 8.39-7.1
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
  • pcre-devel >= 8.39-7.1
  • pcre-devel-static >= 8.39-7.1
  • pcre-tools >= 8.39-7.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1744
SUSE-SLE-SDK-12-SP1-2016-1827
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpcrecpp0 >= 8.39-7.1
  • libpcreposix0 >= 8.39-7.1
  • pcre >= 8.39-7.1
  • pcre-devel >= 8.39-7.1
  • pcre-devel-static >= 8.39-7.1
  • pcre-tools >= 8.39-7.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1744
SUSE-SLE-SDK-12-SP2-2016-1827
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1744
SUSE-SLE-WE-12-SP1-2016-1827
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libpcrecpp0 >= 8.39-7.1
  • libpcrecpp0-32bit >= 8.39-7.1
  • pcre >= 8.39-7.1
Patchnames:
SUSE-SLE-WE-12-SP2-2016-1744
SUSE-SLE-WE-12-SP2-2016-1827
openSUSE Leap 42.1
  • libpcre1 >= 8.39-5.1
  • libpcre1-32bit >= 8.39-5.1
  • libpcre1-debuginfo >= 8.39-5.1
  • libpcre1-debuginfo-32bit >= 8.39-5.1
  • libpcre16-0 >= 8.39-5.1
  • libpcre16-0-32bit >= 8.39-5.1
  • libpcre16-0-debuginfo >= 8.39-5.1
  • libpcre16-0-debuginfo-32bit >= 8.39-5.1
  • libpcrecpp0 >= 8.39-5.1
  • libpcrecpp0-32bit >= 8.39-5.1
  • libpcrecpp0-debuginfo >= 8.39-5.1
  • libpcrecpp0-debuginfo-32bit >= 8.39-5.1
  • libpcreposix0 >= 8.39-5.1
  • libpcreposix0-32bit >= 8.39-5.1
  • libpcreposix0-debuginfo >= 8.39-5.1
  • libpcreposix0-debuginfo-32bit >= 8.39-5.1
  • pcre >= 8.39-5.1
  • pcre-debugsource >= 8.39-5.1
  • pcre-devel >= 8.39-5.1
  • pcre-devel-static >= 8.39-5.1
  • pcre-doc >= 8.39-5.1
  • pcre-tools >= 8.39-5.1
  • pcre-tools-debuginfo >= 8.39-5.1
Patchnames:
openSUSE-2016-1448
openSUSE Leap 42.2
  • libpcre1 >= 8.39-6.1
  • libpcre1-32bit >= 8.39-6.1
  • libpcre1-debuginfo >= 8.39-6.1
  • libpcre1-debuginfo-32bit >= 8.39-6.1
  • libpcre16-0 >= 8.39-6.1
  • libpcre16-0-32bit >= 8.39-6.1
  • libpcre16-0-debuginfo >= 8.39-6.1
  • libpcre16-0-debuginfo-32bit >= 8.39-6.1
  • libpcrecpp0 >= 8.39-6.1
  • libpcrecpp0-32bit >= 8.39-6.1
  • libpcrecpp0-debuginfo >= 8.39-6.1
  • libpcrecpp0-debuginfo-32bit >= 8.39-6.1
  • libpcreposix0 >= 8.39-6.1
  • libpcreposix0-32bit >= 8.39-6.1
  • libpcreposix0-debuginfo >= 8.39-6.1
  • libpcreposix0-debuginfo-32bit >= 8.39-6.1
  • pcre >= 8.39-6.1
  • pcre-debugsource >= 8.39-6.1
  • pcre-devel >= 8.39-6.1
  • pcre-devel-static >= 8.39-6.1
  • pcre-doc >= 8.39-6.1
  • pcre-tools >= 8.39-6.1
  • pcre-tools-debuginfo >= 8.39-6.1
Patchnames:
openSUSE-2016-1448


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 pcre Released
SUSE Linux Enterprise Desktop 12 SP2 pcre Released
SUSE Linux Enterprise High Availability 12 SP1 pcre Released
SUSE Linux Enterprise High Availability 12 SP2 pcre Released
SUSE Linux Enterprise SDK 12 SP1 pcre Released
SUSE Linux Enterprise SDK 12 SP2 pcre Released
SUSE Linux Enterprise Server 12 GA LTSS pcre Released
SUSE Linux Enterprise Server 12 SP1 pcre Released
SUSE Linux Enterprise Server 12 SP2 pcre Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI pcre Released
SUSE Linux Enterprise Workstation Extension 12 SP1 pcre Released
SUSE Linux Enterprise Workstation Extension 12 SP2 pcre Released