Upstream information

CVE-2015-8241 at MITRE

Description

The xmlNextChar function in libxml2 2.9.2 does not properly check the state, which allows context-dependent attackers to cause a denial of service (heap-based buffer over-read and application crash) or obtain sensitive information via crafted XML data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 4.3
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial None
SUSE Bugzilla entries: 956018 [RESOLVED / FIXED], 959469 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
Patchnames:
sledsp3-libxml2-20151221-12298
SUSE Linux Enterprise Desktop 11 SP4
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
Patchnames:
sledsp4-libxml2-20151221-12298
SUSE Linux Enterprise Desktop 12
  • libxml2 >= 2.9.1-13.1
  • libxml2-2 >= 2.9.1-13.1
  • libxml2-2-32bit >= 2.9.1-13.1
  • libxml2-tools >= 2.9.1-13.1
  • python-libxml2 >= 2.9.1-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-38
SUSE Linux Enterprise Desktop 12 SP1
  • libxml2 >= 2.9.1-13.1
  • libxml2-2 >= 2.9.1-13.1
  • libxml2-2-32bit >= 2.9.1-13.1
  • libxml2-tools >= 2.9.1-13.1
  • python-libxml2 >= 2.9.1-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-38
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-2-32bit >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libxml2-2
SUSE Linux Enterprise Desktop 12 SP3
  • libxml2-2 >= 2.9.4-45.1
  • libxml2-2-32bit >= 2.9.4-45.1
  • libxml2-tools >= 2.9.4-45.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libxml2-2
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-nokogiri >= 1.8.2-1.16
Patchnames:
SUSE Linux Enterprise High Availability 15 GA ruby2.5-rubygem-nokogiri
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.1-20160307082632
Patchnames:
SUSE-SLE-Module-Containers-12-2016-459
SUSE Linux Enterprise Server 11 SP3
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-doc >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
  • libxml2-x86 >= 2.7.6-0.34.1
Patchnames:
slessp3-libxml2-20151221-12298
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-doc >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
  • libxml2-x86 >= 2.7.6-0.34.1
Patchnames:
slessp4-libxml2-20151221-12298
SUSE Linux Enterprise Server 12
  • libxml2 >= 2.9.1-13.1
  • libxml2-2 >= 2.9.1-13.1
  • libxml2-2-32bit >= 2.9.1-13.1
  • libxml2-doc >= 2.9.1-13.1
  • libxml2-tools >= 2.9.1-13.1
  • python-libxml2 >= 2.9.1-13.1
Patchnames:
SUSE-SLE-SERVER-12-2016-38
SUSE Linux Enterprise Server 12 SP1
  • libxml2 >= 2.9.1-13.1
  • libxml2-2 >= 2.9.1-13.1
  • libxml2-2-32bit >= 2.9.1-13.1
  • libxml2-doc >= 2.9.1-13.1
  • libxml2-tools >= 2.9.1-13.1
  • python-libxml2 >= 2.9.1-13.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-38
SUSE Linux Enterprise Server 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-2-32bit >= 2.9.4-27.1
  • libxml2-doc >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libxml2-2
SUSE Linux Enterprise Server 12 SP3
  • libxml2-2 >= 2.9.4-45.1
  • libxml2-2-32bit >= 2.9.4-45.1
  • libxml2-doc >= 2.9.4-45.1
  • libxml2-tools >= 2.9.4-45.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libxml2-2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-doc >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libxml2-2
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-doc >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
  • libxml2-x86 >= 2.7.6-0.34.1
Patchnames:
slessp3-libxml2-20151221-12298
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-doc >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
  • libxml2-x86 >= 2.7.6-0.34.1
Patchnames:
slessp4-libxml2-20151221-12298
SUSE Linux Enterprise Server for SAP Applications 12
  • libxml2 >= 2.9.1-13.1
  • libxml2-2 >= 2.9.1-13.1
  • libxml2-2-32bit >= 2.9.1-13.1
  • libxml2-doc >= 2.9.1-13.1
  • libxml2-tools >= 2.9.1-13.1
  • python-libxml2 >= 2.9.1-13.1
Patchnames:
SUSE-SLE-SERVER-12-2016-38
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libxml2 >= 2.9.1-13.1
  • libxml2-2 >= 2.9.1-13.1
  • libxml2-2-32bit >= 2.9.1-13.1
  • libxml2-doc >= 2.9.1-13.1
  • libxml2-tools >= 2.9.1-13.1
  • python-libxml2 >= 2.9.1-13.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-38
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-32bit >= 2.7.6-0.34.1
  • libxml2-doc >= 2.7.6-0.34.1
  • libxml2-python >= 2.7.6-0.34.4
  • libxml2-x86 >= 2.7.6-0.34.1
Patchnames:
slessp3-libxml2-20151221-12298
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-devel >= 2.7.6-0.34.1
  • libxml2-devel-32bit >= 2.7.6-0.34.1
Patchnames:
sdksp3-libxml2-20151221-12298
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2 >= 2.7.6-0.34.1
  • libxml2-devel >= 2.7.6-0.34.1
  • libxml2-devel-32bit >= 2.7.6-0.34.1
Patchnames:
sdksp4-libxml2-20151221-12298
SUSE Linux Enterprise Software Development Kit 12
  • libxml2 >= 2.9.1-13.1
  • libxml2-devel >= 2.9.1-13.1
Patchnames:
SUSE-SLE-SDK-12-2016-38
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libxml2 >= 2.9.1-13.1
  • libxml2-devel >= 2.9.1-13.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-38
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2-devel >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libxml2-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libxml2-devel >= 2.9.4-45.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libxml2-devel
openSUSE 13.1
  • libxml2 >= 2.9.3-2.19.1
  • libxml2-2 >= 2.9.3-2.19.1
  • libxml2-2-32bit >= 2.9.3-2.19.1
  • libxml2-2-debuginfo >= 2.9.3-2.19.1
  • libxml2-2-debuginfo-32bit >= 2.9.3-2.19.1
  • libxml2-debugsource >= 2.9.3-2.19.1
  • libxml2-devel >= 2.9.3-2.19.1
  • libxml2-devel-32bit >= 2.9.3-2.19.1
  • libxml2-doc >= 2.9.3-2.19.1
  • libxml2-tools >= 2.9.3-2.19.1
  • libxml2-tools-debuginfo >= 2.9.3-2.19.1
  • python-libxml2 >= 2.9.3-2.19.1
  • python-libxml2-debuginfo >= 2.9.3-2.19.1
  • python-libxml2-debugsource >= 2.9.3-2.19.1
Patchnames:
openSUSE-2015-959
openSUSE Leap 42.1
  • libxml2 >= 2.9.1-10.1
  • libxml2-2 >= 2.9.1-10.1
  • libxml2-2-32bit >= 2.9.1-10.1
  • libxml2-2-debuginfo >= 2.9.1-10.1
  • libxml2-2-debuginfo-32bit >= 2.9.1-10.1
  • libxml2-debugsource >= 2.9.1-10.1
  • libxml2-devel >= 2.9.1-10.1
  • libxml2-devel-32bit >= 2.9.1-10.1
  • libxml2-doc >= 2.9.1-10.1
  • libxml2-tools >= 2.9.1-10.1
  • libxml2-tools-debuginfo >= 2.9.1-10.1
  • python-libxml2 >= 2.9.1-10.1
  • python-libxml2-debuginfo >= 2.9.1-10.1
  • python-libxml2-debugsource >= 2.9.1-10.1
Patchnames:
openSUSE-2016-32
openSUSE Leap 42.2
  • libxml2-2 >= 2.9.4-1.4
  • libxml2-2-32bit >= 2.9.4-1.4
  • libxml2-devel >= 2.9.4-1.4
  • libxml2-tools >= 2.9.4-1.4
Patchnames:
openSUSE Leap 42.2 GA libxml2-2
openSUSE Leap 42.3
  • libxml2-2 >= 2.9.4-10.1
  • libxml2-2-32bit >= 2.9.4-10.1
  • libxml2-devel >= 2.9.4-10.1
  • libxml2-tools >= 2.9.4-10.1
Patchnames:
openSUSE Leap 42.3 GA libxml2-2
openSUSE Tumbleweed
  • ruby2.2-rubygem-nokogiri >= 1.6.8.1-1.3
  • ruby2.2-rubygem-nokogiri-doc >= 1.6.8.1-1.3
  • ruby2.2-rubygem-nokogiri-testsuite >= 1.6.8.1-1.3
  • ruby2.3-rubygem-nokogiri >= 1.6.8.1-1.3
  • ruby2.3-rubygem-nokogiri-doc >= 1.6.8.1-1.3
  • ruby2.3-rubygem-nokogiri-testsuite >= 1.6.8.1-1.3
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-nokogiri


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 libxml2 Released
SUSE Linux Enterprise Desktop 10 SP4 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP1 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP2 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP3 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP4 libxml2 Released
SUSE Linux Enterprise Desktop 12 GA libxml2 Released
SUSE Linux Enterprise Desktop 12 SP1 libxml2 Released
SUSE Linux Enterprise SDK 11 SP2 libxml2 Released
SUSE Linux Enterprise SDK 11 SP3 libxml2 Released
SUSE Linux Enterprise SDK 11 SP4 libxml2 Released
SUSE Linux Enterprise SDK 12 GA libxml2 Released
SUSE Linux Enterprise SDK 12 SP1 libxml2 Released
SUSE Linux Enterprise Server 10 SP3 libxml2 Released
SUSE Linux Enterprise Server 10 SP4 libxml2 Released
SUSE Linux Enterprise Server 10 SP4 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP1 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP2 libxml2 Released
SUSE Linux Enterprise Server 11 SP2 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP3 libxml2 Released
SUSE Linux Enterprise Server 11 SP4 libxml2 Released
SUSE Linux Enterprise Server 12 GA libxml2 Released
SUSE Linux Enterprise Server 12 SP1 libxml2 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 libxml2 Released
SUSE Linux Enterprise Server for VMWare 11 SP2 libxml2 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 libxml2 Released