Upstream information

CVE-2015-8158 at MITRE

Description

The getresponse function in ntpq in NTP versions before 4.2.8p9 and 4.3.x before 4.3.90 allows remote attackers to cause a denial of service (infinite loop) via crafted packets with incorrect values.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
SUSE Bugzilla entries: 959243 [RESOLVED / FIXED], 962966 [RESOLVED / FIXED], 975578

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • ntp >= 4.2.8p6-46.5.2
  • ntp-doc >= 4.2.8p6-46.5.2
  • yast2-ntp-client >= 3.1.12.4-8.2
Patchnames:
SUSE-SLE-DESKTOP-12-2016-727
SUSE Linux Enterprise Desktop 12 SP1
  • ntp >= 4.2.8p6-8.2
  • ntp-doc >= 4.2.8p6-8.2
  • yast2-ntp-client >= 3.1.22-6.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-694
SUSE Linux Enterprise Desktop 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA ntp
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p10-63.3
  • ntp-doc >= 4.2.8p10-63.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA ntp
SUSE Linux Enterprise Module for Legacy Software 15
  • ntp >= 4.2.8p11-2.12
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA ntp
SUSE Linux Enterprise Server 11 SP2-LTSS
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
  • yast2-ntp-client >= 2.17.14.1-1.12.1
Patchnames:
slessp2-ntp-12561
SUSE Linux Enterprise Server 11 SP3-LTSS
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
Patchnames:
slessp3-ntp-12561
SUSE Linux Enterprise Server 11 SP4
  • ntp >= 4.2.8p6-8.2
  • ntp-doc >= 4.2.8p6-8.2
Patchnames:
slessp4-ntp-12533
SUSE Linux Enterprise Server 12
  • ntp >= 4.2.8p6-46.5.2
  • ntp-doc >= 4.2.8p6-46.5.2
  • yast2-ntp-client >= 3.1.12.4-8.2
Patchnames:
SUSE-SLE-SERVER-12-2016-727
SUSE Linux Enterprise Server 12 SP1
  • ntp >= 4.2.8p6-8.2
  • ntp-doc >= 4.2.8p6-8.2
  • yast2-ntp-client >= 3.1.22-6.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-694
SUSE Linux Enterprise Server 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ntp
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p10-63.3
  • ntp-doc >= 4.2.8p10-63.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ntp
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA ntp
SUSE Linux Enterprise Server for SAP Applications 11 SP2-LTSS
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
  • yast2-ntp-client >= 2.17.14.1-1.12.1
Patchnames:
slessp2-ntp-12561
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
Patchnames:
slessp3-ntp-12561
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ntp >= 4.2.8p6-8.2
  • ntp-doc >= 4.2.8p6-8.2
Patchnames:
slessp4-ntp-12533
SUSE Linux Enterprise Server for SAP Applications 12
  • ntp >= 4.2.8p6-46.5.2
  • ntp-doc >= 4.2.8p6-46.5.2
  • yast2-ntp-client >= 3.1.12.4-8.2
Patchnames:
SUSE-SLE-SERVER-12-2016-727
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ntp >= 4.2.8p6-8.2
  • ntp-doc >= 4.2.8p6-8.2
  • yast2-ntp-client >= 3.1.22-6.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-694
SUSE Linux Enterprise Software Development Kit 12
  • yast2-ntp-client >= 3.1.12.4-8.2
  • yast2-ntp-client-devel-doc >= 3.1.12.4-8.2
Patchnames:
SUSE-SLE-SDK-12-2016-727
SUSE Linux Enterprise Software Development Kit 12 SP1
  • yast2-ntp-client >= 3.1.22-6.2
  • yast2-ntp-client-devel-doc >= 3.1.22-6.2
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-694
SUSE Manager 2.1
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
Patchnames:
sleman21-ntp-12561
SUSE Manager Proxy 2.1
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
Patchnames:
slemap21-ntp-12561
SUSE OpenStack Cloud 5
  • ntp >= 4.2.8p6-41.1
  • ntp-doc >= 4.2.8p6-41.1
Patchnames:
sleclo50sp3-ntp-12561
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • yast2-ntp-client >= 2.13.18-0.20.1
Builds
ZYPP Patch Nr: 9295
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • ntp >= 4.2.8p8-0.7.1
  • ntp-doc >= 4.2.8p8-0.7.1
Builds
ZYPP Patch Nr: 9293
openSUSE Leap 42.1
  • ntp >= 4.2.8p6-15.1
  • ntp-debuginfo >= 4.2.8p6-15.1
  • ntp-debugsource >= 4.2.8p6-15.1
  • ntp-doc >= 4.2.8p6-15.1
  • yast2-ntp-client >= 3.1.22-6.1
  • yast2-ntp-client-devel-doc >= 3.1.22-6.1
Patchnames:
openSUSE-2016-578
openSUSE Leap 42.2
  • ntp >= 4.2.8p8-25.1
  • ntp-doc >= 4.2.8p8-25.1
Patchnames:
openSUSE Leap 42.2 GA ntp
openSUSE Leap 42.3
  • ntp >= 4.2.8p10-30.1
  • ntp-doc >= 4.2.8p10-30.1
Patchnames:
openSUSE Leap 42.3 GA ntp
openSUSE Tumbleweed
  • ntp >= 4.2.8p9-1.1
  • ntp-doc >= 4.2.8p9-1.1
Patchnames:
openSUSE Tumbleweed GA ntp


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 ntp Released
SUSE Linux Enterprise Desktop 11 SP3 ntp Released
SUSE Linux Enterprise Desktop 11 SP4 ntp Released
SUSE Linux Enterprise Desktop 12 GA ntp Released
SUSE Linux Enterprise Desktop 12 SP1 ntp Released
SUSE Linux Enterprise Server 11 SP1 LTSS ntp Released
SUSE Linux Enterprise Server 11 SP2 ntp Released
SUSE Linux Enterprise Server 11 SP2 LTSS ntp Released
SUSE Linux Enterprise Server 11 SP3 ntp Released
SUSE Linux Enterprise Server 11 SP3 LTSS ntp Released
SUSE Linux Enterprise Server 11 SP4 ntp Released
SUSE Linux Enterprise Server 12 GA ntp Released
SUSE Linux Enterprise Server 12 SP1 ntp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ntp Released
SUSE Linux Enterprise Server for VMWare 11 SP2 ntp Released
SUSE Linux Enterprise Server for VMWare 11 SP3 ntp Released