Upstream information

CVE-2015-8041 at MITRE

Description

Multiple integer overflows in the NDEF record parser in hostapd before 2.5 and wpa_supplicant before 2.5 allow remote attackers to cause a denial of service (process crash or infinite loop) via a large payload length field value in an (1) WPS or (2) P2P NFC NDEF record, which triggers an out-of-bounds read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 937419 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1351
SUSE Linux Enterprise Desktop 12 SP2
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA wpa_supplicant
SUSE Linux Enterprise Desktop 12 SP3
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA wpa_supplicant
SUSE Linux Enterprise Server 12 SP1
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1351
SUSE Linux Enterprise Server 12 SP2
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA wpa_supplicant
SUSE Linux Enterprise Server 12 SP3
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA wpa_supplicant
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA wpa_supplicant
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1351
openSUSE Leap 42.1
  • wpa_supplicant >= 2.2-8.1
  • wpa_supplicant-debuginfo >= 2.2-8.1
  • wpa_supplicant-debugsource >= 2.2-8.1
  • wpa_supplicant-gui >= 2.2-8.1
  • wpa_supplicant-gui-debuginfo >= 2.2-8.1
Patchnames:
openSUSE-2016-1104
openSUSE Leap 42.2
  • wpa_supplicant >= 2.2-8.2
  • wpa_supplicant-gui >= 2.2-8.2
Patchnames:
openSUSE Leap 42.2 GA wpa_supplicant
openSUSE Leap 42.3
  • wpa_supplicant >= 2.2-10.4
  • wpa_supplicant-gui >= 2.2-10.4
Patchnames:
openSUSE Leap 42.3 GA wpa_supplicant


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA wpa_supplicant Released
SUSE Linux Enterprise Desktop 12 SP1 wpa_supplicant Released
SUSE Linux Enterprise Desktop 12 SP2 wpa_supplicant Released
SUSE Linux Enterprise Server 12 GA wpa_supplicant Released
SUSE Linux Enterprise Server 12 GA LTSS wpa_supplicant Released
SUSE Linux Enterprise Server 12 SP1 wpa_supplicant Released
SUSE Linux Enterprise Server 12 SP2 wpa_supplicant Released